5029 Problems and Bugs


#1

5029 broke audio on my domain. My door not have sound.
The new script i worked stopped playing. This one.

(function()
{ 
    this.clickDownOnEntity = function(entityID, mouseEvent) 
    {     
        var soundurl = SoundCache.getSound("http://market.simsquaremetaverse.nl/sounds/dooropen_CCBY30_249573.wav");
        var soundvolume = 1.0;

        var Ent = entityID;    
        var copyEnt = Entities.getEntityProperties(Ent, ["position"]);
        var jsonEnt = JSON.stringify(copyEnt);
        var data = JSON.parse(jsonEnt);    
        var basepos = data.position;
        
        Audio.playSound(soundurl, { loop: false, position: basepos ,volume: soundvolume });
    }
}
)

Getting this error now as soon i play a sound.
[06/17 00:01:07] [DEBUG] AudioInjectorManager::threadInjector could not thread AudioInjector - at max of 40 current audio injectors.

And teleporting is very slow. playa did not really load. I cannot check everything because i cannot access my own server right now to. SInce build 5029 i have lot’s of problems.

Strange, sound worked again on my door. things seems recovered. Mabye something got flooded when i tried a new audio script. ! Nope things are still extreme slow or laggy My server cpu is doing nothing

Few minutes later, after fixing my door position because it got stuck. it’s playing sound. not moving the door now. hmm, mabye my door is broken. it moves once after i come from other domain. but it feels 5029 is doing weird things to

The above sound example works now.

Looks like after a sound flood with above error the connection get slow. It looks like high fidelity 5029 is in some cases flooding my connection i think.


#2

For some reason in HMD mode i always go back to 3rd person mode. very annoying.
Especially when the framerate is already bad on playa and HMD.