A Question about fbx geometry and Hi Fi domains


#1
  1. I made terrain + stuff and placed it in a domain. It looked OK.
  2. After hearing about less material switches is better, I made terrain and most everything all one object.
  3. I made changes to terrain and everything and it still looked good.
  4. Hi Fi announces change to textures. 1 to 8, max 2k. 8+ half etc. all of a sudden my terrain texture looked crappy.
  5. I stopped working on it for months because I would have to cut the terrain from the rest of the model and that was step backwards because I had made changes to everything since the last save when they were separated.
  6. Finally decided to spend time to fix it. Separated terrain from everything else and painted it with 2k texture, It looked OK.
  7. Added all the stuff I had removed and brought into Hi Fi as fbx, It looks OK in external programs. Autodesk, Blender, etc. But when I brought it into Hi Fi there were some major geometry issues.

Sort of the way it should look and the way it does look at one position:

The way it looks at original position:

This is the same fbx file, just at different places. The first is at 0,0,0, the second is at 8800 away.
I can understand why this might be happening, I’ve written 3d transform stuff and know limitations.

My question is:

Is it possible that by changing the origin / scale / rotation of each object when read from the fbx this could be avoided? I mean using the bounding box of the whole rather than the individual objects themselves could this be fixed?


#2

Usually the origin of objects in High Fidelity will be the center of the bounding box of the model, so changing this in the FBX wouldnt do a thing.

Generally speaking it is a good precaution to always, prior to export to make sure that the scale of the object is defaulted to 1:1, so that the dimensions would be its true dimensions.

When you start to work with values and distances after 2048, you start to have quite increasing amount loss of significance, and with large object it becomes more and more obvious the further you go from the center.

Not exactly sure on why this should effect geometry, as its only the placement of the entity, and only in scales that shouldnt really matter as much: I would have though the geometry placement would be more from where you are viewing them relative to the coordinate of the entity, not in the world, but what you show there, something similar to it does seem to happen.

So Right now unfortunately, I dont think anyone on these forums has a proper answer for this question if it can or cannot fix, because no one else is making big builds… even my Nexus is mainly focused on small little build areas with about a few kilometer or so difference…

Would probably need @Sam’s input on this.


#3

If I understand this thread it’s about the model moving as it gets bigger
I’d
I build land with a church in blender
Import it and it’s good
In hi-fi I sit a bird on the church tower

Then I go back into blender add a second building. Export it all again
Replace the model in hi-fi
And the bird which hasn’t moved no longer sits on the tower

Hifi ignores blender origin points
It’s really annoying

In cromptonmoor I put a massive invisible box around the entire blender build to hold the location constant but it’s a hacky solution


#4

The Center of Bounding box issue is easier to solve: You can basically fix this by setting the Entity registration point in High Fidelity (aka, the bounding box generated center) to 0,0,0. By default this is set to always be 50%, 50%, 50% (as in the very center of the bounds of the geometry) of the bounding box of the model. Setting it to 0, will always calculate the position by its lowest corner of the bounding box, making it consistant to always start from the corner, instead of moving as the model is modified.

Setting the registration point to 0 in all directions allows it to remain static regardless of what you do with the model. as long as the lowest point remains consistant. Unfortunately, shifting this will also shift the model, so its best done before you start doing any modifications, and moving the model around to its final position.

This way, if you update the model, and the bounding box changes, it will not move around, unless you start moving the lowest corner around.


32

You can also simulate this in blender, by going to bounding box mode. But i dont think thats the issue @Twa_Hinkle is experiencing, Sounds more like geometry shifting.


#5

When I woke up this morning I was thinking about this problem and thought about when I had seen things similar to this before.

It was when I had changed scale or rotation in HiFi but not in all dimensions.

I think that is what happened to me now. I did not realize I had slightly changed the dimensions which then screws up the rotations or something like that.

So, oops, never mind.

Thanks for the help guys. I’ll just tip toe back to doing what I do best: learning from my mistakes.


#6

Doesn’t even have to be a box. I just create 4 tiny unconnected triangles around the build to serve as the “points” of the box. The bounding box and origin is calculated from this just the same, and since they’re tiny and far away, users will never notice them.

I really wish we didn’t have to do hackish things like this just to have everything aligned properly.