All my textures are going black after load completes (solved..?)


#1

Just started playing around again after my hiatus, and running everything on 127.0.0.1, latest GIT, Debian/Testing, QT5.7. ATI OS drivers. (Just on spec, I tried with QT5.6 too but same deal :disappointed:)

When I start up the interface, everything (avatar from Mixamo, mesh from Marketplace, cube created locally) flashes briefly with its colour/texture as it loads then goes black.

Popped across to another (external) domain for a moment and had same issue.

…

Above: Ready to host MST3K


#2

Satellite of love ?

Have u reset to default settings. Did u say it’s doing this everywhere other domains and stuff?


#3

I’d been encountering the same thing recently - once in a while looked OK but more often that not displayed dark, too.
This seems to have been fixed in recent dev builds for me (e.g., build 5400 but possibly earlier).


#4

A completely fresh install with all prefs folders (in /.local/share, /.config and .interface deleted).
Latest Git build from head/master as of the time/date of this posting. If I am reading GIT right, that is RELEASE-5402.

Yes, I picked a few random destinations from the location menu and experienced the same at those locations.

The textures are definitely loading as I can see them for a fraction of a second when the load-bar tops-out, then they go black again.


#5

Hmm. Kept fiddling with things and finally discovered if I turn shaddows ON textures show up.
(It is still pretty dark, but I assume that is a lack of local lights).


…
Another random external location:

My avatar is a bit washed out. It is loaded directly from a Mixamo download so I am not sure if that is a PBR issue???
…
And loading a skybox into my local server from marketplace:

Provides the needed global illumination.


#6

I only see problems at times with skyboxes / zones that not load or stay black after teleport or enter it. It random and relog fix it. But relog is not what you want.