An Alternative Entities Editor


#81

Noticed a bug.

If I assign an angular velocity of 1 to an object, then duplicate it by shift/drag,

The resulting copy has an angular velocity of 57.3

So we’re back to degrees being converted back to radians.

You might have to do the conversion in the script to compensate for this.


#82

Thanks, @Adrian … I’m on it!


#83

Release 0.1.8-57:

  • Fixed shift-duplicating not setting correct angular velocity or key light direction values.
  • Made save dialog position and size settings only once have stopped moving and resizing.

#84

Double clicked on name, not sure why :open_mouth: But this happend. It did select to much.

It did happen when i clicked the last row, model field.


#85

That looks like a text select of much of the (Web) page’s text. Seems to happen if you double-click in some parts of the dialog. I might be able to do something about it; will see. Thanks.


#86

Release 0.2.0-62 - Undo & Redo:

  • Adds undo/redo support: multi-level; Ctrl-Z to undo & Ctrl-Y to redo.
    Note: Undoing the deletion of an entity with children assumes that all the parent entity’s children were in the local copy of the domain model in Interface on your computer, i.e., are or have been in your view so that they’ve been “downloaded”. *
  • Report an error when can’t add, edit, or delete an entity.
  • Fix zone entity being added at too high an elevation.
  • Revisit key press handling.

[*] There’s currently no way in High Fidelity of guaranteeing a complete list of all an entity’s children and their properties. However, this is being considered as a feature in High Fidelity’s long-term roadmap.


#87

Release 0.2.1-64:

  • Limit stretching entities to minimum non-negative dimensions.
  • Add “grabbable”, “triggerable”, and “ignore IK” form fields.
  • Fix some spurious null edit history items.
  • Fix undo when editing a field messing up field value.

#88

Release 0.3.0-66 - Cut, Copy, & Paste:

  • Add cut, copy, and paste of entities with Ctrl-X, Ctrl-C, and Ctrl-V. Including entities with children. [1]
  • Add shift-drag duplication of entity with children.
  • Add copy and paste (“C” and “P”) buttons for copying triple values such as dimensions and colors.
  • Add import and import from URL menu items. Supports importing multiple entities, including entities with children. [2]
  • Add export menu item. Supports exporting entity with children. [2]
  • Fix double keyboard events after automatically opening editor window for import from market place.

Undo and redo work with all the above.

[1] The Windows alternatives of Shift-Del, Ctrl-Ins, and Shift-Ins also work in place of Ctrl-X, Ctrl-C, and Ctrl-V respectively.

[2] Work-around to avoid the annoying Interface HMD menu appearing when you use the Alt key for these menu items’ shortcuts: instead of pressing Ctrl then Alt then the letter for the shortcut, press Alt first then Ctrl then the letter.


#89

Release 0.3.1-67:

  • Add “static mesh” collision shape type.
  • Fix behavior of compound collision shape field values.

#90

CTRL-E seems to have it’s own life.
It sometimes not respond on the key after reloading my own default scripts.
Another reload fix it. but it keeps weird.

Edit, it did happen again today. ctrl-e did not respond at all. and i clicked on the world screen. Again a complete reload of default scripts fixt it. Now only the question how do i break it. Must be soemthing with switching between desktop / vive and using 2 edit tools.


#91

I’ve noticed the same thing, sometimes ctrl-e doesnt open it, something gets hooked up somewhere and if I push a few keys it eventually works.


#92

Thinks of new any difficult things to add to edit js

What about find and replace find and replace all
use case
my lamps yes those again
I need to change them all to a different url say they are all in www.dropbox/lamp and i want to change them all to www.github/lamp

That might be useful?


#93

Re Ctrl-E: I’ve had a few instances of keyboard shortcuts in general not working (e.g., Ctrl-J) recently but haven’t managed to reproduce yet. … To help track down, when it happens to someone again: does Ctrl-J (open Running Scripts dialog) work? Try pressing and releasing the Shift key on its own; does that fix it? Ditto for Alt and Ctrl keys. Try giving an application other than Interface focus then give Interface focus again by clicking on the window’s title.

Re lamps: My evil plans include being able to address that scenario.


#94

Hi @ctrlaltdavid, Shift key is not working for me in this case, but Alt. Alt and followed Ctrl-E brings it back. If ALT is pressing again, Ctrl-E is not longer working until I press Alt again… Hope that helps, thanks for your great work and support :slight_smile:


#95

Think bigger. Along with creating primitive shapes like sphere and dodecahedrons, let’s have terrain button, castle, tree, alligator, etc.


#96

I believe that may have been a bug I introduced, but I also believe it should be fixed in the beta build currently being tested.


#97

That hasnt worked for me at all using this release, hopefully the fix @Jherico mentioned cures that too.


#98

Thanks very much for all the comments.

  1. I’ve found and have a fix (not published yet) for a small “funny” were Ctrl-E didn’t close the dialog “immediately” after you opened it. … Probably not what people have been noticing.
  2. If the editor window has focus and a field in it has focus then Ctrl-E doesn’t work. This is intentional but perhaps not very nice; I’ll have a think about this. (It’s tried up with Ctrl-Z/Ctrl-Y actions when a field has focus.) … Could be part of what people have been noticing.
  3. If the Interface window has focus and you press and release the Alt key, then Ctrl-E doesn’t work, until you press and release the Alt key a couple more times. This shortcut comes (or should come) via the shortcut set for the menu item but the Menu.menuItemEvent events aren’t making their way to the script after pressing and releasing the Alt key.

@Jherico Re item 3: This happens (event stops being sent to script) on build 5086 and the latest source. If you keep pressing Ctrl-E the after a few key presses you start getting the following in the program log: [WARNING] QAction::eventFilter: Ambiguous shortcut overload: Ctrl+E (These warnings aren’t issued normally.)

Note: Ctrl-J to open the Running Scripts dialog seems to be working fine for me, both the release and latest builds, whether or not I’ve pressed the Alt key.


#99

Release 0.3.2-68:

  • Work around Interface bug wherein the spherical translation handles have stopped rendering. (Temporarily use cubes instead.)

#100

Hello @ctrlaltdavid, Since the last update of your alternative editor, the crossfade are no longer behind an object. I guess I read somewhere, that was a bug and it’s fixed now. Unfortunately now it is much harder to center the crossfade to a object, in my case the street lamps. Before this fix, it was easy to find the center of the light bulb, now it is very difficult. The lamps are part of the walkway and not a single object. Is it maybe possible to give an option if someone want the crossfade in front or behind an object? Here a two pics - they show the same just from different views.