Assignment Client Script Basics


#1

Hey all.
Very exciting: I’m trying to run an Assignment Client Script on my Stack Server for the very first time.
I’ve tried using the included rain.js example. I’ve uploaded it to my server, added it into the Stack Server settings, restarted everything, but my Stack Server log shows this over and over:

No response to UDP hole punch pings for node…

And I see no rain (or new entities) in my Domain (using Localhost). I’m pretty convinced it’s not running, but besides the Stack Server logs, I’m not sure how to check.

I’ve tried this on Mac 10.10.5 and Windows 7 (x64) with today’s latest and greatest Interface and Stack Server.
Same error in the logs.
I’ve also tried with a registered Place Name location.
Is there something I’m not doing that must be done?
Thanks for any help!


#2

By the way, in my StackManager logs, the standard error reads:

hifi.embeddedwebserver: Attempting to bind TCP socket on port "40100"
hifi.embeddedwebserver: TCP socket is listening on QHostAddress( “0.0.0.0” ) and port 40100
hifi.networking: Asynchronously looking up IP address for hostname “ice.highfidelity.io” - lookup ID is 1

Domain Server logs are quiet. The Assignment Client log keeps repeating the above error over and over in addition to the following:

[10/25 13:45:32] [DEBUG] [12888] [asset-server] Killed “Agent” (I) {4389c340-72c7-4849-8c0a-a2f050b61b87} 104.35.60.203:53865 / 192.168.0.7:53865
[10/25 13:45:32] [DEBUG] [12888] [asset-server] Added “Agent” (I) {4389c340-72c7-4849-8c0a-a2f050b61b87} 104.35.60.203:53865 / 192.168.0.7:53865
[10/25 13:45:32] [SUPPRESS] [12890] [agent] 199 repeated log entries matching “Packet of type \d+ ([\sa-zA-Z:]+) received from unknown node with UUID” - Last entry: “Packet of type 3 (PacketType::Ping) received from unknown node with UUID bbfd5287-0863-4651-9561-731fb05184b5”
[10/25 13:45:32] [DEBUG] [12890] [agent] Packet of type 3 (PacketType::Ping) received from unknown node with UUID bbfd5287-0863-4651-9561-731fb05184b5

Anyone have ANY thoughts that might help lead me to a resolution?
Thanks.


#4

Hey @Twa_Hinkle! I don’t know why your post was withdrawn because IT WORKED!
That ambient sound script is running as expected, despite the continuation of all the errors above!
Thank you! I’m going to use it as a starting point for my experiments.


#5

Then maybe you could ask him to repost it? @Twa_Hinkle shed some light on this topic. Thanks.


#6

Opps, didn’t see this, I withdrew it because I should have just posted the script as text. And then realized that without the valid sound URL, it would not really be a working example.

It may just be that the rain script you were trying to use is broken now, I’ve not looked at it in a long time. Also, I think the problem you are seeing in the logs may have nothing to do with the AC.

If people really want me to post the script I will. I’ve been using it and other AC scripts for months now and they seem to work well.