Audio device selection re-enabled in Windows build 1807


#1

Audio device selection has been re-enabled in Windows build 1807 in the Tools > Audio menu. It was previously disabled some time ago because it caused crashes when Interface was using an older Qt version, but it should be OK now.

If anyone has any problems, please let me know.


#2

Not sure if this problem appears because this or because interface.exe But i noticed now twice that interface.exe is crashing at the point its trying to work with audio.

Build 1836


#3

Hi @Richardus. From the looks of it, it’s crashing for you at start-up? But only sometimes?

What version of Windows are you running? And 32 or 64-bit?

Can you reliably produce the crash somehow?


#4

I think the crash is unrelated to audio: https://worklist.net/job/20284


#5

@ctrlaltdavid Sadly no, the crash is sofar random. Keeping eye on it when its crashing.
Using windows 7 64bit The worklist sounds pretty close with what happend today here.
Did startup/shutdown 10 times but it did not appear.

Other thing i see is that interface.exe is crashing if you quit it to fast after you logged in.
between, connecting to region and appearing of the appartment building i can crash interface.exe sometimes

add: it seems around startup nr. 15 it crashed at the same point as the above screenshot

[DEBUG] [01/28 19:18:56] [VERSION] Build sequence:  1836
[DEBUG] [01/28 19:18:56] First call to Menu::getInstance() - initing menu.
[WARNING] [01/28 19:18:57] QObject::connect: No such slot Application::changeVSync()
[DEBUG] [01/28 19:18:57] AccountManager URL for authenticated requests has been changed to https://data.highfidelity.io
[DEBUG] [01/28 19:18:57] Found a data-server access token for https://data.highfidelity.io
[DEBUG] [01/28 19:18:57] input  device: “Line-In (Sound Blaster X-Fi Xtr”
[DEBUG] [01/28 19:18:57] Starting worker thread to generate 2048-bit RSA key-pair.
[DEBUG] [01/28 19:18:57] DEBUG [ “Line-In (Sound Blaster X-Fi Xtr” ] [ “Line-In (Sound Blaster X-Fi Xtr” ]
[DEBUG] [01/28 19:18:57] Logging activity “launch”
[DEBUG] [01/28 19:18:57] The default audio input device is “Line-In (Sound Blaster X-Fi Xtr”
[DEBUG] [01/28 19:18:57] The audio input device  “Line-In (Sound Blaster X-Fi Xtr” is available.
[DEBUG] [01/28 19:18:57] The desired format for audio I/O is QAudioFormat(24000Hz, 16bit, channelCount=1, sampleType=SignedInt, byteOrder=LittleEndian, codec=“audio/pcm”)
[DEBUG] [01/28 19:18:57] The desired audio format is not supported by this device
[DEBUG] [01/28 19:18:57] The format to be used for audio input is QAudioFormat(48000Hz, 16bit, channelCount=1, sampleType=SignedInt, byteOrder=LittleEndian, codec=“audio/pcm”)
[DEBUG] [01/28 19:18:57] Created Display Window.
[DEBUG] [01/28 19:18:57] output  device: “Speakers (Sound Blaster X-Fi Xt”
[DEBUG] [01/28 19:18:57] Status: Using GLEW 1.10.0

[DEBUG] [01/28 19:18:57] V-Sync is ON

[DEBUG] [01/28 19:18:57] Initialized Display.
[DEBUG] [01/28 19:18:57] DEBUG [ “Speakers (Sound Blaster X-Fi Xt” ] [ “Speakers (Sound Blaster X-Fi Xt” ]
[DEBUG] [01/28 19:18:57] The default audio output device is “Speakers (Sound Blaster X-Fi Xt”
[DEBUG] [01/28 19:18:57] The audio output device  “Speakers (Sound Blaster X-Fi Xt” is available.
[DEBUG] [01/28 19:18:57] The desired format for audio I/O is QAudioFormat(24000Hz, 16bit, channelCount=2, sampleType=SignedInt, byteOrder=LittleEndian, codec=“audio/pcm”)
[DEBUG] [01/28 19:18:57] The desired audio format is not supported by this device
[DEBUG] [01/28 19:18:57] The format to be used for audio output is QAudioFormat(48000Hz, 16bit, channelCount=2, sampleType=SignedInt, byteOrder=LittleEndian, codec=“audio/pcm”)
[DEBUG] [01/28 19:18:57] Output Buffer capacity in frames:  3
[DEBUG] [01/28 19:18:57] Oculus SDK 0.4.2
[DEBUG] [01/28 19:19:01] Trying to go to URL “hifi://alpha/575.423,14.1962,1526.79/3.67216e-06,0.0181569,-2.1159e-05,0.999835”
[DEBUG] [01/28 19:19:01] Loaded settings
[DEBUG] [01/28 19:19:01] Faceshift: Connecting…
[DEBUG] [01/28 19:19:01] Sending intial stun request to stun.highfidelity.io
[DEBUG] [01/28 19:19:01] init() complete.
[DEBUG] [01/28 19:19:01] Startup time: 5.43 seconds.
[DEBUG] [01/28 19:19:01] QHostInfo lookup result for “stun.highfidelity.io” with lookup ID 1 is “54.67.22.242”
[DEBUG] [01/28 19:19:02] Generated 2048-bit RSA key-pair. Storing private key and uploading public key.
[DEBUG] [01/28 19:19:02] Total time to generate stars:  15.5652  msec
[DEBUG] [01/28 19:19:02] Total time to retile and generate stars:  45.0484 msec
[DEBUG] [01/28 19:19:02] Changing face model for avatar to “http://public.highfidelity.io/models/heads/ron.fst
[DEBUG] [01/28 19:19:02] Changing skeleton model for avatar to “http://public.highfidelity.io/models/skeletons/ron_standing.fst
[DEBUG] [01/28 19:19:02] Changing display name for avatar to “Richardus”
[WARNING] [01/28 19:19:02] QObject::connect: Parentheses expected, signal QThread::started
[DEBUG] [01/28 19:19:02] DEBUG [ “Line-In (Sound Blaster X-Fi Xtr” ] [ “Line-In (Sound Blaster X-Fi Xtr” ]
[WARNING] [01/28 19:19:02] QSystemTrayIcon::setVisible: No Icon set
[DEBUG] [01/28 19:19:02] Created QT Application.
[DEBUG] [01/28 19:19:02] The audio input device  “Line-In (Sound Blaster X-Fi Xtr” is available.
[DEBUG] [01/28 19:19:02] The desired format for audio I/O is QAudioFormat(24000Hz, 16bit, channelCount=2, sampleType=SignedInt, byteOrder=LittleEndian, codec=“audio/pcm”)
[DEBUG] [01/28 19:19:02] The desired audio format is not supported by this device
[DEBUG] [01/28 19:19:02] The format to be used for audio input is QAudioFormat(48000Hz, 16bit, channelCount=2, sampleType=SignedInt, byteOrder=LittleEndian, codec=“audio/pcm”)


#6

I believe that @samcake has a fix for the crash (is unrelated to audio). Hopefully will be in a build soon.


#7

Hi Guys,
I just pushed a fix
the crash is somehow coming up from a bad skeleton initialization before it’s even loaded…
i just cleaned the values to avoid the crash.

ALso just so you know, i pushed a big change on the texture loading to GL last week and we are seeing several issues poping up that i ll do my best to fix asap… :slight_smile:
Cheers

S