Audio issues with realteck audio card


#1

For some reason audio is playing though my computers case speaker and not my normal speakers. I cant seem to figure out how to switch output devices in highfi


#2

Make sure under running scripts the defaultscript.js is loaded.

Windows: go to the menu option tools , then go to audio. there you can select the input and output device.


#3

my tools window never loads it’s a solid white window
ok for some reasion defaultscrip.js is not showing in my list of running scripts.
I do not see a copy of it stored anywhere in my hifi folder and when I try to load it from http://highfidelity-public.s3-us-west-1.amazonaws.com/scripts/defaultScripts.js it fails to load im runing build 2328 as it was marked latest should i downgrade to 2327 or wait for 2329 fo get published?


#4

I managed to get the default script to load from https://raw.githubusercontent.com/highfidelity/hifi/master/examples/defaultScripts.js the output selector only listed the one output as for some reason in windows both have the same name so was just easier to go to my audio playback devices and disable the one i do not want to use.
I found the better solution then disabling the audio output in windows simply rename the audio output in the sound control panel so something like case speaker and presto the hifi audio output switcher is seeing both outputs now.