Audio Mixer Problems (2015 version)


#1

Continuing the discussion from Meetup: Our regular Friday meetup will be moved to Monday:

On local echo, I hear myself with no delay and no dropouts. On server echo I hear myself with some delay, 150ms, but no dropouts. Same results with jitter buffers enabled or disabled. With or without audio noise reduction, no dropouts. With audio noise reduction it mutes (as expected) when low threshold level is reached. but my problem wsn;t sending, it was receiving the stream.

My backhaul is sprint-net San Jose. tracert to the stun server is <28ms, to the HF WEB site <30ms.

[edit]
I tried this on InMotion (server on my local network), Spiritmoving (server in the same computer), then the HF sandbox, and HQ places. It all worked the same - very well. Then I realized in all those cases my local audio mixer was probably chosen, so I took down my two domains. And then in sandbox and hq, I saw the ping times rise to 115+ms, and also experienced those long dropouts.

@chris, in the video you can hear me commenting to you on the setup. My audio was working mostly OK at that point, but as more people arrived audio fell apart for me quickly. Not sure what on my end could have caused that since the audio mixer at/near HQ is supposed to deliver a steady audio stream, hence mix together the audio streams of all sound sources and avatars present. At the last two meetups I attended I did not have this problem.

Running the task manager to view network activity, I saw the incoming bandwidth at 1.5 to 2.0Mb/sec, which given the number of people there was nominal. So, where do you think the breakups were happening?

I don’t want this problem to just be forgotten. If HF cant deliver decent audio to everyone, then it’s missed an important goal.


#2

Am curious what packet size high fidelity is useing for voice. i would say 1500. but mabye it’s different.

@Balpien_Hammere skype and other voice like sl works fine ?
Is the log ctrl-shift-L showig some intressting messages ?


#3

Skype, Zoom, Go2Meeting all work just fine audio and video.
In the last two meetup visits, sound was mostly OK, some choppiness on occasion.
In yesterday’s meetup everything was fine too when I arrived early. You can hear me in the vid @chris made. Then it fell apart badly.
About an hour ago, I went to the sandbox to test server loopback and sound was completely OK. Was speaking to someone there, all OK.
Then I went to HQ to test loopback mode there, and the audio problem persists. Had a chat with a new person there, very choppy, 1/2 second drop outs every few seconds.
Tried it between two computers running interface connected to a domain in my local network, that too OK.

All that suggests to me whatever audio mixer HQ is connected to has a problem.

[DEBUG] [07/07 14:24:33] Added “Audio Mixer” (M) {1153b419-e629-4f82-b98f-c92d6128e20f} 54.215.97.188:60560 / 10.249.135.145:60560


#4

Looks like no one in HF is interested in this problem, so I took it upon myself to do further analysis. http://testmy.net is a site that offers UDP bandwidth testing. Here are their results on my net connection:

UDP Average Download Speed: 6.4 Mbps
Current Download Speed Index: Info 12.7 Mbps
Your Average Download Speed: 9.4 Mbps - 3 results averaged

The variance throughout the test was low, so this suggests the dropout problem is not on my end.

I trace routed the audio mixer my interface was attached to when in HQ/meetup to an amazon AWS virtual server. I recommend you check it out, it’s having problems.


#5

Just tested audio between myself in California and another person in South Carolina. We visited HQ, Sandbox, Free, Café, InMotion, and Qwhimsy. All worked fine except HQ. In HQ we both were getting multi-second long dropouts.