Autodesk FBX converter broke (suggestions for new one?). Time that high fidelity get .blend support


#1

Still fighting with my new mixamo avatar. I have it now correct as DAE file. But now autodesk fbx converter is on strike. And i do not see any logic in this error.

I checked my process list triple. did a system restart. i uninstalled the 32bit and reinstalled a new downloaded 64bit version. It’s still a fail.

Now i where never happy with the autodesk FBX converter, because the font is so tiny that you need to go 10cm from the screen to keep it readable. So is there any suggestion for othr FBX converter ? One that can convert dae / obj to fbx. No maya is expensive and not readable font. same with some other grood progrtams that always have a design error with font sizes.

Unless someone can tell me why the FBX exporter is doing strange things in blender. Only see in FBX review the shoe texture and that is applied on the whole avatar.

Think it’s time that high fidelity add .blend support. I think that would solve lot’s of problems for people. Again everything i try except my last mesh building seems always to get in trouble because bugs or missing functions. I think blender have more VR users then maya

Or DAE support, that seems to work fine with the avatar and FBX preview. Problem with dae is that the file size get bloated to the extreme. from 12MB to 140MB. Now that is really bad.


#2

To simplify, just use the Blender FBX export with the latest version of blender. Its been working fine for the year or so Since 2.77. Everything I make is with that without using a converter.


#3

@menithal, it’s not working with exporting the fuse avatar. i lose the texters from

  • hat
  • top
  • bottom
  • skin

the get replaced for the shoe texture. shoes seems fine. And i do not see anything wrong. And nobody seems to tell or know what go wrong.

Yes fbx export works fine if you made the mesh in blender.


#4

For the fuse avatars there is a couple of things related to what can cause it:

A. Texture Names having periods
B. Material Names having periods

This was detailed in the post I made to an issue you were having earlier

with an example of this issue being:
https://forums.highfidelity.com/uploads/highfidelity/_optimized/3bc/1cc/1ece799de8_690x427.jpg
When you embed the textures / materials into the fbx, instead of keeping it separate.

However that information is very much historical, and things may have changed. Could you send me your avatar so I can take a peek? Because I very much think it still is the same issue.


Mixamo avatar -> blender -> export fbx = wrong texture
#5

Mine is looking like this. (FBX previewer)
Tried it to export without armateur. but the result is the same.

This are my export settings.

I do not see any names with a dot. looks like mixame not use it anymore.
mixamo version is 2015.1.0. Every object have it’s own single UVmap .
And yes i use blender 2.78a as soon it came out.

As soon am exporting more then one object. the texture of the first object get assigned to the other object to.

Nothing todo with dot’s in the names.


#6

Can you send me the fbx? I’ll check it once I get home because I have not yet bumped into the issue ever since the last time

And I’ve done 6 avatars, from various sources (mixamo, scratch, Maya, zbrush) now so I know blender works fine.


#7

You have PM now with the download link.


#8

You are correct, the textures are just fine

Aside from the glossiness making it look like he was dunked in oil, the avatar works just fine.
I dont really know what exactly might be causing that issue for you? I do skip the autodesk converter entirely and just do it in blender.

Ill record what I do to import it so you can compare and see if there is something you do differently. It would be good to document.


#9

Thanks.

Only thing i did is remove the eyelashes. mabye that is the problem now i think about it. AT the other side i do not see why that would create problems with exporting.

Yes the shine i removed in bledn er. That are just settings.


#10

This is flow I used to do it.
(sorry for the font size)

Import was default blender fbx:

Most of the time, I just click on the texture just to load it from the fbx embed, when first loading it in blender (it will be pink).
Having the material window open while clicking parts will load up the embedded texture. I also did some minor tweaks to lessen the glossiness.

Also usually I just clean up the avatar to pose mode, but that usually shouldnt be needed.

export was semi default, but with embedded textures.


#11

I go try it soon. but it sounds almost the same workflow as what i did.
Ill check the video first. Just done a straight forward in blender. no changews nothing. And that works.

Going to eat my virtual shoe ! :grin:

Tried it again with removing the eylashes. It still works.

Now this feels a bit. :scream: Not see what is different now.
Trying to remove the glow etc. later.
Anyway. Thanks again.

Foxes, the are so smart ! :slight_smile: