Avatar animations and shineyness?


#1

Okay, so I’m quite proud of myself so far! I’ve managed to clean up, convert, and with the help of that mixamo thingie rig the mesh avatar I made for myself on SL / OS into something that looks like it’ll work on HiFi. But so far I’m left with two minor little glitches that to seem to be leaving me somewhat baffled.

First off (probably the easy one), in Blender how one Earth do you tone down the specular so things don’t look like they’re coated in oil once brought into HiFi? Each of my materials is using Phong with an intensity of 0.2 and a hardness of of 2 which renders just about perfect in Blender but comes out WAY too strong on the HiFi end.

Second, how exactly do you add animations to the avatars? So far I’ve sent it up to Mixamo and packed it with the walk / fly / run / idle animations that I like and from there I downloaded the pack which gave me a big mess of fbx files, each which seems to contain the armature loaded up an animation. Now how do I tell HiFi to use those animations instead of the default robot ones that really don’t work well at all with this shape. :smiley:


#2

Hey to stop the shiny you need to change the specular color to black in the materials color picker window
its completly white by default


#3

As @judas mentioned, bring down the specular to about 1/10 of the value you would normally use, maybe even less. Having a white will cause it to be much more refl

Because Hifi is supposively using PBR based rendering the Specular value of the reflect light, with the default assumption that the roughness for all objects is fully smooth and reflective (but not metallically).

Since we cant export the PBR settings, such as roughness into FBX, only diffuse, specular, binary glow, normal and transparency are supported with models we bring in…

Animations on the other hand have to be applied to through the animations window, through the animation overrider json or through a script.

However, as of this moment I have no idea where to find them with the changes to placement of settings window.


#4

Thanks @Judas and @Menithal! That pretty much solved the specular problem where my guy looked like he’d just been swimming in a vat of baby oil. As for the animations, after poking through every menu of the interface and quickly browsing through the source files I can’t find any mention of an animations window. I was able to do a little bit of tinkering with the json file, but with some rather glitchy results. I’ll have to pummel at it some more later today when I have more time.

:slight_smile:


#5

So, I updated and now all of a sudden the default animations are working just fine. Yay! I love it when things seem to magically fix themselves! Thank you mysterious and wonderful developer gnomes! :slight_smile: I still want to tinker with loading up animations.json with the ones I chose from Mixamo, but first I think I’ll just enjoy being myself in HiFi for the night. :smiley: