Avatar is deforming oddly


#1

The 1 year anniversary of my joining HiFi is coming up so I thought I’d make a new avatar to celebrate. I made myself a new penguin, a blue one this time with a cartoonier look (kinda inspired by Linux’s Tux.) This is how it looks in Blender, with the standard avatar rig from Menithal.


But when I import it into HiFi, the lower half of the body (from the waist down) seems to be twisting and animating wrong. It looks odd even when standing still, BTW.
Untitled

I did not modify the bone rotations of Menithal’s armature at all (edit: forgot I rotated the feet. Could that be the culprit?). All I did to the bones was translate and scale.

Is there anything that is known to cause this? I’m gonna try Mixamo’s rigging again in a bit but I’d rather not touch that as my past experiences with it have been horrible.

P.S. Yes my texture isn’t loading either for some reason, but I’ll worry about that later.


#2

I looks like a bone in the lower body, like the *Leg has rotated quite extensively in the base skeleton. Fixing that should solve it. If you use Axes from the Armature settings, the bones should have their relative Z axis pointing forward or up.


Also have you tried using the improved version of the skeleton with the example model?
http://norteclabs.com/HF/avatar/TestAvatar/LeanDummy/LeanDummy.fbx


#3

Thank you, that LeanDummy skeleton actually fixed the animation issue. I just replaced the old rig with that one. The bones now move correctly in HiFi.

Now I have a new problem. My avatar is falling through the floor. If I press W to walk, I suddenly climb up very high, like I’m flying. Here’s a GIF that I just recorded:
https://drive.google.com/uc?id=0B96e8tz1yUmUZ1hzaW15NEN1RzA

Is this something collision related? Maybe I just need to modify the shape of the feet. I feel like I’m super close to getting this thing working now, at least.


#4

This looks like some scaling issue. did you make sure the skeleton and mesh are correctly scaled?


#5

Developer > Render > avatar collision hull

Screen shot the black capsule result here.


#6

Yeah, make sure the toe bones are sticking out of the foot mesh a little on the bottom…


#7

Thanks guys, the issue above was a scale issue after all.

As for the texture, Flame and some others took a look at it and got it working in-world. Not even entirely sure what they did, but it works now.

It seems to be rendering fullbright though, even though I never added an emissive map and Emit is set to 0. But at least it mostly works now.

Hopefully someday a material editor gets added so we can just adjust textures/material values after import and fix stuff like this.


#8

Did you check my blender materials tutorials and check the values and use jpg/PNG?


#9

The issue was no intensity on the diffusion map. As soon as it was enabled (and set to 1), all of it worked out.