(Basic Outline Only) How to compile HiFi in Ubuntu 14.04 Again


#11

I compile hifi at a VPS with Ubuntu 14.04 and it runs since weeks stable.

  1. I install:
    sudo apt-get install screen git build-essential cmake libssl-dev libsdl2-dev libasound2 libxmu-dev libxi-dev freeglut3 freeglut3-dev mesa-common-dev unzip zlib1g-dev
    sudo apt-get install libudev-dev libxslt1.1 libpulse0 libgstreamer0.10-0 libgstreamer-plugins-base0.10-0 libicu52 libxcomposite1 -y
    sudo apt-get install libasound2 libxmu-dev libxi-dev libasound2-dev libjack-dev libxrandr-dev
    sudo apt-get install qt5-default qtscript5-dev qttools5-dev libqt5xmlpatterns5
    sudo apt-get install qtmultimedia5-dev libqt5svg5-dev libqt5webkit5-dev libsdl2-dev libqt5xmlpatterns5-dev qttools5-dev-tools

  2. I install with XMing gt5.4.1 with the path /usr/local/opt/Qt5.4.1/:
    chmod u+x qt-opensource-linux-x64-5.4.1.run
    ./qt-opensource-linux-x64-5.4.1.run

  3. I run compile:
    git clone https://github.com/highfidelity/hifi.git
    mkdir compile
    cd compile
    cmake …/hifi/ -DQT_CMAKE_PREFIX_PATH=/usr/local/opt/Qt5.4.1/5.4/gcc_64/lib/cmake/
    make assignment-client
    make domain-server

  4. I start hifi
    cd compile
    cd domain-server
    screen -S stack -d -m ./domain-server
    cd …
    cd assignment-client
    screen -S assign -d -m ./assignment-client -n 4


#12

thanks but it is compiling fine, running stable however is a different issue, I just completed the compile on a 15.10 server and am having the same issues described on the 14.04 server, actually more issues even, since i can’t even connect to the web interface,

and i got a warning this time while compiling which i’ve never seen pop up before:

in member function ‘virtual void 
OctreeInboundPacketProcessor::processPacket(QSharedPointer<NLPacket>, SharedNodePointer)’:
/usr/local/src/highfidelity/hifi/assignment-client/src/octree/OctreeInboundPacketProcessor.cpp:156:47: warning: format ‘%hhu’ expects argument of type ‘int’, but argument 3 has type ‘PacketType’ [-Wformat=]
                         packet->pos(), maxSize);
                                               ^
/usr/local/src/highfidelity/hifi/assignment-client/src/octree/OctreeInboundPacketProcessor.cpp:193:104: warning: format ‘%hhu’ expects argument of type ‘int’, but argument 3 has type ‘PacketType’ [-Wformat=]
                     packetType, packet->getPayload(), packet->getPayloadSize(), editData, packet->pos());
                                                                                                        ^
/usr/local/src/highfidelity/hifi/assignment-client/src/octree/OctreeInboundPacketProcessor.cpp:210:71: warning: format ‘%hhu’ expects argument of type ‘int’, but argument 3 has type ‘PacketType’ [-Wformat=]
         qDebug("unknown packet ignored... packetType=%hhu", packetType);

I really can’t help thinking someone has stuffed up the code somewhere, (though please feel free to prove my hunch wrong)


#13

Hi summer, thanks for that step by step tutorial. Point 1 - works fine.

I am not very experienced with server software setup, can you explain how to do to install with XMING, your second point? I’ve jumped to /usr/local/opt/Qt5.4.1 (the opt and Qt5.4.1 directory was created by me) and tried to chmod u+x qt-opensource-linux-x64-5.4.1.run but just get this error message back: chmod: cannot access ‘qt-opensource-linux-x64-5.4.1.run’: No such file or directory.

So I guess, the installation with XMING works somehow different :confused:


#14

Hey there @Skimi, I am not sure if you have figured this out yet but you need Qt 5.5.1 now to run HiFi. If you still need help with some Linux stuff feel free to hit me up in SL, my name is Coal Edge. You can also send me a message here but I saw by your info you are in SL too.


#15

Hi @Coal thanks for your answer :slight_smile: - very appreciate it. I still stuck at point 2 (all steps in point 1 was done without an error message). Would be great if you can explain how I get this Qt 5.5.1 installed - for dummies

About SL - I am not very active there anymore. Would be cool, if we can stay here in touch.


#16

Click on a person’s name. You will get the following pop up. Next, click on the message button to send a direct message to that person:


#17

Without a good text chat in HiFi, and me liking real time chat to explain things more in depth than doing PMs back and forth, it was the best option I thought but any way you wish to do is fine.

Anyhow, installing Qt depends a lot on your configuration, what else is installed, what versions they are etc. If you want to start fresh with installing it on a VM or something dedicated, I suggest this method which is HiFi compiled, as long as it is Ubuntu 14.04 with a fresh install:

Step 1:
apt-get install software-properties-common

Step 2:
add-apt-repository "deb http://debian.highfidelity.com stable main"

Step 3:
apt-get update

Step 4:
apt-get -y --force-yes install hifi-qt

Step 5:
apt-get -y --force-yes install hifi-domain-server

Step 6:
apt-get -y --force-yes install hifi-assignment-client

Configuration files are found in the /.local and /.config folders (under the root directory)
These would be /.config/High\ Fidelity/ and /.local/share/High\ Fidelity/

You can control the services with
service hifi-domain-server restart/stop/start and service hifi-assignment-client restart/stop/start


#18

Hi @Coal, thank you, that works :slight_smile: - and it was easy! Thank you so much!


#19

Hi Balpien - oh yes, I knew that - sorry if you felt annoyed about that posting, thanks anyway :slight_smile:


#20

Annoyed? Not at all. How did you get that impression?

The instructions for DM is simply because there is not IM facility here, nor is there any meaningful and standardized local chat in domains. About the only way to stay in touch is either post here in the forums or do direct messages.

Welcome, and enjoy!


#21

I was needed to install my server today, and tried now to install HF on my vServer (Ubuntu14.04 fresh install) - followed these 6 Steps, but I don’t get the webinterface running.

Maybe something it has changed and this installation guide is outdated?


#22

@Skimi

Not outdated totally, just need to change the version of qt since their install of qt5.6.1 is not registering correctly and right now it is just easier to tell it to install qt-5.5.1 right now.

if you already have it installed run apt-get remove hifi-qt

next:

where it says apt-get -y --force-yes install hifi-qt
use apt-get -y --force-yes install hifi-qt=5.5.1 for now

NOTE: you may have to reinstall hifi-domain-server and hifi-assignment-client again


#23

You made my day! Thank you so much @Coal , that works :slight_smile:

Sometimes I think, I am just not smart enough for HF.


#24

You are welcome and this is why its a community and we help each other!


#25

I have updated the instructions a bit since HiFi has updated their repo to Qt 5.6.1 and you need to manually tell setup the library directories

Step 1: apt-get -y install software-properties-common

Step 2: add-apt-repository "deb http://debian.highfidelity.com stable main"

Step 3: apt-get update

Step 4: apt-get -y --force-yes install hifi-qt

Step 5: echo "/usr/local/Qt5.6.1/5.6/gcc_64/lib" >> /etc/ld.so.conf

Step 6: ldconfig

Step 7: apt-get -y --force-yes install hifi-domain-server

Step 8: apt-get -y --force-yes install hifi-assignment-client


Domain server at Ubuntu 16.04.1 LTS
#26

It works, thank you @Coal


#27

I’ve installed the latest dev-build, and that forced me to update the linux server. So I did the step 1 to step 8 from your last posting here again. The server is starting, just not the assignment client.

It seems, it always stop by itself - but, I am really a noob in that stuff…

Not sure, maybe they changed something on the other side and @Coal 's last how-to is outdated again? Or maybe I did something wrong?

Thanks for help :slight_smile:
Skimi


When you feel lost
#28

@Skimi

No, they changed something in the requirements for the server now.

At first I found

./assignment-client: error while loading shared libraries: libquazip5.so.1: cannot open shared object file: No such file or directory```

Which I used `http://software.opensuse.org/download.html?project=home%3Aolav-st%3Aubuntu-universe&package=libquazip5-1` this to fix it.

After that I still get QT errors so until I can play more with it later, or someone else wants to do more research... its broken.

#29

Peering back after my first year of software design at college! There’s a Repo for Hifi now? i tried this haphazardly on my desktop (Mint) but getting apt issues

Unpacking hifiqt5.6.1 (5.6.1) …
dpkg: error processing archive /var/cache/apt/archives/hifiqt5.6.1_5.6.1_amd64.deb (–unpack):
trying to overwrite ‘/usr/local/Qt5.6.1/5.6/gcc_64/translations/qt_help_uk.qm’, which is also in package hifi-qt 5.6.1
dpkg-deb: error: subprocess paste was killed by signal (Broken pipe)
Selecting previously unselected package hifi-domain-server.
Preparing to unpack …/hifi-domain-server_515_amd64.deb …
Unpacking hifi-domain-server (515) …
Processing triggers for ureadahead (0.100.0-16) …
ureadahead will be reprofiled on next reboot
Errors were encountered while processing:
/var/cache/apt/archives/hifiqt5.6.1_5.6.1_amd64.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)

Will try this on a clean Debian VM soon though! any pointers/low beams i should be aware of? i’ve been out of the loop for a number of months and i can see there’s been lots of changes since.


#30

@Ronnie and @Skimi

I am about to post instructions on how to install it on Ubuntu 16.04 LTS in a little bit, its not a repo but it tells how to compile it yourself which is good for now since the releases arent as often as the dev ones.

I found out that the hifi installation builds its own version of libquazip5 which I may just package up and let others use it to help make this work again since the current compiled builds do not package that like it should.

I am more focused on getting 16.04 working for now.