Beta 20 Oops Oops Oops


#1

Ok, i still have problems to make my latest mesh visible (beta 19 and 20) But sicne beta 20 i cannot look in the log anymore. It get spammed with,

[09/06 20:49:04] [WARNING]     updateModel(ModelPointer,QString,QString)
[09/06 20:49:04] [WARNING] QMetaObject::invokeMethod: No such method EntityTreeRenderer::updateModel(ModelPointer,const QString&)
[09/06 20:49:04] [WARNING] Candidates are:
[09/06 20:49:04] [WARNING]     updateModel(ModelPointer,QString,QString)
[09/06 20:49:04] [WARNING] QMetaObject::invokeMethod: No such method EntityTreeRenderer::updateModel(ModelPointer,const QString&)
[09/06 20:49:04] [WARNING] Candidates are:
[09/06 20:49:04] [WARNING]     updateModel(ModelPointer,QString,QString)
[09/06 20:49:04] [WARNING] QMetaObject::invokeMethod: No such method EntityTreeRenderer::updateModel(ModelPointer,const QString&)
[09/06 20:49:04] [WARNING] Candidates are:
[09/06 20:49:04] [WARNING]     updateModel(ModelPointer,QString,QString)
[09/06 20:49:04] [WARNING] QMetaObject::invokeMethod: No such method EntityTreeRenderer::updateModel(ModelPointer,const QString&)
[09/06 20:49:04] [WARNING] Candidates are:
[09/06 20:49:04] [WARNING]     updateModel(ModelPointer,QString,QString) 

This on localhost sandbox.

Deleted the mesh that did not rezz. The error is gone for now.
But i still have complete invisble mesh. and in the log it seems to load fine.

The error is back again ?

[09/06 21:08:54] [WARNING] QMetaObject::invokeMethod: No such method EntityTreeRenderer::updateModel(ModelPointer,const QString&)
[09/06 21:08:54] [WARNING] Candidates are:
[09/06 21:08:54] [WARNING] updateModel(ModelPointer,QString,QString)

It happens with ATP after i placed object and sometimes i need to update the object with ?v=… (because we still not have a reload button) Interfface beta 20 is going wonky on the ATP url when you want to reload the model.

Back on beta 19, i can at least reload the old way. But my mesh is still invisible. arrgh, version mismatch with other domain. back the bad beta 20

The above error happens also when you just replace old url for new url. Not nice in challange.


Beta Release 20
#2

The running scripts are big improvement now. Easy to find the script you add.