Beta Release 26


#1

Release Notes:

  • more conservative texture memory budget to prevent swapping on lower end video cards
  • fixes to script agents for avatars and audio
  • update help window to auto select xbox or vive controller tab on availability of device
  • centered HUD/toolbar (you can unlock this and move it freely by going to Settings/General)
  • use snapshot data from file
  • fix a couple of minor polyvox problems
  • fix autoresize of Entities.addEntity() and fix Quat.lookAtSimple()
  • fix a network protocol bug related to model-entity joints
  • allow assignment client scripts to create ATP assets
  • fix the reported amount of GPU memory physically available for GPU with video mem larger than 4gb
  • add smooth turning support to tutorial
  • add “High Fidelity” to sandbox and interface description in Windows Task Manager
  • changed old interface icon with new interface icon
  • installer now launches the interface on installation after the content is loaded
  • fix tutorial tracking wentToEntry if you haven’t finished the tutorial
  • fix for crash-on-shutdown related to audio devices
  • fix broken eyes in mirrored animations
  • fix a bug that could cause obj textures to be flipped around the wrong way
  • log spam cleanup
  • deactivate hand controllers when not in HMD
  • fix some crashes
  • redundant and obsolete mute icons removed from audio meter

HOTFIX 11/7/2016: Disable Sandbox auto-update popup when the application is running from Steam.


#2

I cant run this release, I get
error opening file MSVCP120.dll

Windows 7 Pro


#3

Adrian - were you able to run beta 25?


#4

Yes, no probs there.


#5

Adrian - can you try the v5638 from dev-download and see if that runs for you?


#6

We’ve tested the installer on Win7 and it is working for us. We also include the MS C++ redistribution installer with our installer, which includes that DLL… Adrian, can you try to do a clean install? Uninstall and then re-run the latest installer.


#7

Yes, clean install has solved this for me.

Thank you


#8

You guys are funny, installed the older version. just updated and i can update again because 25 versions behind :smiling_imp: Please update the version on the download link.

Also is it possible to stop asking if i want to update the content on the server to a newer one when i did already say no to it versions before. It’s just a pit for trouble. You can bet once you going to click the wrong button.

Or mabye is there option to check if the content is anyway present on the sadnbox before asking ? Or just say that there’s new content and then you can select update content inm the tray menu of the sandbox ?

Ok, now build 5654.

The sandbox installation . (sandbox only on the server) gives me this error after installation.

When i click the old desktop icon, it’s straight into a dang ! Trying a clean installation.

Add: Reinstallion after uninstall. It create the same window ! Clicking the desktop icon is send me again straight into a dang ! So, my domain is down until this is fixt ! @ZappoMan you got the 2 dangs send, without comments (sorry)

Build 5629 did install and start fine. before i installed the new version 5654


#9

Oh wait, it’s working now. let me check soemthing. I think interface did install more then i wanted and i clicked interface instead of the sandbox. That is what you get when you uninstall it complete.

Oops.

Anyway, interface got installed on the wrong account to ! I can doub le check it now i need to uninstall and reinstall it.

That explains the error when it tried to stgart interface automatic. I hate settings like start it automatic after installation. You get results like this.

Well removed high fidelity, put it back again doubnle checked it only install the sandbox. And where back to error 1

So i did it right, something else is wrong.
Lucky i can start the sanmdbox by clicking the icon on the desktop, so it’s solved for now.


#10

Richardus, I just checked your "Dang!"s – and those are crashes in the OpenGL Version checker… (we shouldn’t crash) – but I’m curious… what video card/os are you running… and did you say, that machine is now running ok? Did you say the crash occurred when you had installed as admin?


#11

It’s a pile or errors @ZappoMan
For somereason the installer did select to put the sandbox icon on the desktop
I fixt that with the last installation, i could anyway not uncheckl the installation of interface.
The installer only gave me option for the sandbox to untick. interface.exe where greyed out, but checked ! (error, i need to have that unchecked on the server)

After the last try the installer came still with the last error. But i could start sandbox manual. It’s this error that the installer created at the end.

Ohh, wait. why does high fideltiy try to start sandbox from the admin account ?
That’s the problem. It’s looking at the wrong location.

Need to note that sandbox still get installed also under the other administrator account i still not want it there. for now i only see the icon. need to check with next windows update and reboot if it is doing iligale start on the admin account to.

@ZappoMan It’s a windows server, there’s no real openGL support and remote desktop for sure not support that really.

No i always install high fidelity as user. But high fidelity still wants it as admin. i talked about that with @clement


#12

Ah - so wait… you’re installing this on a remote windows machine? A server only? That would explain it…


#13

Yes @zappoman,. i do install this for months on remote server (sandbox only)


#14

ok - that explains it. I’ve added some bugs to our bug tracking system to allow install of sandbox alone.

We changed that in Beta 26… clearly we hadn’t considered this case.

The crash is from sandbox launching interface. It should only do that on “first run of sandbox after install”… subsequent runs of sandbox do not attempt to launch interface.


#15

“Work done for today” :grin:


#16

I just had an openGL error when I updated. see my Dang comments.

Other issues with this version:

  1. Why did the mute mic button disappear from the volume level meter? Is this the intended design?.. the only way to I can see to mute your mic now is by going to the Audio menu and then muting it?
    (edited because I was told it was moved to the Hud bar but it does not show up for me, probably because I use a custom set of defaultScripts.js).

  2. (edited to remove question about unlocking the HUD button) and how can I turn off the full width Hud thing when nothing is showing? In desktop mode, the wide Hud button thing makes the stats unreadable if at the top. In HMD mode, why would I want a big wide thing like that in the field of view?

  3. What has changed in the address bar domain list? I see domains listed that have no one on them but some domains, including mine, do not show up on the list even if I type in the whole name, unless I am already at the domain of the placename I type. It would be nice to have a detailed description of the way the address bar works, rather than have to try to figure it out each time it changes. Also, the snapshots overwhelm the list. There are many many snapshots of Welcome, good times etc. that you must scroll through to get to any domain that lists any people on them.

I thought we were not going to have any “November surprises”


#17

Were you installing sandbox on a headless server?

Correct, this is intended design, the HUD mute button indicates mute stats and so the old mute icon was redundant.

For other people’s benefit, we’ve enabled on Settings > General… the ability to lock/unlock the movement of the HUD.
The reason we moved the HUD to the center of the screen is for ease of use for novice users, we’ve found that that placement is easier for most new users.

We’re still working on fine tuning the ranking system for places to discover.

We gotta keep things interesting right?


#18

If by “headless server” you mean did I just download the server and not interface. No, I’ve always downloaded both. I just never run interface on that machine any more and have not for close to two years because it does not have a monitor and stuff connected to it.

I still would much rather have the mute button where it was before. It was available when the Hud button was not active and showed up when I use modded and other scripts.

I tried to add mute.js to my setup but it does not seem to add the button or do anything and I’m wondering if the ToolBars function has changed. (not sure what “com.highfidelity.interface.toolbar.system” is). Bottom line is: it is not redundant for me if I can’t see the new one.

After being told about the lock/unlock setting for the Hud button, the only thing that I still do not like is the width when not populated with your default buttons. It might be nice to have that expand only when a new button was added, etc.

Last but not least. All of my placenames do not show up in the address bar when no one is there, while other people’s do. I wonder if they show up at all for anyone even if I am there. Even if I type in the whole placename, no picture etc. shows up at all.

You may be “fine tuning the ranking system” but my question was how did this get released in the first place? I suspect that this code is HiFi server side, not anything that I can look at. I’d like to see how my placesnames somehow failed some test.


#19

Sounds like you run headless server.

Just a dedicated system you mabye access with remote
desktop and the system have mabye a poor graphics card.

In my case the headless server is inside datecenter.
Not suitable to run interface. It can only run sandbox etc.


#20

If building from source and wanting to match apples-to-apples – with the hot-fix Beta Release 26 Includes up to Developer Release 5667 now right?