Beta Release 40


#1

HOTFIX 40.1 Gathering stats on user launch to get better visibility into tutorial usage

A bunch of tweaks and fixes for you in Beta Release 40! You should see this update go live in the next hour or so. Here we go:

  • Avatars can walk up steps! :open_mouth:
  • Minor handshake improvements
  • Minor handshake script update
  • Fix lookAt eye snapping
  • Fix unreachable eye blink code
  • Avoid floating point error when generating fake mouth shapes
  • Moved the Vive Tracker configuration to actions into the Vive controller plugin
  • Fix the PAL not showing user info for user who opened PAL
  • Improve robustness of display name focus in PAL
  • Implement a script to hand-raise while in desktop mode
  • Desktop users of different height can shake hands
  • Fix the Twitter @mention reference in Snapshots
  • Snapshots: Fix case when user story would be incorrectly deleted
  • Prevent another GIF from being captured while one is processing
  • Ensure snapshots without story_ids get uploaded
  • Fix avatar mouth movement when driven by audio loudness
  • Update WASAPI audio plugin for Qt5.6.2
  • Cleanup Audio background threads on shutdown
  • Fix crackle in local audio
  • Fix randFloat error in ac audio searcher
  • Audio source sync
  • Close audio device when switching outputs
  • Fix issue when loading recording file into the input recorder
  • Fix avatar recording playback mouth not moving
  • Fixed input recorder crash
  • Fix recording playback not clearing attachments and nametags
  • Fix erroneous “did not start playing recording” messages
  • Fix OBJ model load hang
  • Use new images in api/v1/users response json
  • Enable the PAL to update data about a single connection
  • Added the ability to choose Vive Tracker configuration from the general settings
  • HMD now routes through the Vive input plugin
  • Fixed Vive Tracker sorting issue and added debug
  • More stable IK when hips, feet and chest are controlled via external input
  • Better handing when the Vive Trackers lose tracking and OpenVR still sends you a “valid” data
  • Change Vive Tracker Calibration Time from 2 sec to 1 sec
  • Hand controller lasers work better in thirdPerson camera mode.
  • Fix crash in texture transfer logic
  • Fix possible corruption of KTX cache files
  • Fix progressive loading of KTX cubemaps
  • Add protections when accessing the mip bytes of a texture when provided from a KtxStorage
  • Fix KTX image size in progressively loaded cubemaps
  • Add an internal tool for domain/model/skybox KTX texture baking
  • Fix potential crashes when loading invalid KTX cached textures
  • When you are in HMD and you go to File->Menu->Quit, it should no longer give you no menus when you come back
  • Add launch.tester to user_actions
  • Audience applause meter
  • Modified StretchTool to allow for movement in 3D
  • Fix tablet showing up for a short period of time on launch
  • Fix for multiple settings dialogs
  • Lock in Overlays::findRayIntersectionInternal
  • Animate scroll of partially visible cards
  • Avoid crash in glTextureSubImage2D
  • Implemented chat interface script and tablet web page
  • Don’t send avatars to previous lookup on server restart
  • Misc action/constraint changes
  • Added floating lantern box that spawns floating lanterns
  • Add the ability to duplicate an object with hand controller
  • Marketplace crash fix
  • Fix crash in sit script
  • cleanup Head::simulate() code
  • Fix the default skybox texture
  • Use baked default skybox
  • Remove unnecessary assert in Model.cpp
  • Clean up children of deleted avatar-entity
  • Fix the Face Camera checkbox on the text entity properties tab.
  • TriangleSet optimizations - ~80% improvement in Ray picking against models
  • Add domain to record script user activity logging
  • Launch the Sandbox as early as possible
  • Set max packet per second on the agent
  • Send smoothed orientation from a local client when a snap-turn is done across the network so all remote agents don’t see the snap.
  • Add function findEntitiesByType
  • Cleanup Actions and Constraints part-1
  • Fix suppress request constraint log spam
  • Remove extraneous calls to sendIdentityPacket()
  • Enable Map/List storage in the settings (more here)
  • Switch from timestamp to sequence id for avatar identity
  • Fix domain settings not getting cleared on re-assignment

#2

on my shop domain i have an atp entity keeps going massive white and wrong looking
if i clear my cache it goes back to normal
when i re log it breaks again

Experimenting with this it seems that models using way 2 big textures 4k kinda thing yes i dont need textures that big but there they were lol seem to fail when uploaded to atp in a way they dont when hosted on the s3 servers. Knows that hifi is suppose to re sample textures and stuff so assume its breaking on oversized ones


#3

Not really improvements. It only got more problematic.

For some reason High Fidelity not load my domain when i login there.
Ending in some void. I need o type the domain name now every time to get there.
It seems not to happen always, after you did once Teleported to your domain it works. Until the next day i think and it breaks.

I better stop thinking it cannot get any worse. Because it can !

ADD: Seems to happen if steamVR where not running and did start it hidden without permission of the user. If steamVR is running it seems to load the domain and connect. But when your not connected to the domain you not get connected if steamVR where started before by interface until you goto to your domain.

I did know it where a bad idea to upgrade.

ADD: It just not connect at startup and login at startup.
Only after a teleport it’s connecting. After a teleport it’s connecting fine.
Until you kill SteamVR manual because high fidelity is not doing that. (still a bug it get started) I just triued the test on empty. and it’s doing what i describe. Not connecting if steamVR where killed or not running. :rage:


#4

@Richardus.Raymaker, was getting this yesterday 2 along with alotta people , as i understand it its being looked at


#5

I just tried beta 39. but the devs done soemthing because you never can downgrade or interface is crashing. Am still not understand how the call this software beta.


#6

Thought beta meant it was unfinished and liable to having bugs


#7

Yes beta can have bugs, and is not finished.
But it’s still more in a state with User Interface and everything that it’s still more alpha then beta. Priority’s are for around 15 months already on the wrong things.


#8

Looks like audio is also broken in beta 40 to. I have no audio at all.

There’s also a conflict between the menu bar audio (it does not show any selected input device) and what the audio options menu say if you click the audio button. (shows correct info)

Before people start to scream: moving interface.json to otehr palce and restart high fidelity clean does not fix audio problems. So, it’s not a config problem. (moving quick the good config back now :grin:)


#9

Help with Update
For the first time, the Mac update is smooth as butter, but I cannot use the update on my PC.

  1. Every time I log in, it tells me I am unconnected on my own domain. The only way to fix this is to use a landmark to elsewhere, and then come back to Franny.
  2. My audio does not work at all. Any setting related to audio (input/output device) is greyed out. Muting and unmuting the mic does nothing.
  3. Most of the time, I have to use the Task Manager to log out.

I see others on, so I assume I am doing something wrong?
I did update Windows to the new creator thingie. Could that be it?

Thanks.


#10

You do nothing wrong.
Beta 40 is just a pile of troubles.

I need to telport to the domsin i already be on but beta 40 does not connect. And audio is complete broken and not working. But i can logout the normal way. But need to kill the hidden started SteamVR stuff in task manager everytime after logout. I told steamvr to not start.


#11

Have to admit, letting SteamVR start HiFi is a hit and miss for me. Sometimes it is flawless (except for starting in my sandbox - I always get the message on the tablet that says it isn’t available, so I click OK and hit the Home icon, and… ta-da!), sometimes it crashes relentlessly when I try to change audio inputs. I’m on Win10 Home - the only way audio works for me is to unplug and plug in the USB connection before running anything - SteamVR or HiFi, test audio input and output within Windows properties, then launch SteamVR or HiFi from the desktop. At that point, SteamVR will always pick it up and most likely pass these settings on to HiFi. If I start HiFi from the desktop, audio may never kick in. Not sure why.