Beta Release 65


#21

This still doesnt actually say what a material is, what type of resource should the URL point to? a texture or some other thing? (It doesnt appear to be an image because I tested that). There doesnt seem to be any way of exporting a material from blender.


#22

The “materialURL” property can be either (a) a URL to a “MaterialResource”, or (b) the string “userData” in which case the content of the userData property is used as the MaterialResource.

The MaterialResource is a JSON object per: http://ctrlaltstudio.com/downloads/hifi-dev/jsdoc/global.html#MaterialResource

The “materials” property of the MaterialJSON object is either a “Material” JSON object or an array of them per: http://ctrlaltstudio.com/downloads/hifi-dev/jsdoc/global.html#Material

There are some test scripts that apply different types of material properties to spheres at: https://github.com/highfidelity/hifi_tests/tree/master/tests/content/entity/material

Unfortunately, I don’t know of any other more “practical” examples. Maybe when the devs are back online on Monday we can find some.


#23

Re “You can now bring a 2D image into world as a 3D “poster” object via the Create menu.” - What about video? Can we bring an YouTube video or live stream in world?


#24

a) no. just rez the item the proceed to click and hold on the item
b) no. left click on the item. not the item ‘window’ qml / html
c) YES. This is closest explination. I bought a lamp. Try the lamp.
d) Can someone order a pizza? I’m kinda hungry. :stuck_out_tongue:


#25

Just wondering when the update issue with DO cloud domains will be fixed? Unless I am missing something, I would suspect it was only that the correct version was not updated on the cloud domain web control page.


#26

Press and hold the alt key and drag an arrow to duplicate the entity.


#27

Hi! Sorry for the limited information about this. Hopefully our docs will be updated soon.

As ctrlaltdavid mentioned, currently, materialURL can point to a JSON description of a material or it can be “userData” and then you can define the material in the user data of the entity.

Here are some very basic examples of materials:
https://hifi-content.s3.amazonaws.com/samuel/TestMaterial.json
https://hifi-content.s3.amazonaws.com/samuel/TestMaterial2.json

You apply a material to an entity (currently only model, soon shapes) by setting the material’s parentID. You can apply a material to an avatar by making it an avatar entity.

We’re working on adding support for additional material formats.

Let me know if you have any questions!


#28

Now live: a fix for the DigitalOcean cloud domain issue, where those domains were not updating to the latest version.


#29

Hotfix release 65.1 - includes fixes for:

  • Crashing when web-overlays or web-entities are present
  • Domain settings backups not loading on IE
  • Not being able to select entities in edit mode

This will go live in the next ~1.5 hours.


#30

Still not working.I am running build 7995 and my digital ocean domain says it is still running 7885. When I go to hifi cloud domains and update, it goes through the process but still come up yellow when back running and when I try to goto it … it says protocol mismatch and will not let me connect.


#31

Still no fix for the DO domain updates? 6 days ago it was supposed to be fixed?


#32

Hi Twa_hinkle

Did you restart from cloud domains page or from the domain server settings page. If you can please try restarting directly from the cloud domains page and let us know that would be helpful. The restart from cloud domains page restarts the container itself.


#33

I just tried it again.

went to the domain: could not connect

updated domain from the website cloud domains page.

went to the domain: could not connect.

reset virtual server from the website cloud domains page.

went to the domain: could not connect.

updated the domain again from the website cloud domains page.

went to the domain: could not connect.

and just to try everything I went to the domain settings and looked at my settings, which looked correct, and then restarted from there too.

went back to the domain again and could not connect because of protocol mismatch. It says it is still running version 7885 and I have version 7995.


#34

It still doesn’t update. One thing that might be different on my cloud domain compared to others is that it has no place name connected to it. But this has never been a problem before.


#35

Hello does someone knows while my google poly elmtree s are glowing since this version ?
It is the same with my Poly google seals.


#36

@adrian I have experienced this as well, but I am so used to the same/similar behaviour from other programs (e.g. Blender) that I initially wrote it off.

@sbin looks like it could be an issue with specular/glossiness. Do you have any way to manually edit the materials on those objects? That would probably be your best bet for fixing them is opening them in a program such as blender, editing the material to turn glossiness all the way down, making sure the material is set to diffuse, then reimporting them. My uneducated guess is, knowing nothing about Google Poly, is that HiFi was not rendering the material properly before, and is rendering the material correctly now.


#37

They did switch from binary to scaled metallic values recently. Could you have a metallic value in your textures that was previously being rounded to one of the extremes?


#38

Hi VikiAi and mold,
It s since this Version. In the past when this was happens for others it s has never hit me -)
I have import the obj now also I have found Materials. (I m not a Blender PRO)
Diffuse Intensit from 1.0 to 0.4
Specular from 1.0 to 0.3
I don t have found glossiness-(
so it s has keep the glossiness when I have upload the modifytree


#39

I see the Specular color set to white in your screenshot.
This is why this look metallic.
Must be black for non-metal.

The “Glossiness” is the “Hardness” under specular…
min: 1 is rough… to max: 511 is glossy.


#40

Oh cool I chose a pretty black color and have set it to 10 in my first test and it s match.
Thank you-)
elm2%20-%20Kopie