Beta Release 69


#1

Beta Release 69 is arriving in a few hours. You will need to update to this version in order to visit domains running it.

New Features

  • Avatar center of mass balancing: this will allow a person to use their body in a more natural way to move about and explore the virtual world. Previously, the hips remained under the head position at all times, which created a swaying appearance over the feet instead of leaning
  • Improvements to scrolling displays, including faster load time
  • Equipping/dropping hand-equipped items via script messages – for example, you can now make a scripted item that can equip itself to (and drop itself from) your hand
  • New sitting and love emotes in the Emotes app
  • Crashpad integration for Android for gathering crash reports
  • Support Client Side Compression for Android for reducing memory footprint and optimizing performance

Bug Fixes

  • Fixed instances of when an avatar collides with something and falls through the floor once landing on a default path
  • Fix for cloned items not behaving dynamically
  • Various crash fixes
  • Fixed Sandbox shutdown issue
  • Fix for manipulating the camera on the non-primary monitor
  • Fix for a bug that caused custom blendshapes to be invisible to others
  • Fixed issue with Snaps showing up as cubes
  • Reduced bubble radius to improve avatar social interaction
  • Minor changes in the tutorial
  • Minor fix in the particle explorer
  • Fixed various Wallet bugs

#2

hi there :slight_smile:

I am a bit confused. Is the Beta the Version 0.66.7? I’ve download the ‘only client’ from the Website. There is no Information anymore about beta xy - if the Client is running, I just see the 0.66.7 where the 8xxx Version number was before. Is that Beta 69 - so many numbers … head Scratching

I’ve also update the cloud domain via the webiste. Now I get an error message when I try to log in: Domain version would be 8483, but can’t Login the domain.

Would be much easier, if you guys would use only one number version for everythin :wink:


#3

@Skimi

Beta Release 69 is not out yet. When it is released later today, it will be 0.69.0. Going forwards we will be using the semantic versioning system for stable releases.

Any products with update notifications (Cloud Domains, Interface, Sandbox) should correctly present a notification for update from 8483 to 0.69.0.

The client only build on the website should still be 8483. I’ve just downloaded the build and confirmed that it is showing up as 0.66.7. I will follow up on why the website it pointing to that incorrect build.

In the meantime the correct latest client only build is available at this link:
https://builds.highfidelity.com/HighFidelity-Beta-Interface-8483.exe


#4

Thanks. This is the build with Substance Painter GlTF support? Thanks


#5

The download links on the website have been fixed. They are currently both pointing to 8483 and will be pointing to 0.69.0 once released later today.


#6

Goto: Recent Snaps: We can’t directly see the picture as before.

I understand that now the “i” icon leads now to the “place” page where we have all the snapshots of that place. (it’s a good idea.)
But maybe it would be nice to be able to see directly the picture when we click on the picture of the thumbnail and then decide from there if we want to teleport, instead to be directly teleported there.
I don’t know for other people, but personally, my first reflex with a snapshot thumbnail is to click on it to see what it is, not to directly be teleported. But getting sent to the Picture page, we can get the information we need to decide if we want to teleport.


#7

Does not compile on Ubuntu 16.04:

[ 85%] Building CXX object libraries/physics/CMakeFiles/physics.dir/src/CharacterRayResult.cpp.o
/home/root/src/hifi/libraries/physics/src/CharacterRayResult.cpp: In constructor ‘CharacterRayResult::CharacterRayResult(const CharacterGhostObject*)’:
/home/root/src/hifi/libraries/physics/src/CharacterRayResult.cpp:23:42: error: invalid initialization of non-const reference of type ‘int32_t& {aka int&}’ from an rvalue of type ‘int32_t {aka int}’
     _character->getCollisionGroupAndMask(m_collisionFilterGroup, m_collisionFilterMask);
                                          ^
In file included from /home/root/src/hifi/libraries/physics/src/CharacterRayResult.cpp:16:0:
/home/root/src/hifi/libraries/physics/src/CharacterGhostObject.h:32:10: note:   initializing argument 1 of ‘void CharacterGhostObject::getCollisionGroupAndMask(int32_t&, int32_t&) const’
     void getCollisionGroupAndMask(int32_t& group, int32_t& mask) const;
          ^
libraries/physics/CMakeFiles/physics.dir/build.make:86: recipe for target 'libraries/physics/CMakeFiles/physics.dir/src/CharacterRayResult.cpp.o' failed

This was not an issue when testing 0.68.1.

EDIT: Domain-server, however, compiles like a charm. This failure is on the assignment-client.


#8

With this release, those 2 actions:

  • Navigate > Copy address to Clipboard
  • Navigate > Copy Path to Clipboard

are causing a systematic crashes of Interface.


#9

Is the userlist loading slow for anyone else?


#10

i can confirm and this is really unfortunate since I really need to know my location and copy to clipboard to effectively use hf :frowning: this happens on windows and on macos, but on macos I can give you this coredump trace: https://pastebin.com/fQft45Jh


#11

A hotfix (AKA v0.69.1) is incoming:

  • Fix crash when copying address / path to clipboard
  • Improvements to avatar appearance - fixes for an awkward knee issue, an eyelid issue, and making sure something (an orb) always renders for an avatar if a mesh or identity isn’t available

#12

Thanks good one. Now… sorry if I’m a bit demanding… But what about fixing also the cut and paste problem on MacOS? Teaching to my students to make skyboxes some of them having MacOS they got quite upset to be obliged to retype very long https://xxxxxxxxxxxxhhhxhxhxhxhxhxhxhxhxhxhxhxhxhxhxhxhxhxhxhxhxhxhx.ktx path over again … :slight_smile:
I am curious: when I’ve been to USA last year every programmer I saw (or almost every) had a MacOS, so it is very strange that a program like HighFidelity is not Mac friendly (however, on the other hand, I really thank you to have tried to make it run on MacOS, since Linden Lab’s Sansar is not doing that)…


#13

There is a new problem. (I think its new)
AFK for some minutes then I go back and my camera is locked looking straight down and there is a low rez image overlay saying AWAY. and I cant do anything, cant get out of this mode had to terminate application from the task manager.


#14

While historically High Fidelity was originally only available for MacOS (Windows and Linux binaries had to be compiled)… what programming group only uses MacOS? I can’t imagine writing code for just such a platform. I know there’s QT and all that makes writing cross platform work a lot easier, but I guess it depends on the product being worked on.


#15

The “Script Log (HDM Friendly)” is indead buggy in that release.
If you turn it in and then switch to HMD, it doesn’t render.
We need to quit to be able to use it again.


#16

Not that I want to polemicize here, it was just an observation from my travels in US and UK (Here in Italy MacBooks among programmers are extremely rare).

I was at meetings in London with programmers from Google and they all had MacBook Pro laptops, and they are using it for programming on major opensource projects.
I also worked and committed some interesting code for one of these projects (gerrit) which is a creature from Google and Android ecosystem and most of programmers did come and regularly used Macs.
Were two years ago at a conference about Jenkins in Santa Clara and I was able to spot only a few not Mac computers around.
I also can state having a macbook myself (and a win10 and various Linux vm) that it is really convenient for developing opensource applications: has a wonderful docker support, and via brew you have a 99.999999% linux compatible system. So it is definitely not true that programmers use MacBook to develop on Mac platform. All the programmers I knew developed programs for opensource projects which normally run on Linux.


#17

I have reviewed the behavior regarding the zone Skybox, Keylight, Ambient Light, versus Zones rotation and Inheritence. Here’s the problem I have isolated.

1- if I want to set a specific “Ambient Light URL” on a child zone, for a zone that is suppose to fit a building that is not at rotation 0.
How can we adjust the Ambient Light texture if the only way to capture a spherical 360 image in-world is doing it at Rotation 0? This is going to be very painful. It would require editing the spherical texture to compensate.

My I suggest that:
-When the “Ambient Light URL” is not inherited, and it is different than the “Skybox URL”, that it get displayed at rotation 0.
OR
Implement a flag on the Ambient Light to allow to force the display to rotation 0.

To figure the issue, imagine you want to add an Ambient Light texture that will be the indoor ambient light of a building that is not at rotation 0.

2- Minor issue: when we change the Ambient Light URL, it’s often not getting effective. (It get effect if we change the Intensity. Or fi we clear the cache) This is causing back and forth to adjust that over many visits.


#18

I have clarified the issue about the zone. Please read.


#19

This topic was automatically closed after 30 days. New replies are no longer allowed.