Beta Release 71


#1

Beta Release 71 is coming to you today. As usual, there is a protocol change, meaning that you will need to update to this version in order to visit domains running it.

No new features this time, just a bunch of yummy bug fixes:

  • Fixed an issue causing audio settings be set to desktop while in HMD
  • Numerous minor UI fixes to the Avatar App
  • Fixed an issue which resulted in bluescreen in VR mode
  • Fixed an issue which caused an avatar’s elbows to penetrate the body
  • Added ability for creators to disable handtouch from JavaScript
  • Create App Bugfixes:
    ** Fixed an issue where creating an entity can’t be undone with CTRL+Z
    ** Fixed an issue where deleted entities don’t get removed from the list
    ** Fixed an issue where Animation FPS can not be changed
    ** Fixed several issues with Grid functionality
    ** Fixed issues where web entities in the scene interfered with edit handles
    ** Fixed issue where light and particle icons cover the tablet
    ** Fixed an issue where the web entity was invisible if it didn’t have a URL
    ** Ensured entity property menu is blank when no entity is selected
    ** Improved using Create menu in Mirror mode
    ** Misc Create handle fixes
    ** Other misc. API and Editing bugfixes
  • Fixed a couple of crashes
  • Fixed a bug where child entities with constant rotation behave erratically when parent entity is grabbed
  • Fixed a bug related to shadows in serverless content set
  • Fixed a memory leak in Domain Server.
  • Fixed a bug on Mac related to haze

#2

Howdy

I just installed Beta 71 on my local Sandbox and Interface installations (Mac & PC) with no issues, but my Digital Ocean Cloud Domain refuses to update to the latest version. It says update is available, I initiate the download, it says “Server Updating”, then goes back to saying “Update High Fidelity”. I have rebooted the server, but past that I am not sure how to solve this issue, as it has worked great with all previous updates. Is there any know issues on the HiFi end of things, or do I contact Digital Ocean for support?

Locked out my my primary Domain due to this issue, so any assistance would be welcomed.

Thank you -


#3

I was able to update on both digital ocean cloud servers I am currently managing.
Just for information, no problems here.


#4

Thanks for letting me know Adrian - I will contact Digital Ocean and see if they can see something on their end.


#5

My DO domain does not update now either. As has happened in the past, this is not a DO problem as far as I know.


#6

Twink is right it’s prob not a DO issue, it has happened to me before for no reason, just try refreshing your browser and trying again. It will probably work eventually.


#7

Can we please give more heads up notice on these updates? Last one was on Wednesday, previous ones were Tuesday, and now Mondays? I know I made tools to help with compiling but it still isn’t ready for automatic yet.


#8

I’ve refreshed and refreshed and updated and updated, it says it is updating but it does not take the same length of time that the real update takes.

Meanwhile, I polish my tinfoil hat.


#9

Is it just me? I just used Goto to go to my locally hosted domain. Both running 0.71 as far as I know.

The landing point is 0, 0, 0.

I end up stuck in the block entity that worked fine before. Didn’t that new guy claim that the new landing point would be above the old ones? Which I think is a bad idea because you could never set an exact landing point.

If this is really just a change to make the feet be the new point of landing, are avatars now going to have their origin at feet instead of hips?

As I’ve said to some here: I know when my builds here are “finished”, it’s when what worked before stops working.


#10

After the update I’m missing the particles (the candles had a flame before the update). I’ve checked the enitity list, and all particles are deleted. Also, after restoring a content backup from before the update, the particles are missing.

Something with transparent entities has changed, in my case, the color (or maybe the texture?) is poofed away, if the entity is viewed from a different angle of view.

Version 71.0

Version 71.0 from a different angle of view


#11

did u check the url for the texure?


#12

I’ve checked the blender file. the glass has no attached textures, just properties from blender, and it worked fine before the update.

The particles of the lantern were an entity, not created by a script. Which are still in the list are created by a script.

Version 70.4

Version 71.0


#13

Still cannot run sandbox. domain-server.exe get still jailed by avast. and removed after the first startup.

Client works fine.


#14

Yes, that is what they told me after I submitted a support request, which I totally expected. I have tried updating it a couple of dozen times now from different computers, but get the same result. I guess I will search the forum to see what people have done to resolve this in the past.


#15

For anyone else having this same issues with 0.71.0, I just deleted the Digital Ocean droplet, created a new one, uploaded my backup settings/content and everything snapped back together.


#16

I just updated and tried to rez a new environment and nothing happens…


#17

Why is the 3D pivot having washed out colors and look to have opacity ? It’s demoted the use of it very much.

I cannot really see what is blue or green.

To much pastel colors.
Just give it hard RGB colors and remove the opacity.
This looks TERRIBLE now !


#18

I think this alternate learning sandbox is a BAD idea. What possible reason is there for this? It will only make the entry into HiFi even more confusing then it already is for non technical people who enter for the first time. I would put this in the category of BUG. I spent a day trying to figure out why I couldn’t rez an environment from the store there. There was no indication I wasn’t in the standard learning sandbox!

I’ve got over 20 years in a technical field and work with people on computers daily. I can tell you that one thing I’ve learned is that you have to keep things simple for people. HiFi is way to complicated for a casual user. A new user won’t understand the concept of a sandbox. To them, this is HiFi! This is the world they first encounter and it should be a GREAT experience.

My recommendation is to make the “Desert Oasis” the first place people see in their sandbox. It’s visually stunning. Put one of the teleport portals in it from the learning environment for people to find. Create another domain and call it “Learning Environment” or something else telling. Put another portal that leads to it in the HUB as you do for other demo worlds you have. Then put it in the “GOTO” menu under places.

As for the sandbox, at least make places for people to sit and gather. One of the first things you want is for new people to figure out is how to invite their friends and family. You should encourage this behavior from the beginning. Once they have found this incredible new world they will want to tell others to download it so they can invite them to hang out. Do this and HiFi will become the viral social VR HiFi desires to be.

Building, scripting and development is last thing people are thinking about when they first visit HiFi. Only veterans from Second Life or Sims think about this. Yes HiFi will need builders but lets not sacrifice the HiFi user base to get to that point.

At any time when I look at the “GOTO” menu from the available places to go it appears that there are very few people using HiFi. You should count the number of active interfaces and put that number in the “GOTO” menu. People aren’t going to want to use a social VR where there are no people and the perception is that there are very few people to meet in HiFi.

Perception is reality, especially in VR. Put that on a card and place it on the desk of every HiFi employee.

As a first time builder it annoys me that I have to delete the learning environment to start building. You should put an alternate builder sandbox under the Edit ribbon toolbar options. You could call it “Blank Slate” or something descriptive. This should be a blank slate where people can build. The “Create Tools” hud should open by default when people enter this builder sandbox. You should also put an option in the “Create Tools” hud above “OPEN THIS DOMAIN’S ASSET SERVER” that presents the blank slate sandbox option.

Lastly, since I realized there were actually two versions of the sandbox, it would be nice to use this feature to leave your “Home” untouched as you edit and experiment in the “Blank Slate.” This way people don’t have to sacrifice their current sandbox while they experiment. Perhaps there should be an “Apply” button or feature under the “Edit” ribbon bar that can apply the Blank Slate to our sandbox once we are happy with the new world we have built.


#19

Hi, on PC, I am unable to shut down interface in the usual manner, and have to go to the Task Manager and force it to close. Then, when I go to log in again, it acts as if I had crashed the last time.
I hadn’t seen this as an issue with anyone else.
Haven’t tried on MAC yet, but I will.


#20

why would u want to shut down hifi
burn the none beliverrr burn burnnnnn
:stuck_out_tongue: