Beta Release 80 Now Scheduled for Tuesday, March 19, 2019

#5

Can we sent script events to Web entities yet?

see API note below, my scripts use the web3d overlay as it doesn’t seem supported yet on entities:

https://docs.highfidelity.com/api-reference/namespaces/entities.html#.emitScriptEvent

emitScriptEvent(entityID, message)

Send a script event over a Web entity’s EventBridge to the Web page’s scripts.

Parameters:
Name Type Description
entityID Uuid The ID of the Web entity.
message string The message to send.

To Do:

  • This function is currently not implemented.
0 Likes

#6

Yes, I believe this should work now! I will update the jsdocs to reflect this. Let me know if you have any issues with it. As of this release, the Overlays API will just make a local entity under the hood, so you can’t gain any functionality by using it, and you’re just paying the price for the conversion of properties.

EDIT: spoke to soon! This wasn’t fully enabled in 80, but it will be in 82! It should work if you go through the tablet, as many of our scripts do, but not through an arbitrary web entity via that API call until 82 @whyroc

1 Like

#7

So it sounds like the Overlay Emit script event will break with 80? Reason why I was not using the tablet entity was so I didn’t have to keep the tablet open to run the script.

thanks

0 Likes

#8

How were you previously using it? I don’t think there was ever an “Overlays.emitScriptEvent”.

There may have been a way of doing it via the Overlay object directly, with Overlays.getOverlayObject(<id>)? Is that what you’re referring to? That method should still work, and there’s also an Entities.getEntityObject now, which will do the same thing.

0 Likes

#9

Ok super, yes I was using Overlays.getOverlayObject. I will wait for 82 and then implement a basic local entity, fingers crossed will be good for 80.

thanks @SamGondelman

1 Like

#10

Way more filter documentation is needed, adding a couple more examples isn’t nearly enough. This should be thoroughly documented, and in a way that beginners can understand how to write them. Securing domains is extremely important.

0 Likes

#11

image image
Hmmm something changed. I’m using the the original fst packager. Any idea how to solve it?

0 Likes

#12

@123.Basinsky.321, is this for a new avatar or an avatar that used to work?

If it is a new avatar, please try the new packager.

If it is an avatar that used to work, please email support@highfidelity.com along with the file you’re using, note this forum conversation, and the team will look at it.

0 Likes

#13

Re http://roadmap.highfidelity.com/bugs/p/keep-likes-when-marketplace-objects-updated

This appears to be fixed only going forward, i.e., it hasn’t been fixed retroactively.

0 Likes

#14

@emilythethird
“Your did not”
You did not
:wink:
Typo in avatar packager screeny above

1 Like

#15

AND looks like this version breaks attachments even harder:
http://roadmap.highfidelity.com/bugs/p/wearables-detaching-after-roughly-4-minutes

0 Likes

#16

This is for a new. I tried it also with my buzz lighyear avatar and it gives me the same error. It did not when I used it in 79. When I use the avatar packer the avatar is imported but is horizontal in stead of vertical. I will try to experiment a bit more, and send the avatar to support.

1 Like

#17

Great headway! With major releases like this it assumed there will be some bugs but I am satisfied that HiFi is developing in the right direction. Kudos to you and the HiFi team. I look forward to getting back involved when I am finished moving to my new job in another state.

Hap ?;O)

0 Likes

#18

I can recreate this issue as well - it will not work on any models that I have used the same process with in the past - just get the same error. I would really appreciate it if this could be fixed, as it is my preferred way of packaging an avatar.

0 Likes

#19

Ok, not so good news… the web3d Overlay doesn’t seem to exist anymore, so script is likely broken until 82. slightly better news… I have a version using the tablet I can revert to for the time being.

++ for the API docs updates btw!

0 Likes

#20

@ultranique - Would you also email support@highfidelity.com with the file you’re using so we can investigate this?

0 Likes

#21

I saw that this release has fixed the bug with changing the animations, but unfortunately, when you play animations, it will slow down the Game Rate. The animations also are not playing flawless. In one of mine domains (INDUSTRY40), where I have many animations on industrial robots, I am not able to move, even the Render Rate is over 60 fps, the Game Rate is 1 or 0. This must be fixed!

0 Likes

#22

Got it working on a tip from @SamGondelman , needs some delay now for the web entity to connect:

Script.setTimeout(function () {
  overlayObject = Entities.getEntityObject(web3dOverlay);
  //print(JSON.stringify(overlayObject));
  overlayObject.webEventReceived.connect(onWebEventReceived);
}, 5000);
1 Like

#23

As per the meeting, if though wants a watch:

Bug #1: http://roadmap.highfidelity.com/bugs/p/entity-bones-reset-locally-on-teleport-but-not-remotely

This makes the watch look right to everyone else, but not to the user themselves.

Bug #2: http://roadmap.highfidelity.com/bugs/p/windowdomainchanged-does-not-work-on-avatar-entities

This prevents ‘flashing’ the watch to resolve Bug #1 as a work around.

Fixing one of them should allow the watch to be published. I have a work around for both, but it involves a menu option to ‘flash’ the watch manually. No, I will not add a tablet button for a workaround.

0 Likes

closed #24

This topic was automatically closed after 30 days. New replies are no longer allowed.

0 Likes