Black Materials


#1

At times, you might see your materials rendering black. This could be due to the phong material “reflected color” value. Be sure to set it to Black or 0, depending on your application.


#2

Also, if you’re exporting out of Blender, check the fbx version. It will also affect the material properties.


#3

Ive noticed that sometimes this is also caused by Vertex colors being set for the mesh, this causes there to be some odd behavior, with the vector colors doing some odd things to the shader. I need to do some experiments.


#4

@Menithal I’ve seen the same issue with vertex colors in blender. A potential culprit is the vertex color settings.

Currently Hifi does not support shaders with vertex colors and texture files. If you want to use a texture file be sure to disable the vertex colors.


#5

Another offender is the “Loop Color” attribute in the “Object Data”. If you’re not using vertex colors, be sure to remove it.