Blender vs High fidelity problem


#1

After many A,B ,C and aaarghs. I have cut down mu work to something simple and only with one texture. multitexture fails for me. But i know how to fix that later.

@judas pointed already at som eproblem, not sure if it’s the same. I have finaly something that seems to look fine. But in high fidelity it’s a ghost, texture gone and it got alpha. i know on the project i used alpha in the past, and sadly it seems very hard to remove in the UV-editor images from the list, pretty annoying from day one. (bug ?)

But here’s my result sofar, and for now i can betetr find a good program or high fidelity need to get fixt. or mabye both

Anyway, with more then one material thing get terrible screwed on my screen in blender render or or, doing something not in not logic workflow that blender needs.


A logic workflow would be for me

  • make the object
  • Add materials and textures.
  • Align them and resize it so it looks good how you want it (a bit like sl(
  • bake the textures and your done.

But that seems to simple for blender to implement.

How it looks like you need todo it now in blender, is something like this.

  • make the object
  • Add materials and textures.
  • Make UV map
  • Tinker on the uv map to align and get your texture right and looks correct.
  • Bake it ?

ADD: It Seems high fidelity is not using embedded textures anymore ?!
Using a seperate texture and not embedded it in the fbx works.


#2

@Richardus Raymaker - Yes that’s the basic work flow, and you only need to select from the drop menu Bake - ‘Textures’ (not Bake - ‘Full Render’)
Before you make the final ‘Confirm’ for 'Export as ,fbx ’ do you set the export values in the T(ools) menu, its at the bottom of panel, for HiFi Export?
Which should be
7.4 Binary
Select ‘Mesh’ icon
Path Mode = Copy
Embed Textures - Check On
Embed - Check On

Learning how to Unwrap and use UV Maps is as big a learning curve as the initial modelling of an object, but once grasped it is extremely powerful if very time consuming
Good luck and my sympathies because atm learning Blender and testing in HiFi is one of the recommended punishments in Level 9 of Dante’s Inferno


#3

This is bad news. I hope it’s just a glitch.


#4

Did a quick test on embedded alpha: still works

Now would actually help to see the actual blend file that has the issue but let me try to blindly troubleshoot the issues:

Blender: Removing Textures from Texture Editor

Blender works via datablocks: so nothing really gets “removed” until it has no references in the scene setting datablocks to for a texture, then saving and reloading ( this seems intuitive, but knowing how rendering engines need to references to single texture, it is there to make sure the texture is loaded only once to memory instead of many: to make sure rendering is as fast as possible, since you only have to references to the textures,object,mesh,etc)

To remove images from the UV editor (or just texture viewer as they say in blender, right click view image to see all the text):

  1. Press the X next to the file open with shift+left mouse click: Tool tip on it says shift+click to set users to zero, data will not be saved
  2. Check the texture list: (see 1)

    (see 2) 0 infront of the name means it has no references: and will not be saved on the next save. F means it has a “Fake” user: and will be saved even if it doesnt have any actual users.
  3. Reload the scene by Save and Open Latest ( ctrl + w, ctrl + shift + o + enter )

Hifi: The Ghost ( 'pooky ) Window Issue: (Material swap)

What I noticed about embedded textures, is that **if you do embed the textures, you better make sure that all texture and material names have no periods in the names in the objects you bring into high fidelity -

Otherwise high-fidelity will render all the materials in incorrect order, and from your case it seems as if the glass texture got assigned to the frame of the window. This will occur on other 3d suites and not just blender.
You can try running @humbletim 's script to replace all the periods with _ ( which is really annoying to do since blender’s conventions always add periods if you replicate something :smiley: )

###Hifi: No materials defined:

This means you have no materials defined for the faces of the object: Especially apparent if as you move around this the textures switching like crazy: hard to reproduce if there is only one other texture being used in the scene (mixamo avatars have a bundled texture). Objects without materials tend to start sucking in all the textures in the environment, especially avatars.

Hifi: Other stuff you may encounter

Transparency materials are known to have some issues in Hifi: do not combine solid and transparent as of this moment, in the same mesh (blender object, you can still export all the mesh into a single file, see below image for example what I mean)

if object with a solid material intersects the transparent part of the model, the transparency will turn solid. : usually its best to keep them as separate mesh objects (but can be combined into the same file):
Forexample with my Fennec Avatar’s eyes I have the corneas separated as a separate object. The same concept applies on entities as well.

But entire model is exported into a single fbx. which fixes that issue for now.

Hopefully that helps.


Autodesk FBX converter broke (suggestions for new one?). Time that high fidelity get .blend support
#5

Lot’s to check. lot’s to learn. and i know to avoid the dot in names, normally use underscores. but mabye a dot sneaked in. For now i go test it with external textures first. or in this case now my window works try to convert it to embedded again.

I know the basic uv stufff, but some things still bite me.

Thanks.


@Menithal

Right now i have the weird problem that as soon i pressd bake the good look get overwritten bij a block texture. Ah, bake worked now !

And thanks for the bake mode, did not know that one.

ADD: starting new project from scratch. to see if baked textures work fine then. Last test still created alpha window frame with embedded textures.


LStill lot’s of weird problems. one is that embedded textures are going wrong. locally already. just external textures work fine.

But now am stuck again with that the glass get the wood texture. and both are 2 materials.
Now the frame looks good in High Fidelity. but my glass is gone NOW ?

Who is nuts ? me,blender or high fidelity ? :open_mouth:


#7

Well, I’m really not a Blender expert, so my question may be dumb. I never have baked my textures. I have attached to every prim my material and often different material to each face. Then I have loaded the textures to the material and exported with embed textures. This has worked for me.


#8

Only thing I ever usually bake is AO, even that is only a temporary measure as most of the time I trust that my specular and my normal maps will handle most of the work (seriously, now that they are always on one should use them :smile: unlike in SL where you cant trust that everyone has them working ) or if I have some point lights in the scene I want to “stress”.

Ill have to look into the baking issues later once I return home.


#9

Loved your last comment, ha ha.


#10

… I feel your pain. And transparency might be more mysterious yet – I think the C++ code might be scanning pixels and deciding for itself sometimes (despite FBX settings) about whether alpha applies.

Would being able to preview models on the High Fidelity rendering engine (from inside of Blender) help very much? Something like this maybe:


#11

@humbletim if i understand you correctly then a big yes.
It would also save many exports uploaded to the cloud before discovering failure in HiFi

I’m guessing an ‘add on’ of a “HiFi Preview” would require atm almost daily updates (weekly?) but further along the dev journey this would be a great aid in taming the Beast of Blender,
Although lol if…

"the C++ code might be scanning pixels and deciding for itself sometimes (despite FBX settings) about whether alpha applies"
then it sounds like a nightmare scenario for future thinking machines.


#12

For local litmus testing (ie: off-cloud) I like to use a local modelURLs like file:/home/tim/folder/model.fbx?v=timestamp – and then set up a JavaScript timer to refresh the value continually.

That way the number of import steps on the HiFi side effectively becomes zero – I just edit in Blender, export the same FBX again and “alt tab” over to HiFi (and if not already showing, within seconds the latest export magically appears). This same sorta trick works for rapidly testing FSTs from local files.

(Note: this would be a terrible idea to do when connected to a domain server or with any kind of network resource over http – so I always make sure I’m in a disconnected state first)


#13

Hmm, i don’t get it. in blender the object looks perfect. in texture , materials and render mode. As soon i export it as fbx and use the fbx previewer the object is texture less. Yes i did say copy and embed textures.

Add, discovered something new, if you doi glass as first material the fbx previewer is going wrong. i changed the glass and wood material order now it looks fine in the fbx previewer.

And now it’s showing wrong in high fidelity. It looks like it’s not seeing both materials. Help ! :open_mouth:


#14

Could you dm me the blend file? I can take a peek on Sunday evening and comment on it. :slight_smile:


#15

Time for new mesh banging round. it’s again only shpowing one texture. and i have assigned 2.

  • Ok, first error where that i used 1 object with 2 textures…

  • so for safety i have split that in seperate objects and assigned only 1 texture to object this still sounds stupid way…

  • then the other high fidelity bug appeared.So i renamed everything with dot in the name.

But again, still only one texture. there’s some terrible bug that keep crawling around. Now i need to find it again and fix my error. Possible solution i need todo, remove all materials and do it again.


#16

Oh, this is extreme annoying it seems the still not have fixt the problem with textures in seperate location on your disk.

Trying to keep things a bit organized but high fidelity is not allowing me todo that.
What you need todo is place all directory’s in the same location as the bledner file, i also save the fbx there. If you dfo the opposite and organize things lie this

/textures
/object
…test.blend
…test.fbx

and you have the textures in /textures , high fidelity is not reading all the textures. only the first one seems to stick on everything. Strange, because i got the idea that the problem already where fixt…


#17

This is a known bug. I and a few others reported it weeks ago. Interface is not following paths, just looking in the root directory. I think this bug is on a work list.