[Bug] Xbox one controller wireless stops responding


#1

The xbox one controller, wireless version is falling automatic asleep.
If you wake the controller up again, high fidelity is not responding anymore on it.

It’s also crashing interface.

  • Xbox controller fell asleep.
  • Activated xbox controlelr again
  • No respons.
  • Switched SDL off and on.
  • No respond.
  • Turned it again off and on
  • Interface crashed.

Pretty annoying.


#2

The bug still exist, but found a easy way to trigger it.

  • Have wireless .xbox one windows controller
  • Start high fidelity, test controller.
  • Turn controller off (simulates standby sleep mode)
  • Turn controller one

It’s not responding anymore, turn SDL2 off and on is not helping. high fidelity lost the xbox controller complete. This need to be fixed because wireless box controller will go automatic in sleep mode. That means you need to logout every time from high fidelity to get the xbox controller working.

Better fix this before the final beta release !

New Update, it’s already enough to keep the xbox controller on and just disable SDL2. After you enable SDL2 again. You still lose the xbox controller for the time interface is running.

Beta 4820, still a big fail. just did test by turning the xbox wireless controller off. and then on. It;s useless after that.

Another update:
Can anybody from high fidelity confirm if the have the same problem.
It works fine if you turn the xbox controller on after starting high fidelity. But it still go wrong in the case it where on in high fidelity and then go in sleep mode. etc. see above.


#3

Tried another test,

Disabled SDL2 in interface.
Closed interface
Turn Xbox controller on
Start Interface
Wireless Xbox controller works
Turning SDL2 off and on again.
Wirteless xbox controller stops workig.

It looks like when you disable and then enable the SDL2 functionality, there’s no detecion done on available hardware. @chris, can you confirm this problem on your windows 10 system too ? Is this a bug ? SO i know at least if it’s me or just a bug.

Build 4856, the xbox controller decided to start sleep. And since then it’s dead in interface. And still not any confimation if it’s a bug or something else.


#4

can confirm that it’s not a problem in windows or the xbox hardware. Just installed my star wars game back. The only one i know works with xbox one controller.

I can turn on and test movement , then off the controller and turn it on again. It keeps working perfect in star wars.

Only not in high fidelity, if turned off. it’s gone until restart of interface. Ill report a bug on GIT.


#5

Fixed with Build 5029