Build 1285 and Stack manager crashes at startup


#1

Windows build 1285 crashes at start up, on windows 7
Also getting an error with the stack manager running on a different windows 7 machine, getting the error program can’t start because LIBEAY32.dll is missing from your computer. try reinstalling the program to fix this problem.

I have uninstalled and reinstalled the stack manager, still no joy.


#2

Confirmed, just upgraded to 1285, interface.exe is crashing

Problem Event Name:    APPCRASH
  Application Name:    interface.exe
  Application Version:    0.0.0.0
  Application Timestamp:    54401857
  Fault Module Name:    ntdll.dll
  Fault Module Version:    6.1.7601.18247
  Fault Module Timestamp:    521ea8e7
  Exception Code:    c0000005
  Exception Offset:    0002e3be
  OS Version:    6.1.7601.2.1.0.256.48
  Locale ID:    1033
  Additional Information 1:    0a9e
  Additional Information 2:    0a9e372d3b4ad19135b953a78882e789
  Additional Information 3:    0a9e
  Additional Information 4:    0a9e372d3b4ad19135b953a78882e789

Not seeing anything about LIBEAY32.dll


#3

Interface 1285 on Win7 64 bit is failing to run for me as well. I had to run it from a command shell to capture its output.

C:\Program Files (x86)\High Fidelity\Interface>"C:\Program Files (x86)\High Fidelity\Interface\interface.exe"
NodeList getInstance called before call to createInstance. Returning NULL pointer.
QObject::connect: invalid null parameter
[Info] DDE Face Tracker Socket: QAbstractSocket::BoundState
[2014-10-16T16:52:55] [VERSION] Build sequence: 1285
[2014-10-16T16:52:55] First call to Menu::getInstance() - initing menu.
[2014-10-16T16:52:56] NodeList socket is listening on 56873
[2014-10-16T16:52:56] Changed socket “send” buffer size from 8192 to 1048576 bytes
[2014-10-16T16:52:56] Changed socket “receive” buffer size from 8192 to 1048576 bytes
[2014-10-16T16:52:56] Local socket is 192.168.1.2:56873
[2014-10-16T16:52:56] AccountManager URL for authenticated requests has been changed to https://data.highfidelity.io
[2014-10-16T16:52:56] input device: “Line-In (Sound Blaster Recon3Di”
[2014-10-16T16:52:56] Found a data-server access token for https://data.highfidelity.io
[2014-10-16T16:52:56] No private key present - generating a new key-pair.
[2014-10-16T16:52:56] Starting worker thread to generate 2048-bit RSA key-pair.
[2014-10-16T16:52:56] Logging activity “launch”
[2014-10-16T16:52:56] Created Display Window.
[2014-10-16T16:52:56] DEBUG [ “Line-In (Sound Blaster Recon3Di” ] [ “Default Input Device” ]
[2014-10-16T16:52:56] The default audio input device is “Default Input Device”
[2014-10-16T16:52:56] The audio input device “Default Input Device” is available.
[2014-10-16T16:52:56] The desired format for audio I/O is QAudioFormat(24000Hz, 16bit, channelCount=1, sampleType=SignedInt, byteOrder=LittleEndian, codec=“audio/pcm”)
[2014-10-16T16:52:56] The desired audio format is not supported by this device
[2014-10-16T16:52:56] The format to be used for audio input is QAudioFormat(48000Hz, 16bit, channelCount=1, sampleType=SignedInt, byteOrder=LittleEndian, codec=“audio/pcm”)
[2014-10-16T16:52:56] output device: “Headphones (Bluetooth Hands-fre”
[2014-10-16T16:52:56] DEBUG [ “Headphones (Bluetooth Hands-fre” ] [ “Default Output Device” ]
[2014-10-16T16:52:56] The default audio output device is “Default Output Device”
[2014-10-16T16:52:56] The audio output device “Default Output Device” is available.
[2014-10-16T16:52:56] The desired format for audio I/O is QAudioFormat(24000Hz, 16bit, channelCount=2, sampleType=SignedInt, byteOrder=LittleEndian, codec=“audio/pcm”)
[2014-10-16T16:52:56] The desired audio format is not supported by this device
[2014-10-16T16:52:56] The format to be used for audio output is QAudioFormat(48000Hz, 16bit, channelCount=2, sampleType=SignedInt, byteOrder=LittleEndian, codec=“audio/pcm”)
[2014-10-16T16:52:56] Output Buffer capacity in frames: 3
[2014-10-16T16:52:56] Status: Using GLEW 1.10.0

[2014-10-16T16:52:56] Initialized Display.
[2014-10-16T16:52:56] Oculus SDK 0.4.2

It hangs maybe 2 seconds after last line above then terminates with no further output. I’m wondering if the first two lines is an issue or simply something I’ve never noticed before.

NodeList getInstance called before call to createInstance. Returning NULL pointer.
QObject::connect: invalid null parameter


#4

Same here, if you need duplicate log post I can reproduce and share here but above is what I am experiencing as well.


#5

I checked older version of Interface - the null pointer thing comes out with them as well so I don’t think that’s an issue. :slight_smile:


#6

Hi All. We have found the issue and a fix is on the way.


#7

Thank you all for the logs and stack traces. Apologize for this one - undefined behaviour that caused a crash on windows but passed fine in testing on OS X.


#8

In case people forgot the download link https://highfidelity.io/download/

Build 1287 still crashing, so maby im to fast…


#9

1288 Crashing same way for me - not attaching log as it same I posted for 1285.


#10

Removing my Interface prefs lets 1285 run.


#11

And immediately crashes upon entering log in credentials.


#12

Fixed in #1289. Should be good to go.


#13

@b 1289 = all good so far. Thanks!


#14

Same here, just install 1289, i can login again ! :smile:


#15

Hold on !, i can login, but… now the stack manager is broken ! so still cannot login on my domain.

LIBAY32.dll error as soon you press the domain start button.

download link for when new version is available. https://highfidelity.io/download/stackmanager/win


#16

Build 1291 working good for me, but im still having a problem with the stack manager, getting the error LIBEAY32.dll missing on clicking the start button.


#17

@Derric_Foggarty are you still having issues?


#18

I have still problems with the stack manager.


#19

Yeah @Chris, same as Richardus that missing LIBEAY32.dll


#20

stack-manager should be fixed today - @leo is working on it.