Build 1906 Installation problem


#1

Hi, after installing V 1906, when launching Interface I get a message of a missing library MSVCR120D.dll and Interface will not start.


#2

Hey there @Templar

This is from them getting changes with their build system sorted out but I have put up a copy of the DLL files that may be needed on my server if people wish to try them in the mean time.

Here is the link, but I suggest everyone read the readme.txt file before copying files. If any other files are requested feel free to ask and I can get them added to that directory:

http://coaledge.com/hifi/hifi-dll/


#3

Did both of you guys install a pull request build at some point in time? the release build is actually, well, release, and doing a dependency walk on it there’s no debug dll linked at all. I think this is some issue associated to having both a PR build and a release build installed in the system. Can you guys confirm if that applies to you to help debug?

@Templar @Coal @OmegaHeron


#4

@leo I am running one instance only and it wont start anymore. I am not techy enough to tell you more.


#5

Ok I just tried 1906 on a clean system and it ran fine. Can you guys please try uninstalling completely any version you have installed in your system, restart, and install 1906 from scratch and let me know how it works.

Thanks!
L


#6

Did the test, start interface.exe,
Download 1906 because that’s the latest, installed it. and this is the result. Its not starting.

I have not done a clean installation. I go try to download the 1906 from the webpage. its not the first time the the download interface.exe gives is not complete.

Download from website is same result.
Uninstalled old one, installed a fresh one that i have downloaded from the download page.
Ok, i did not restart, because cannot do that right now between uninstall and install.

Same problem.

@leo Have you done the test on system without visual studio or developer tool installed ? because that can possible installing the dll.


#7

@Richardus I did, however I think this is an issue not with interface rather some library getting linked is debug and not release for some odd reason, I’ll have to dig into this.

I can clearly see that interface.exe itself is linked to C++ redistributable release dlls (you can confirm this if you download http://www.dependencywalker.com/ and open interface.exe with it):

For now, to get you guys unstuck, I’ve just added the debug redist to the release build, patch solution for now since I can’t dedicate a lot more time to this right now and have to take care of family, however, I will further dig later today or tomorrow and find the actual culprit of this linking problem.

Please run 1907 once released and let me know if all good.


#8

Writing that message it dawned on me!!! I know which library it is, its SOXR library that is only available as debug lib! I’ll fix later today. Thanks for your patience guys.


#9

I knew you would get it worked out and traced back! That makes a lot of sense and we await the fixed version :smiley:


#10

build 1908 coming out, please all grab, should get you all going. Will properly fix before the weekends over.


#11

1908 works fine by me.

thanks


#12

I’m also getting this problem with build 1907. Same as the screen shot


#13

@estarbrook please use build 1908


#14

Just in case anyone gets stuck and needs the installer…

https://highfidelity.io/download/