Build 4441 - Issues since Build 4439 Related to Alpha / Transparency


#1

Sometimes when i load High Fidelity, or teleport on build 4441, this happens. Sometimes alphaed objects also refuse the render ( like the fur ball at center ) until reloaded. Related to PR7281 merge.

Reloading the avatar/entity fixes it temporarily until teleport or relog.

Framebuffer Debug seems to skip the model at all buffer levels, except the eyes, which do not clip, it looks like an alpha is applied to the model, even though the png has no alpha mask defined (yet) This also occurs with the entity, where the lowest is comming ontop of the other layers…

If using Shadows, when the avatar goes to the state, it also doesnt show, instead the separate objects do (in this case, the eyes and the teeth cast the shadow.


Normal map is also fully ignored when in the state.
Hopefully that is enough information to get a bug fix for the above :slight_smile:

I do however like the fact that the alpha seems to now be gradiental. However I do not like it that they ignore scene lighting.


vs Pre build 4439

Similarly this also occurs with other avatars

CC: @Chris, @Sam


#2

I’d noticed this with Albert’s coat before the merge, but thought I’d fixed it by treating models as opaque if they have any opaque materials.

I believe the root cause may be https://app.asana.com/0/26225263936266/100152512675188, although it definitely needs more investigation. (EDIT: This points to an issue where the FBX Reader mistakenly reads alpha channels.)

As far as the shadows go, no shadow is an indication that something is marked as transparent. As it is set up now, only opaque shapes cast shadows. That picture definitely helps, and makes me think even more that opaque PNG may be being read incorrectly WRT their alphas.

Thanks for noticing this, @Menithal!


#3

ah that link explains it all so clearly

-.- sighs*

*apart from the chosen ones alphas don’t have access to asana, this is why we keep asking over and over and reporting then reporting the same bugs over and over again.
were kept in the dark for our own protection
if we knew what was going on we would risk being productive
and that would never do


#4

Just consider an asana link as proof positive that we know about it and we’re working on it. :slight_smile:


#5

Build 4465:
Objects with transparent masks are still ignoring scene lighting (only using the skybox ambientlight instead)

Also alphaed objects still also occasionally dissapear like earlier / refuse to load unless the model is reloaded.
"[03/19 00:42:42] [WARNING] libpng warning: iCCP: known incorrect sRGB profile" is thrown.

Good news though is that I have yet to encounter the alpha sorting issues so it seems to have been solved. Close guys, close :slight_smile:

You can use the test model I made http://www.norteclabs.com/HF/experiment/furTest2.fbx
Do not mind the seams.


#6

thinks this is fixed now so yay


#7

Only partially, the lighting issue is still there. and occasionally disspearing alphaed object as seen above.


#8

well my inside out buildings are back to normal but the ambient reflections seem to be dead


^