Build tools troubles


#1

Not much improvment with the build tools. it only got worse. Still cannot get in bird view when you edit. tried it with clicking on the object and press ‘p’ then i zoom in on the object. But still cannot get my cam moved into bird view. or i use the wrong key. Also the mouse movement is way to fast. more people complained about that with mouselook. but in build tools it’s triple worse after pressing the ‘p’ key.

Resizing the object, It’s like playing the lottery. most times it fail sometimes it work. In this case i just wanted to make the object bigger. so you grab a corner and start pulling. Instead it’s resizing all directions it’s only going one way.

It still seems that new uplouded items go in ghost mode. i see the tree but cvannot select it. finaly seen it in the entities list and selected the tree from there. a living ghost, pfuuu.

And where are the movement arrows people want for more then 12 months to move object normally with mouse in X and Z direction.


#2

Did you do the double tap F in edit mode with the object selected thing?


#3

:blush: Hmm no, i used the wrong key, i forgot it where ‘F’ and i think it’s nowhere in the menu to that function ?

Thanks @judas, until the next time i forget it.


#4

just think whats the F*^%^ key i have to press


#5

The F*^%^ key worked !, mouse movement is also much better then the default one.


#6

Arrrgh , F*^%^. the broke the F*^%^ key in build 3920.
Everytime i think i found something todo in high fidelity the removing it, breaking it. or it just vanish.

Now i can do again nothing. the default build tool is crap. Offcourse i like the new properties window (can the font bigger !) but i cann ot place the objects now. Because the still refuse to add the X and Z arrow. That would fix the problem to.

How long before the F key in edit tools is fixt again ?


#7

We’re working on a possible design that includes a ‘scale’ control on the frame, so you can change the overall scale of the window for better visibility.


#8

Anyway, the Del key seems to fail to in the latest build in edit mode. cannot delete entity anymore the normal way.


#9

Keyboard shortcuts right now are kind of hit or miss, because of issues with focus. I’m actively working on the issue.


#10

So the core issue, if you’re interested, is that we have to do our own concept of ‘keyboard focus’ management in the in-application UI. Normally the OS does this for you.

Previously if you brought up the entity properties, they showed up in tabs in a new desktop window. If you have the rendering window of Interface focused, then there’s no way the entity properties window can interfere with them…

Fast-forward to the new mechanism, where entity properties are displayed in a window rendered in-world. This is great because it means that you can edit entities while wearing an HMD. However, it also means that those entity property controls can capture keyboard events away from the application. In particular, any in-world window which contains rendered HTML is using a QML WebEngineView, which will, if it has focus, consume every last keyboard event.

The solution is to emulate the OS level behavior that people are used to. We already have functionality where if multiple windows were opened you could move focus between them by clicking on a given window or it’s frame. What was missing was the ability to unfocus all windows by clicking somewhere else… the equivalent of clicking on your desktop in a normal context.

Fortunately I believe this commit will fix that problem. In my local testing, I was able to click the edit button to bring up the entity properties in world, but when I click on an item in the world, the entity properties window loses focus, so I’m able to use keyboard shortcuts such as Delete to act on the entity.

We’ll be doing greater polish on the in-application windowing system in the future and hopefully be able to add things like visual indicators for when a window is focused or unfocused, just like you see on a normal desktop.