Buildings not rezzing properly


#1

I built two little houses on my plot, they looked fine for a day or two, now they dont seem to properly resolve into their correct resolution.
the 2 houses on my plot have devolved into about 10 fat voxels where they were once a few thousand, once two houses now look like a dozen random boxes.
I have moved around, logged in and out, and tried a few things but they never change from the few blocks that they have become.
On the plot across the strip from me I built one green house and now it is just the back gable and wall, and not much else.

I can easily rebuild because they are scripted builds but I was hoping to gain some knowledge in this area before I do this.

Thanks
Adrian


#2

I’ve been trying to lay a complex layer on my plot and it always ends up looking like it only could run for a time. I’m wondering if it’s there but I can’t see it, or if it’s genuinely not finishing and needs to be broken up into separate scripts.


#3

I think it could be a good time to start adding some additional assignment clients to Alpha.highfidelity.io .I will send out an email to Alpha to get some volunteers.


#4

Ok but that doesnt answer my question in any way.
Has my building degenerated for some reason, or is my system failing to rez properly for some reason, or is the server failing to rez or save properly, or has someone simply clicked around and messed it all up?


#5

@adrian Could you take a photo of your location? You could also of had a situation where someone removed or went over the top of your Voxels.

@BluemanSteele Have you looked at Voxels.setPacketsPerSecond(number); to slow down how quickly the voxels are getting created, then also use Voxels.hasPacketsToSend(); to make sure the script keeps running until the voxels have been created.


#6

@Chris Actually I was just rezzing 100’s (if not 1000’s) directly in a “for” statement >.<

I’ll look up those functions and start to see about throttling it into pieces. TY!


#7

@Chris
I started looking here: https://github.com/highfidelity/hifi/wiki/Javascript-API but I can’t find the list of functions that include Voxels.setPacketsPerSecond or Voxels.hasPacketsToSend. Can someone point me in the right direction?


#8

Hi @BluemanSteele it looks like it has not been documented, that page needs to be updated. I have actually created a worklist job to have that page updated if you or anyone else is interested. https://worklist.net/19646


#9

@chris
I had taken a snapshot before it broke, so I took another snap before I fixed it.
looking at the broken one if you use your imagination you can see some remnants of the original colours of blues and pinks on the left and remnants of the brown house on the right.

I still dont know what caused it but because to me it looks like what it might have looked like from a distance, thats why I thought rez issue, but it could be people just clicking around

before

I deleted the voxels and started again, no prob for me but it is really easy to bump other peoples stuff, just clicking around causes damage somewhere. (oops my finger slipped)


#10

@adrian are these buildings still in world? If so can you tell me their location? I’d like to see how I render them.


#11

The buildings are still inworld but the problem no longer exists, I have come to the conclusion that they were accidentally damaged somehow, it was not a rez issue, it was a damage issue, anyway I fixed them and they got broken again by someone placing a massive voxel right across the strip, I have again fixed them and at last visit they were ok.
They are on the Strip on Eves plot 6040, 245, 5200 or there abouts, or you can use location #adrianshouse


#12

Taking a look, I was not able to rez anything there. I tried to adjust my LOD settings but could not get better than…

I restarted, but didn’t get much more detail.


#13

@BluemanSteele That is strange, this is what I see from the same location today