Cannot get Textures to import with models


#1

I was wondering if there was a set of guidelines in place with Blender export settings or any kind of framework for saving a model and importing it into HiFi.

I have tried a lot of different models with no success.

I downloaded


and tried converting my models and that did not fix the problem either.

Any ideas?


#2

If your model has only a single texture of any kind you can pack the texture into the FBX and it will work without issue 99% of the time. Set Path Mode to Copy and push the button right next to it that enables packed textures.

If your model has multiple textures, packed textures will not work (Blender produces a screwed up FBX when packing multiple textures for some reason, not HiFi’s fault). EDIT: Apparently this is a bug that doesn’t happen to everyone, others below have had no trouble packing multiple textures into the FBX, try it and see if it does for you.

If you don’t want to pack textures into the FBX, Set Path Mode to Auto. You will need to create a FST file that tells HiFi where the texture directory is online (a Photobucket album will usually work). Look up the FST format on the Wiki or here on the forum for more details.

Also, forgot to mention, if your model does not have anything transparent on it, make sure Transparency is completely off. If it’s turned on when it shouldn’t be (and you do not have an alpha texture set), your whole model will be invisible. If your model does use a non-opaque material, use Mask transparency mode, not Z-Transparency or Raytrace.


#3

I’m not sure what your issue is here because I have always been able to pack multiple textures in my fbx exports, and they work fine.
The main thing is that each texture should be in its own separate material slot.
There are 2 places to set for embedding textures, one as you mention at the export FBX panel to set path to copy and check the box for pack texture, but also on the textures panel on the properties window put a check in the box next to the source image.
I also put a check in “automatically pack into .blend” under External data on the File menu.


#4

The thread you read is quite old, so it is good to look at the dates on posts in a thread, to see if something is uptodate or not.

First make sure your textures are not TGA. This is the most common issue that I see occur.

Second, Check out this thread if using Blender to do assets

It has all quite uptodate info on pretty much everything Blender. I hope that Helps.


#5

If you can only have a single texture per material, that leaves only room for a diffuse/albedo texture. That means you can not use normal maps, roughness maps, etc. That’s not acceptable for the majority of the models I make.

But either way, for me, it doesn’t matter if the textures are in separate materials, it still doesn’t work. I don’t know why. If I have a model with multiple materials, each only with 1 texture, Blender for some reason produces a FBX where all of the material textures have been replaced only by a single one. I’m using 2.78a. I had a friend experience the same issue, he tried for days and could not get a simple avatar into HiFI without all the textures screwing up, if the textures were FBX-embedded.

Also I am speaking strictly about packing into the FBX file, not into the .blend. Those are completely unrelated things that don’t affect each other. If you pack textures into the .blend, those textures don’t automatically get embedded into the FBX, you still have to set the correct FBX export settings to pack them.


#6

Per material, you can embed in the FBX - diffuse (albedo), normal, metallic and roughness if using PBR methodology.

I have multiple models with > 10 materials, each assigned the full PBR “stack” and embedded in FBX. It’s somewhat easier to do with Maya/Maya LT, if you have it, but once you memorize how to assign textures to proper channels in blender it’s just about as easy. The key in blender is setting the option to copy in FBX exporter in blender and make sure you click the microscopic icon by that pulldown – that should be covered in the other recent docs.

And yes - TGA will bite you in the nether regions. Oddly enough - TGA sometimes works - it all depends on if the QImage formats library from QT was built with TGA support or not. Best to use PNG or JPG.


#7

But you can have multiple textures per material, diffuse, normals, emit, spec etc.[quote=“PetVal, post:5, topic:12325”]
it still doesn’t work. I don’t know why.
[/quote]

Doesnt work for you maybe, but it does work, you are missing something in your workflow.

This occurs when the second and further materials have not been assigned to the UV properly.
It happened to me too until I learned how to properly assign and pack and embed textures.

Sorry but thats not correct, textures must be packed into the .blend before they can be embedded into the fbx.
And let me remind you that I can pack multiple textures and you cannot, so do you think you should be telling me I am doing it wrongly before you give it a try?


And yes you still have to set path mode to copy and set to embed textures at the FBX export panel.


#8

Hey @Adrian and @PetVal, could you move the discussion on the packing to another thread? It does work, but there are also bugs with it which I wont get in here.


#9

@Menithal Err but that is what this thread is about, I am just answering questions raised here.


#10

Sorry but thats not correct, textures must be packed into the .blend before they can be embedded into the fbx.

I’ve never packed textures into the .blend, and despite that, Blender has still packed at least 1 single texture correctly into the FBX (but not more than that 1), which was why I thought packing into the .blend was unnecessary. Why does it pack one texture into the FBX correctly (even if that texture is not packed to .blend) but not multiple? That still sounds like a bug to me.

Sorry Menithal, this will be my last post on the topic.


#11

But it is not the Original Poster’s question. Only leads to more confusion. and information being lost in derailed threads.


#12

I’m not speaking of packing in a blend file - never have packed them in blend file, I’m speaking of embedding the texture assets into an export FBX file only. When someone speaks of having issue with cannot get textures to import with models - it’s 1) TGA mayhem 2) Not setting blender to copy and embed textures or 3) FBX didn’t have the textures embedded (set to automatic for FBX exporter) and when the FBX is loaded it’s looking for textures from the source server be it ATP or HTTP. So I’m not sure how/why the comment I have should be moved to another thread as it’s absolutely material (no pun intended) to the topic of this thread.


#13

giggles


#15

@noahglaseruc Sorry about not addressing your exact issue.

Menithals extensive documentation covers a lot of ground, its the closest thing we have to a set of guidelines.

To fix the problem we need to identify the problem.
Tell us what you are able to do, and at what point does it fail. Does the object come in with the wrong texture or no texture? Or does it fail to appear.
Also look at the logs (CTRL/Shift/L) and it should say something about the attempted import, like missing texture or some other valuable hint.

You usually dont need to convert anything if you made it in blender, if you are using someone elses FBX then that needs to be looked at, open it in Blender, trying to import an FBX off the shelf is very hit and miss because of Hifi’s specific needs. If you need to convert a model, do it in Blender.


#16

I use multiple textures and multiple materials on fbx imported models in HiFi (both embedded in the fbx file with copy and as non-embedded textures) without problems. One problem I have had in the past was with naming of the textures (and materials?). In Blender, the default names for materials and textures are always material.001, texture.001 etc. or something.

If I had an fbx file that had multiple objects with default names, I would end up only seeing the first one on all objects. To solve this, I just make it a habit to make a unique name for each material and texture and it seems to solve the problem.

You might want to try renaming everything and see if it works for you. And (at least in Blender) exporting the fbx in Copy Path Mode with the embed textures button enabled will cause the fbx file to include the texture (which is ok for a lot of simple things but can lag load times if the same texture is used in other places nearby).


#17

When I import models they are showing up in HiFi, but as a grayed out non-textured version. The first time I imported a model it came up with the proper texture. And every time since then has been gray - unless they come from this Clara.io site.

I am mostly playing with 3rd party models right now so i do not have any of this work flow of actually creating or assigning the model textures.

For instance, I have a bunch of buildings from my university’s simulations lab. When I import them they show up as gray. I was able to open them in clara.io’s editor and redrag the textures into their respective slots. When I did that and imported them again the textures were there.

But I cannot anything to keep the texture unless I go through this clara site.


#18

It seems that the models I am using are using references for the textures instead of having them embedded within the fbx file.

I need to re-render them with the references embedded into the model? I saw the following info on a HiFi article.

Binary FBX 2014/15, Tangents & Binormals checked, as well as Embed Media checked

Will check to see if these settings fix my problems.