Cannot hear other people


#1

I’ve just compiled latest GitHub build on Linux (Ubuntu 14.04.2).
While I can hear my local audio (when set to Echo it) or some script sounds (stargate teleport sound), I cannot hear other users’ sounds when their avatars’ mouths move which suggests they’re speaking.
When I turned on the audio scope, it seems to show some soundwaves, but I hear nothing.
I’ve checked pavucontrol and other audio settings and tried using both headphones and speakers.
What may cause the problem?
I couldn’t find anything relevant in the log, but not sure what to look for.


#2

That you hear your local audio is a good start, can you hear yourself if you turn “echo local audio” off and turn “echo server audio” on? that will prove if your audio is being transmitted and audio is being received.

There could be several issues but first thing to try is to set the mic and headset before you start interface.
If you change the audio devices while running, the changes wont take effect until next startup.

Try deleting the Interface.ini file located in (Windows) C:/Users/“owner”/AppData/Roaming/HighFidelity/interface.ini
and restart the interface. This will reset all to defaults and its a good place to start troubleshooting.


#3

Ok, so I removed the interface.ini file to reset everything but it didn’t really change much.

Afterwards, an additional speaking indicator showed up (the robot face) and I could see myself speaking there and in the scope.
Also if I had Echo Local on, I could hear myself, but when I had it off and Echo Server on, I could still see the soundwaves and the speaking indicator but couldn’t hear myself.
I also grepped log for audio, but there isn’t really anything interesting there.

As of now, I suppose the audio playback works correctly and the issue may in fact be in the communication between the audio server and my client, as I could see other’s people mouths moving but couldn’t hear them and the animation seems to be handled by another server than audio, so that might be it.

UPDATE: I’ve compiled and ran the assignment client and after it I could hear myself (on echo server) and some voices.
However a few moments later I couldn’t hear anything as before. I tried running assignment client with -n 4 or -type audio, but it didn’t really help. I only managed to hear myself for a short while when switching servers.

If I were to guess, I cannot hear myself or others with other players around, so maybe I can only hear audio when I’m connected to my local AC or something?
Do you think forwarding ports for the AC could help the issue? Or what else may it be? I could hear people for a while, but without changing anything it stopped working then. I tried removing interface.ini again, with no effect.