Cannot load fbx models


#1

Feeling very newbie right now, but I have tried for weeks to load .fbx models without success.

Example: http://dl-web.dropbox.com/s/tzt1vivkugohlxb/Grassy%20terrain2.fbx

This is a dirt simple (and ugly) model. I can load using Visual Studio 2012. Blender sees it, but not here.

Here is another example taken from one of the free sites. I can load this one using Visual studio using this link:

http://dl-web.dropbox.com/s/p9ycnwxpzpwp998/Fantasy%20yatch.fbx

I tried binary format, ascii format. So can anyone explain which version of .fbx interface supports???

In interface, I click on Edit, then upload, enter the above links for the model name, and nothing is rendered. The entity gets created, the properties are correct, but nothing renders. Can someone please help?

Or, is it that dropbox has banned any http GETs from high fidelity user agents?


#2

High Fidelity uses reverse engineered FBX 2013 standard format (7.4+), so any versions beyond that.
Most of the documentation on on Blender, FST and FBX can be found at :

https://alphas.highfidelity.io/t/blender-compendium-and-woes-of-the-blender-fbx-export-at-the-mountains-of-documentation-madness/4739

The format is FBX Binary, as ASCII support was dropped a while ago. Basically everything aside of vertex colors and armatures works currently as they should. Just make sure to have a material on the model (need to create a check list for common issues)

Cant say much about dropbox, but it has been a trend that if something gets more and more traffic they will monitor the situation and throttle. With Hifis assets traffic can get pretty high as people keep refreshing their cache / cache doesnt work as it should. I suggest just loading a local LAMPP (XAMPP) server to test your models on and then later on migrating to a proper web host. Spoofing my agent doesn’t seem to get have an issue, and its not the models them selves as I can add them without an issue if I transfer them over to my own web server.

But, you cant even see it being added to the world as a green cube anymore (so its doesnt even shop up in the list)
So in the firstplace its not even getting added to the domain.
The models them selves work fine, its just that the pasted link from drop box aint working. (Copied them over).

Unfortunately only log message I get is

script:print()<< "Model added: http://dl-web.dropbox.com/s/tzt1vivkugohlxb/Grassy%20terrain2.fbx"

UNEXPECTED!!!! after updateEntity() we no longer have a containing element??? entityID= [entity-id: "{9ac55a69-caa4-417e-a3d1-a7d5c2f6c112}" ]

#3

If I paste those links to my WEB browser, I get the download commencing stuff, so the links are good, and as I wrote, I used Visual Studio to go to the same links and they work. I guess then I must be the format version. I’ll see about trying older formats. BTW, I only tried ASCII to see if interface was horking on binary loads. Made no difference.

And yes, I had many invisible model boxes littering my domain. I went into the entity toolbox window and manually deleted them all. Thanks for the help!


#4

In simpler english:

  • Use binary, it works.
  • Your models currently load fine, but the urls are broken in Hifi. ( I downloaded off onto my own server, and they worked fine)
  • Alas, The dropbox urls wont work anylonger in Hifi. DropBox seems to block connections from client.

#5

OK, it’s dropbox, they must be banning HF requests. I jut uploaded to my WEB server, and it works OK:

https://skyote.com/hf/Grassy%20terrain2.fbx


#6

Everybody is using Amazon to upload mesh models to HIFI. It is more straight forward. I do not understand all the I can load using Visual Studio 2012. Blender sees it, but not here. I am not sure why you need Visual Studio 2012. Maybe you meant the Microsoft FTP,Internet Information Services (IIS) Manager.


#7

MSVS has an ok FBX reader as well, its a bit unconventional, but it works.


#8

It’s called breadth testing, trying to find the root cause. The problem could have been incompatible fbx format (there are several interface does not support), could have been many reasons. I used VS2012 just to verify that 1. the model was not corrupt, and 2. that the link worked.

What threw me off was that I had it working just fine for a short while loading models from dropbox. Then it stopped working. Given this place and the codebase is alpha, it is difficult to determine if the bug arose from a change to interface, or, something external to it. This particular problem is now understood. Dropbox services are deliberately refusing GET requests from interface clients.

I do recommend that the introduction to HF video, which suggests people use dropbox as the place to store models, be redone or redited.


#9

Yeah this should definetly be reiterated to remove the recommendation of dropbox.