Can't quit out of HF server to let new Interface install.... oO


#1

Okay, I went to install the newest windoze HighFidelity-Alpha version, and it popped up the usual notice that I need to quit out of the server system to let it install. So, I went over to the notification area icons pane and… the HF icon is not there! OO

I tried going to Start > All Programs > High Fidelity and launching the Server Console from there, but still no icon in the notification pane and no command windows came up. I figured, “Okay, I’ll kill it from Task Manager…” and launched that. There are no tasks I can easily identify as related to HF in there, other than the installer task.

How the heck do I shut down the HF server system when everything I can go to shows nothing remotely related to HF on it?!?


#2

You’ll be looking for assignment-client.exe and/or domain-server.exe.

The message that tells you what is stuck open should give you the exact name of the executable we’re waiting for you to close. What does it say?

server-console.exe would be the other thing you would need to be shut down.


#3

okay, I had 7 iterations of assignnment-client.exe running,and one iteration of domain-server.exe. And the High-Fidelity Setup (that is, the installer) is telling me Server Console is running. Killing those tasks you named now…

edit: And then there were TWO instances of domain-server.exe when I got down to kill that one. Anyway, installing new HF version now.


#4

The console icon often ends up in the hidden icons section of the notification area (see photo below). Click on the ^ icon to show the hidden notification icons. Then you can click and drag the HF console icon to the notification bar. I think this is an installer bug that neglects to set the icon’s property to “always show”.


#5

Wait … is that an option we can set? I don’t think it is.

I had done some research to see if we could force it to be in the tray and visible but I thought I found that the user would have to drag it down and pin it manually.


#6

I am fairly certain this can be done in the installer - looking for the docs on that.
https://msdn.microsoft.com/en-us/library/windows/desktop/ee330740(v=vs.85).aspx


#7

Yeah, usually my HiFi icon is in that hidden notification area… but this time it seemed to have disappeared completely. oO