Cant select by clicking object


#1

This has been reported before but I am giving a gentle reminder because this function is critical, and yet not working properly. I cant select an object by clicking it, much of the time.
I cant find a pattern to this malfunction, distance away, size on screen, the way I hold my mouth, nothing has any perceivable effect.

The system just ignores more than half of my clicks on screen, no matter what I click.

In fact there is something really wrong with the whole click function not just entities, it just ignores most of the clicks, I can click till the cows come home and nothing happens.


#2

I’ve noticed this lately too. For me it seems to happen most with objects that have an alpha channel. I sometimes have better luck clicking on plain box or sphere entities than I do on models or even fields in QML overlays etc.

Like @Adrian said, it is hard to find a pattern with it.


#3

I started getting instances of an object not being clickable, and not even showing up in the list.

It was like it didnt exist. but I could see it. Then another object, I moved it and suddenly I couldnt select it or see it on the list.

When a third object got orphaned like that I decided to restart the server.

After restart, I had no trouble clicking everything, it was cured. So I wouldnt say the problem doesnt exist, but it seems resolvable with a server restart.

@Twa_Hinkle does restart work for you? if so I will modify the title of this thread.


#4

I think this has something to do with a desync of where the entity is according to the server, and where the client thinks the entity is at (where it is rendered), but the physics is somewhere completely different (thus Camera.computePickRay / Entities.findRayIntersection isnt hitting to “select” the entity).

I’ve had this happen too, with the server reset / reconnection fixing the issue. But they need to fix it definitely to avoid frustration, as this is easilly a big source of it (and not everyone has the capability to restart the domain they are in).


#5

Afraid am so worked around this bug that i did not notice it anymore. besides most of the time inworld object is bad clickable. Most of the time i use the entities list. Works faster…


#6

Well, i noticed this in a very heavy bad way. I cannot select entities soemates at all. also selecting it from the entities list is failing. Until a relog, then it seems to work again. i need to install the latest version. more weird things happen like keys that not respond anymore.

It’s also not selectable when i look at it ! Until i did press reload in the entities list.
I think it’s failing also more when you work in 1 person look.

It’s also not working when your inside the building and want to select that one. you need todo difficult and zoom complete out to get a click on it.


#7

BUMP…
This is still a problem.
Some objects cannot be clicked to select, they just ignore, and the click falls onto the object behind as if it doesnt exist.

This has been an issue for quite a while now and no explanation as to why it happens will help anybody.
It needs to be fixed.
It will be considered a major flaw, imagine clicking something and it just wont be clicked.
It broken and cause frustration to me and I have several workarounds and enormous patience (hard to imagine I know), to the untrained it will be a game breaker.
Please give it some priority.


#8

There’s hugh bug when n edit mode and you want to click some object. and this with the default edit tool.

It happens to many times that object in the distance get selected instead of the object you click in the front. With all the disasters as result, moving. deleting. lucky there’s undo function. This also happens because you think the right object is selected.

To get the right object selected you need to move away from it with you avatar. meh. Not to talk about try to click on very tiny object. impossible.


#9

do you have a test scene i can come visit and see what’s going on? everyone’s arrangement of objects is pretty unique. in the past i’ve run into not being able to click on entities for a couple of reasons, including: invisible objects between you and the object you clicked, being inside of another object and trying to click out, or sometimes the angle between the object and camera (when very flat). i’m sure we can address these issues! specifically reproducible cases will help speed things along. i appreciate the observations and also feel the pain when this stuff doesn’t work.

also, just to be clear you’re using a mouse click in 2D edit mode, correct? not the hand controllers. and are you selecting entities or menus? the more info the better! :slight_smile:


#10

As another potential clue – I think my Entity click handlers (like from Entity Scripts) might actually still be firing when this situation happens – even though ray casting isn’t apparently seeing the Entity anymore.

Haven’t been able to confirm this yet, but am going to set the following trap next time it happens to verify:

function hittest(hint, evt) {
  var ray = Camera.computePickRay(evt.x, evt.y),
      o = Overlays.findRayIntersection(ray),
      e = Entities.findRayIntersection(ray, true);

  o.intersects && print('['+hint+'] overlay hit', o.overlayID)
  e.intersects && print('['+hint+'] entity hit', e.entityID, e.accurate, JSON.stringify(e.properties.position), JSON.stringify(Entities.getEntityProperties(e.entityID).position))
}

Entities.mousePressOnEntity.connect(function(uuid, evt) {
  print('[mousePressOnEntity] entity hit', uuid, JSON.stringify(Entities.getEntityProperties(uuid).position));
});

Controller.mousePressEvent.connect(function(evt) {
  hittest('mousePressEvent', evt);
});

#11

Thanks for your fast reply.
This is an issue and has been for months now. I ran into all those other issues you describe for myself.

Using regular mouse in 2D, selecting models, I have never seen it happen with an entity, just uploaded models.

This is a constant issue, lots of people have seen it, and its pretty regular.
It happens every day several times a day in any and all situations.

@Richardus.Raymaker describes it exactly.

When an object loses its identity or whatever happens, its gone for all click intents and purposes, I cant click it from any angle no matter how I hold my mouse, it is invisible to the click. There seems to be a problem with the servers association with the object, I move close and further away no click, I change my angle no click, I even relog still no click, the only thing that reliably brings the click back is to restart the server.

I can however always select it from the Entity list, and in some cases this selecting from the list restores the clickability, but not always.

As Richardus describes, your click lands on the object BEHIND the subject so this rules out me being inside an entity, and rules out something in front of the entity, and rules out a bad click. There is a click but it misses the target and hits whatever object is directly behind it, once it happens to an object it will do this reliably until I reboot the server.

Generally it happens when I first import an object, about 5% of the time, when I click off the imported object to another object, I cannot click the first object back again, I have replicated this on an empty field with just one entity.
But it cannot be reliably replicated, I can work for 3 hours and not see the issue. then it might happen for 3 objects on the scene within minutes.

Thanks for looking into this.


#12

This is the only thing I’ve been able to use to “kick-start” the solution when the problem occurs. Yes, I’ve dealt with it too, just wasn’t entirely sure if it was a “feature” or not. :blush: