Cant select newly created entities / model server not starting


#1

New stack manager was running nicely until I added birdsong script to a sphere, everything crashed, when I restarted everything was stable so I tried again and it worked, I restarted again and restarted stack manager and all seemed fine.

So I went to create some entities, and the entities appeared but I could not select them, I noticed I only had 4 servers running so I restarted the stack manager and interface and no entities showed up at all and only 4 servers are running. Now no matter how many times I restart the stack the models dont appear.

I get this line repeating in the server logs
"[WARNING] [12/04 21:57:06] QSslSocket: cannot call unresolved function SSL_get0_next_proto_negotiated"

(My models.svo file looks ok now, it was prone to eating itself and deleting certain entities every time, but I deleted those ones and replaced them and that seemed fixed that problem)


#2

Solved.

My Bad. As I said above I did this… " I added birdsong script to a sphere"

Dont do that, after studying the script format and developing some entity docs it becomes clear that normal Javascript scripts CANT be used in Entities, this was causing my problems.

The special javascript functions found here https://alphas.highfidelity.io/t/attaching-scripts-to-entities/1086 are the ones to use.
“The format of the script should be a JavaScript class prototype function” so only put these ones in Entities.

So hopefully this may save others from trashing their models list.