Can't start domain server under Ubuntu Budgie 18.04


#1

Hello all ;D
I have compile the source without problems, but the way is a little bit tricky. So my problem is the start from the domain-server. I use UBuntu Budgie 18.04, when I start then comes this in the console
https://paste.md-5.net/bogonovado.vhdl

Had everyone what is the problem ?

Edit: Sorry, now had the PasteBin text ;D

Have a nice Day ;D

Bogus


#2

Are you sure there’s nothing else running on port 40100? have you tried another port?


#3

yes, I have compile the source local on my pc ;D


#4

What’s the output of netstat -tulpn?


#5

https://paste.md-5.net/gemivubuho.hs


#6

Line 12…

tcp        0      0 0.0.0.0:40100           0.0.0.0:*               LISTEN      - 

Hmm… Shouldn’t matter, but 40100 and 40101 have to be open (the domain server does offer HTTPS, but it shouldn’t matter).

After reading my notes, sadly there’s no way to change 40100 like you can with assignment-clients.


#7

Is Maybe a bug?

The Forum makes me total confused here … lol


#8

I would strongly suggest using a dedicated server for this. Guessing from the fact that you have kde-connect running, i’m guessing this is your personal day-to-day use operating system. There are just so many variables involved.


#9

Yes, I know, but was only a test for first compile from the build. And I remember me, that I have a crontrab for the domain and asset server. That stand so in the Cheatsheet

0 */1 * * * root apt-get update
1 */1 * * * root apt-get install --only-upgrade -y hifi-domain-server
2 */1 * * * root apt-get install --only-upgrade -y hifi-assignment-client

I will that delete make a restart from my pc ;D

Thanks for your help ;D

Edit: I come in the settings from the domain-server, but I can not run the domain server ? Hmm …


#10

The domain server is the manager for the assignment clients. You can check this under Nodes:

You will now need to launch a few assignment clients, all of which by default do not have consistent ports by default.

Unless you are using the apt-get version. Then I have no idea since it’s supposed to start that up automatically.


#11

Yes, that I have check, but I have no content in my Home location.


#12

Hi there ;D
So now I have time to test ;D When I start the asset server, become I this
https://paste.md-5.net/tosiyajuki.vhdl

Greetings
Bogus


#13

are you running this as superuser? Or what user are you under?


#14

Hmmm … I run now with sudo, is the same problem ;( no content in the sandbox …


#15

Sounds like the assignment client isn’t starting for some reason.
Have you tried support@highfidelity.com? Sometimes they can help with server issues


#16

Ok. I have mail send to support from hifi, they mean Linux make in moment avaible, but they make support, only over forum. I should pls use the ppa from hifi.

I understand the point, but I think is very sad for a opensource project that linux no direkt supported … very very sad …