Captain's Log 3.14159265359


#1

I have decided to keep a record of progress made to the domain while the Console and Interface continue to push into Beta. A recent integration port of the “where the river goes” shader has introduced interesting side effects. I will require a rework of the camera, this time without removing it entirely from the shader. Admittedly, I was uncertain if the shader would simply crash interface on the “other machine” that I use as a moderate testing box. To my surprise the machine does load the shader, but will require much optimization to really get things to acceptable levels.


#2

Unknown Physics problems. @Chris I have a lot of physics shapes in this project. Would you or one of the devs have time to take a look? Consider the following:
This is the physics hull shown, note there is zero collision plane, but I am resting upon something in mid-air… ???


Same image, physics hull rendering hidden… still standing upon nothing…??? Note, I am NOT floating… I am standing.

I realize you guys are mega busy right now, but honestly, if physics with hand controllers is the next big things, I as well as many others are going to have many hurdles to overcome. Any idea what is going on with this?

Anyone else feel free to chime in… I’m stumped. cc:@thoys @ctrlaltdavid


#3

Make sure each Physics component is convex, and as separate objects (not of the same object instance, but separate objects within the physics file). There currently is no automatic generation of this within High Fidelity. You can use tools such as VHACD to generate these but they will need manual adjustment.

You can also do the quick and easy method on your current physical hull, but I suggest avoiding it.

Secondary thing is that I think objs currently are the only method for physics hulls.


#4

These are good techniques, checks and balances. Unfortunately, the only thing I can think of is there is a complex object lurking that is not behaving or my current thesis: there is a bug in physics. :slightly_smiling: Users of VHACD will find me foolish for not using the tool; and honestly, I don’t mind the work. The Physics hull has been hand-made. I must have just missed something, but where…


#5

Lately I like to blame a lot of my problems here on cache and have gone back to making unique names for every version of every model, texture, script, physics hull etc. And sometimes even changing names of an embedded URL has not seemed to work right.

Have you tried loading just the physics hull without the rest of the boat or is that what you are doing in the top photo?


#6

I have not tried loading the phull alone, and then applying the phull to itself. I will try that this afternoon. The strange thing is, the gap was working for the longest time, and then it stopped working. In fact, it was such a problem gap, placing the railings in was the next logical step to prevent fall in. So I put up barriers all around and tested it. It was fine. Fast forward a few months and now the gap is not true. Strange.


#7

Can you send me the hifi link to that location?


#8

hifi://QueenCity/7.0,-11.0,-29.0

Thanks @chris


#9

VHACD is presently buggy. But even when it works there is a hypercurve parameter (forgot what it’s called in the app) that determines at what point a curve is not strong enough to follow it. In that case VHACD will ignore the ‘hole’ and that can cause the effect you are witnessing.

So, yes, I understand why you’d not use VHACD yet. I think you missed an object or maybe you ran into the bug where a built in cube or sphere entity, when downsized, does not downsize the physics shape.


#10

I really appreciate this recommendation. I WAS creating things here and there, and doing some resizing. Maybe I’ll check that, but in this situation, there is nothing left in the edit list of entities on a 10,000 meter sweep. Am I still searching for a phantom physics box?


#11

Resolved.
Now I need to figure out which revision of my PHULL caused this. Maybe it’s time to stop blaming the software…


#12

A cube has six sides. Take off the top, now take off the bottom, and remove one of the remaining 4 faces. You will NOT have a convex hull and it does violate the rules. I didn’t think it would, but it does. The physics engine CLOSES the cube. My mistake. This is what my Captain’s Log is for. The advancement of knowledge.

The breakdown of what happened:

• Created this deck and was making mods for stairs.
• Decided I would make the railings into a single object using the box method above.
• Tested it and forgot about it.

I modded the railings again, and now the hole and gap and stairs are working great. The glass walls (i keep calling it a railing) must be unique. I know shame on me for not double checking for convex.


#13

Bullet and physx require manifold physics shapes. Give a non manifold to physx and it will throw an exception. From your description it looks like bullet ’ repairs ’ the shape.


#14

I thought I read somewhere that Bullet physics implemented in HiFi didn’t like using planes as physical entities. I think it was mentioned in a post on converting mesh terrain planes into physics convex hulls.

Sounds like @Balpien_Hammere’s manifold explanation above, although in the Bullet physics docs I didn’t see any explicit requirement, just that if used, they might slow things down. Maybe what happens is a bounding box is used to represent it, filling in the missing faces

I am surprised that the “three sides of a cube” thing works at all. Unless you went back and turned them into three separate objects.

I’ve tried to be frugal adding physics shapes to here (and always, sort of by hand), because even if invisible and use little download bandwidth, the run time cost to the rendering rate can become a problem, especially with more than one avatar or physical object present.

I notice that you are simplifying shapes by representing the curved railing with a flat surface, which is good. Let us know anything else you find out while adding physics and remapping that cool shader and stuff to your build. It is looking good!


#15

Yes, this is exactly how I solved the issue. However, @chris it must still be taken into account that we have a bug in the Physics Hull rendering.

There are screenshots of the “closed cube - invisible collision” but a finalized Physics Hull Rendering would have displayed this issue to me immediately. Instead, I went on a wild-goose chase through 18 different revision hulls trying to find it. If the “Show Physics Hull” rendered the “closed cube” problem this error on my part would have been trivial to correct.

I try to catch more flies with honey than with vinegar, but I’ve got a QA on PHull coming up next month (March) and this tool (Show Physics Hull) really needs to be fully functional for that to be successful. Do you guys have room for it in your work flow? I’ll provide an easier representation of the problem in the slides to come. This time it will be with a basic cube in blender, sides removed, show PHull in HF.

fig1 - a test ground squished cube all sides - a manifold object

fig2 - a test barrier squished cube all sides - awaiting side removal


fig3 - a test barrier squished cube with faces removed in edit mode

fig4 - the test ground is removed and the barrier is then selected for OBJ export

fig5 - the barrier is brought into HF as a rendered OBJ, with PHULL of same applied
fig5 - pending fix of:…

[02/17 10:07:09] [DEBUG] Starting request for: http://metaversecafes.com/images/barrier_OUT.fbx
[02/17 10:07:09] [DEBUG] script:print()<< EBL CAN'ZT CLOSE WEB VIEW- IT DOESNT EXISTS!
[02/17 10:07:09] [DEBUG] script:print()<<   Delete Entity.... not holding...
[02/17 10:07:09] [DEBUG] script:print()<<   Delete Entity.... not holding...
[02/17 10:07:09] [DEBUG] script:print()<<   Delete Entity.... not holding...
[02/17 10:07:09] [DEBUG] UNEXPECTED!!!!  EntityTree::deleteEntities() entityID doesn't exist!!! entityID= [entity-id: "{5a3c77d2-36bb-4579-afdd-5bd7454f53d4}" ]
[02/17 10:07:11] [DEBUG] Focus item is QtWebEngineCore::RenderWidgetHostViewQtDelegateQuick(0x255a7a00)
[02/17 10:07:11] [DEBUG] Focus item is QtWebEngineCore::RenderWidgetHostViewQtDelegateQuick(0x174b9c70)
[02/17 10:07:16] [DEBUG] Focus item is Desktop_QMLTYPE_139(0xa50d6d0, "desktop")
[02/17 10:07:16] [DEBUG] script:print()<< rotate handle case...
[02/17 10:07:16] [DEBUG] script:print()<<     somethingClicked:false
[02/17 10:07:16] [DEBUG] script:print()<<                 mode:UNKNOWN
[02/17 10:07:17] [WARNING] [UncaughtException] TypeError: Result of expression 'Window.setCursorVisible' [undefined] is not a function. in http://s3.amazonaws.com/hifi-public/scripts/edit.js:387
[02/17 10:07:17] [WARNING] [Backtrace]
[02/17 10:07:17] [WARNING]     <anonymous>(event = [object Object]) at http://s3.amazonaws.com/hifi-public/scripts/libraries/entityCameraTool.js:387
[02/17 10:07:17] [WARNING]     mouseReleaseEvent(event = [object Object], 0) at http://s3.amazonaws.com/hifi-public/scripts/edit.js:917
[02/17 10:07:17] [WARNING]     <global>() at -1
[02/17 10:07:38] [DEBUG] script:print()<< rotate handle case...
[02/17 10:07:38] [DEBUG] script:print()<<     somethingClicked:false
[02/17 10:07:38] [DEBUG] script:print()<<                 mode:UNKNOWN
[02/17 10:07:38] [WARNING] [UncaughtException] TypeError: Result of expression 'Window.setCursorVisible' [undefined] is not a function. in http://s3.amazonaws.com/hifi-public/scripts/edit.js:387
[02/17 10:07:38] [WARNING] [Backtrace]
[02/17 10:07:38] [WARNING]     <anonymous>(event = [object Object]) at http://s3.amazonaws.com/hifi-public/scripts/libraries/entityCameraTool.js:387
[02/17 10:07:38] [WARNING]     mouseReleaseEvent(event = [object Object], 0) at http://s3.amazonaws.com/hifi-public/scripts/edit.js:917

#16

Not call that foolish, i call that smart. i never go touch VHACD for a long time again. Last time i tried it it could not handle buildings to make a door walkable. So why use VACHD if you can do it at the same speed or fatser the other way.


#17

Can you DM me the original asset with the collision shape? I can set that up for a dev to look at.


#18

The assets to reproduce (but will unfortunately not load the PHULL) are here:

http://metaversecafes.com/images/test_barrier.fbx
http://metaversecafes.com/images/test_barrier.obj

LINK corrected. Spelling error fixed. Bug persists

When attempting to put the PHULL URL into edit panel I get the errors listed above but with the aforementioned filenames instead. Same issue.


#19

Captain’s Log - finding a bug while trying to replicate a different bug. Today is not my day.


#20

@AlphaVersionD , the obj is not on your server. http://metaversecfes.com/images/test_barrier.obj