Chairs in the Marketplace


#1

None of the chairs in the Market seem to work. They either don’t work at all when the avatar walks into them (suppose to trigger the sitting script this way) or they grab the avatar and won’t let go. Generally speaking, are assets “broken” with each new beta release?


Beta Release 31
#2

Sitting was deemed unhealthy and undesirable in the metaverse so highfidelians have been cursed to stand for all eternity. Feel free to check out sitscript station on my shop domain. This was constructed to the memory of a virtual world where sitting was considered cool


#3

Thanks, but I wouldn’t know how to use it even if I could find it. That’s a big domain. :slight_smile:


#4

Its not a sitscript, its a monumnet to really bloody wanting one too


#5

ROFL! Thanks! That made me laugh!

JR


#6

Is this one also broken for you ?

https://highfidelity.io/marketplace/items/a2fbf902-c189-47d3-827b-db9baf09c3ab

ADD: i just tried my chair. and it works fine on my domain. the one on earth seems not to work anymore. Until i relog, then it works.

But high fidelity have some problems with scripts,
i have many times problems that scripts stop responding.
A relog fix that in most cases. I still not figured out what going on.

So if something is not working , first do a relog. Yes, that’s very annoying.


#7

I tried that to no avail. It works fine when I first bring it in from the Market. But if I leave, log out and log back in, or stop my server and start it again, the sit script no longer works.


#8

I’ve had @Caitlyn’s chair out for the longest, and recently it stopped working. The collider zone is present but nothing happens. The log shows the script started:

[[details=Summary click for log snippet] 01/25 14:12:57] [DEBUG] [hifi.scriptengine] Found script in cache: “http://hifi-content.s3.amazonaws.com/caitlyn/production/sitSystem/chairCollider.js
[01/25 14:12:57] [DEBUG] [hifi.scriptengine] Found script in cache: “http://hifi-content.s3.amazonaws.com/caitlyn/production/sitSystem/chairScriptAndZone.js
[01/25 14:12:57] [DEBUG] [hifi.scriptengine.script] script:print()<< running collider![/details]

But it does not work. I restarted the domain, no joy. So, I think a new bug creeped into interface.


#9

I never got the orginal collider entity script working.
In my chair i use a modified one and that works.
I think problem is that scripts sometimes not
start correct or start todo strange things and stop responding.

It’s hard to figure out, most it happens with reload cache.
or when you teleport to a domain and back to yours.

Possible if you relog in front of the chair it works. otherwise try my sitable beach chair chair.


#10

I grabbed the Caitlyn chair from the market and that one works. Restart the domain and it fails, but one of the other two chair instances that were not working started to work. So, I think the script has a bug with setting up the collision zone.

Yes, it has several bugs. One is that it does not relocate the zone quite correctly when the chair is moved, the other is that alt-drag causes the newly created entity to not create a zone, and finally something about domain restart causes the script to stop getting collisions.


#11

Mine works on Franny. Has worked for a long time, and through several updates.


#12

I do not think it’s something todo with the chairs.
More with scripts. Because it happens many times that my doors and script on ATP not respond correct until relog or reset. or TP to different domain then where i came from. There;s a deeper hidden problem.

Same did happen with my chair on earth.
It did not worked until i did a relog in front of the chair.


#13

Restart that domain, see what happens. Move the chair, see what happens. Pretty sure there are several cases the script does not handle well.


#14

MIne too until it stopped working reliably:


#15

Dang… yeah it hasn’t been working properly in recent days. I’m not sure
why…

Interested in worklisting on it? LMK!


#16

Just restarted my server. Then I moved the chair, and it worked fine. So, for some reason mine works fine so far.


#17

Yes, it’s not 100% reproducible, something racey going on. I did some debug sleuthing and found that if I edited and reloaded (restarted) the script on a nonworking chair, it started to work. I should have checked to see if the script was actually a loaded instance in my interface client since a reload will cause an instantiation to happen. So that is one error case. The other is the case where the zone is gone. That tends to happen on alt-drag cases, although not always. It’s that nondeterministic child entity problem. And the third case is where someone edits the chair’s collision zone and moves it. The script does not asset the zone is properly oriented.

I’m going to take a look at the script to estimate what it takes to fix those deficiencies: verify zone is properly positioned, adjust if not; determine if child zone exists, recreate if not. As for the script not running, I’ll add a debug property to visually indicate when the script is running in your client. Then at least we can determine if the problem is missed events or a bug in instantiating the script when an avatar is in range.


#18

Look at my beach chair. i used and midified the older script. i used the 2 entity zoneless version. zones suck for this purpose. But it still have the problem that scropts sometimes not seems to run correct.