Compilehifi glew error


#1

I just tried compile Hifi with the command compilehifi, but it was an error. Can you help me please?

compilehifi output:

Updating Your OS - If you see Kernel listed you should restart when done and after type ‘runhifi’ to restart HighFidelity.
Loaded plugins: fastestmirror
Loading mirror speeds from cached hostfile
 * base: ftp.plusline.de
 * epel: mirror.imt-systems.com
 * extras: mirror.de.leaseweb.net
 * updates: mirror.skylink-datacenter.de
No packages marked for update
Installing EPEL Repo.
Installing compile tools.
Installing base needed tools.
Already up-to-date.
Source needs compiling.
Killing Running Processess
– The C compiler identification is GNU 4.8.3
– The CXX compiler identification is GNU 4.8.3
– Check for working C compiler: /usr/bin/cc
– Check for working C compiler: /usr/bin/cc – works
– Detecting C compiler ABI info
– Detecting C compiler ABI info - done
– Check for working CXX compiler: /usr/bin/c++
– Check for working CXX compiler: /usr/bin/c++ – works
– Detecting CXX compiler ABI info
– Detecting CXX compiler ABI info - done
– Performing Test COMPILER_SUPPORTS_CXX11
– Performing Test COMPILER_SUPPORTS_CXX11 - Success
– Performing Test COMPILER_SUPPORTS_CXX0X
– Performing Test COMPILER_SUPPORTS_CXX0X - Success
– Found GLM: /usr/local/src/highfidelity/hifi/build/ext/makefiles/glm/project/include
– Found Soxr: /usr/local/src/highfidelity/hifi/build/ext/makefiles/soxr/project/include
– Found OpenSSL: /lib64/libssl.so;/lib64/libcrypto.so (found version “1.0.1e”)
– Found TBB: /usr/local/src/highfidelity/hifi/build/ext/makefiles/tbb/project/src/tbb/lib/intel64/gcc4.4/libtbb.so
CMake Error at /usr/share/cmake-3.0/Modules/FindPackageHandleStandardArgs.cmake:136 (message):
  Could NOT find GLEW (missing: GLEW_INCLUDE_DIR GLEW_LIBRARY)
Call Stack (most recent call first):
  /usr/share/cmake-3.0/Modules/FindPackageHandleStandardArgs.cmake:343 (_FPHSA_FAILURE_MESSAGE)
  cmake/modules/FindGLEW.cmake:50 (find_package_handle_standard_args)
  libraries/gpu/CMakeLists.txt:35 (find_package)

– Configuring incomplete, errors occurred!
See also “/usr/local/src/highfidelity/hifi/build/CMakeFiles/CMakeOutput.log”.
make: *** No rule to make target `domain-server’.  Stop.
cp: cannot stat ‘/usr/local/src/highfidelity/hifi/build/domain-server/domain-server’: No such file or directory
cp: cannot stat ‘/usr/local/src/highfidelity/hifi/build/domain-server/resources’: No such file or directory
cp: cannot stat ‘/usr/local/src/highfidelity/hifi/build/assignment-client/assignment-client’: No such file or directory
Running your HiFi Stack as user hifi
To update your install later, just type ‘compilehifi’ to begin this safe process again - NO DATA IS LOST

CMakeOutput.log:

The system is: Linux - 3.10.0-123.8.1.el7.x86_64 - x86_64
Compiling the C compiler identification source file “CMakeCCompilerId.c” succeeded.
Compiler: /usr/bin/cc
Build flags:
Id flags:

The output was:
0

Compilation of the C compiler identification source “CMakeCCompilerId.c” produced “a.out”

The C compiler identification is GNU, found in “/usr/local/src/highfidelity/hifi/build/CMakeFiles/3.0.2/CompilerIdC/a.out”

Compiling the CXX compiler identification source file “CMakeCXXCompilerId.cpp” succeeded.
Compiler: /usr/bin/c++
Build flags:
Id flags:

The output was:
0

Compilation of the CXX compiler identification source “CMakeCXXCompilerId.cpp” produced “a.out”

The CXX compiler identification is GNU, found in “/usr/local/src/highfidelity/hifi/build/CMakeFiles/3.0.2/CompilerIdCXX/a.out”

Determining if the C compiler works passed with the following output:
Change Dir: /usr/local/src/highfidelity/hifi/build/CMakeFiles/CMakeTmp

Run Build Command:"/usr/bin/gmake" “cmTryCompileExec4288025421/fast”
/usr/bin/gmake -f CMakeFiles/cmTryCompileExec4288025421.dir/build.make CMakeFiles/cmTryCompileExec4288025421.dir/build
gmake[1]: Entering directory /usr/local/src/highfidelity/hifi/build/CMakeFiles/CMakeTmp' /usr/bin/cmake -E cmake_progress_report /usr/local/src/highfidelity/hifi/build/CMakeFiles/CMakeTmp/CMakeFiles 1 Building C object CMakeFiles/cmTryCompileExec4288025421.dir/testCCompiler.c.o /usr/bin/cc    -o CMakeFiles/cmTryCompileExec4288025421.dir/testCCompiler.c.o   -c /usr/local/src/highfidelity/hifi/build/CMakeFiles/CMakeTmp/testCCompiler.c Linking C executable cmTryCompileExec4288025421 /usr/bin/cmake -E cmake_link_script CMakeFiles/cmTryCompileExec4288025421.dir/link.txt --verbose=1 /usr/bin/cc       CMakeFiles/cmTryCompileExec4288025421.dir/testCCompiler.c.o  -o cmTryCompileExec4288025421 -rdynamic gmake[1]: Leaving directory/usr/local/src/highfidelity/hifi/build/CMakeFiles/CMakeTmp’

Detecting C compiler ABI info compiled with the following output:
Change Dir: /usr/local/src/highfidelity/hifi/build/CMakeFiles/CMakeTmp

Run Build Command:"/usr/bin/gmake" “cmTryCompileExec3388367821/fast”
/usr/bin/gmake -f CMakeFiles/cmTryCompileExec3388367821.dir/build.make CMakeFiles/cmTryCompileExec3388367821.dir/build
gmake[1]: Entering directory /usr/local/src/highfidelity/hifi/build/CMakeFiles/CMakeTmp' /usr/bin/cmake -E cmake_progress_report /usr/local/src/highfidelity/hifi/build/CMakeFiles/CMakeTmp/CMakeFiles 1 Building C object CMakeFiles/cmTryCompileExec3388367821.dir/CMakeCCompilerABI.c.o /usr/bin/cc    -o CMakeFiles/cmTryCompileExec3388367821.dir/CMakeCCompilerABI.c.o   -c /usr/share/cmake-3.0/Modules/CMakeCCompilerABI.c Linking C executable cmTryCompileExec3388367821 /usr/bin/cmake -E cmake_link_script CMakeFiles/cmTryCompileExec3388367821.dir/link.txt --verbose=1 /usr/bin/cc     -v CMakeFiles/cmTryCompileExec3388367821.dir/CMakeCCompilerABI.c.o  -o cmTryCompileExec3388367821 -rdynamic   Using built-in specs. COLLECT_GCC=/usr/bin/cc COLLECT_LTO_WRAPPER=/usr/libexec/gcc/x86_64-redhat-linux/4.8.3/lto-wrapper Target: x86_64-redhat-linux Configured with: ../configure --prefix=/usr --mandir=/usr/share/man --infodir=/usr/share/info --with-bugurl=http://bugzilla.redhat.com/bugzilla --enable-bootstrap --enable-shared --enable-threads=posix --enable-checking=release --with-system-zlib --enable-__cxa_atexit --disable-libunwind-exceptions --enable-gnu-unique-object --enable-linker-build-id --with-linker-hash-style=gnu --enable-languages=c,c++,objc,obj-c++,java,fortran,ada,go,lto --enable-plugin --enable-initfini-array --disable-libgcj --with-isl=/builddir/build/BUILD/gcc-4.8.3-20140911/obj-x86_64-redhat-linux/isl-install --with-cloog=/builddir/build/BUILD/gcc-4.8.3-20140911/obj-x86_64-redhat-linux/cloog-install --enable-gnu-indirect-function --with-tune=generic --with-arch_32=x86-64 --build=x86_64-redhat-linux Thread model: posix gcc version 4.8.3 20140911 (Red Hat 4.8.3-9) (GCC) COMPILER_PATH=/usr/libexec/gcc/x86_64-redhat-linux/4.8.3/:/usr/libexec/gcc/x86_64-redhat-linux/4.8.3/:/usr/libexec/gcc/x86_64-redhat-linux/:/usr/lib/gcc/x86_64-redhat-linux/4.8.3/:/usr/lib/gcc/x86_64-redhat-linux/ LIBRARY_PATH=/usr/lib/gcc/x86_64-redhat-linux/4.8.3/:/usr/lib/gcc/x86_64-redhat-linux/4.8.3/../../../../lib64/:/lib/../lib64/:/usr/lib/../lib64/:/usr/lib/gcc/x86_64-redhat-linux/4.8.3/../../../:/lib/:/usr/lib/ COLLECT_GCC_OPTIONS='-v' '-o' 'cmTryCompileExec3388367821' '-rdynamic' '-mtune=generic' '-march=x86-64'  /usr/libexec/gcc/x86_64-redhat-linux/4.8.3/collect2 --build-id --no-add-needed --eh-frame-hdr --hash-style=gnu -m elf_x86_64 -export-dynamic -dynamic-linker /lib64/ld-linux-x86-64.so.2 -o cmTryCompileExec3388367821 /usr/lib/gcc/x86_64-redhat-linux/4.8.3/../../../../lib64/crt1.o /usr/lib/gcc/x86_64-redhat-linux/4.8.3/../../../../lib64/crti.o /usr/lib/gcc/x86_64-redhat-linux/4.8.3/crtbegin.o -L/usr/lib/gcc/x86_64-redhat-linux/4.8.3 -L/usr/lib/gcc/x86_64-redhat-linux/4.8.3/../../../../lib64 -L/lib/../lib64 -L/usr/lib/../lib64 -L/usr/lib/gcc/x86_64-redhat-linux/4.8.3/../../.. CMakeFiles/cmTryCompileExec3388367821.dir/CMakeCCompilerABI.c.o -lgcc --as-needed -lgcc_s --no-as-needed -lc -lgcc --as-needed -lgcc_s --no-as-needed /usr/lib/gcc/x86_64-redhat-linux/4.8.3/crtend.o /usr/lib/gcc/x86_64-redhat-linux/4.8.3/../../../../lib64/crtn.o gmake[1]: Leaving directory/usr/local/src/highfidelity/hifi/build/CMakeFiles/CMakeTmp’

Parsed C implicit link information from above output:
  link line regex: [^( |.[/])(ld|([^/]±)?ld|collect2)[^/]*( |$)]
  ignore line: [Change Dir: /usr/local/src/highfidelity/hifi/build/CMakeFiles/CMakeTmp]
  ignore line: []
  ignore line: [Run Build Command:"/usr/bin/gmake" “cmTryCompileExec3388367821/fast”]
  ignore line: [/usr/bin/gmake -f CMakeFiles/cmTryCompileExec3388367821.dir/build.make CMakeFiles/cmTryCompileExec3388367821.dir/build]
  ignore line: [gmake[1]: Entering directory `/usr/local/src/highfidelity/hifi/build/CMakeFiles/CMakeTmp’]
  ignore line: [/usr/bin/cmake -E cmake_progress_report /usr/local/src/highfidelity/hifi/build/CMakeFiles/CMakeTmp/CMakeFiles 1]
  ignore line: [Building C object CMakeFiles/cmTryCompileExec3388367821.dir/CMakeCCompilerABI.c.o]
  ignore line: [/usr/bin/cc    -o CMakeFiles/cmTryCompileExec3388367821.dir/CMakeCCompilerABI.c.o   -c /usr/share/cmake-3.0/Modules/CMakeCCompilerABI.c]
  ignore line: [Linking C executable cmTryCompileExec3388367821]
  ignore line: [/usr/bin/cmake -E cmake_link_script CMakeFiles/cmTryCompileExec3388367821.dir/link.txt --verbose=1]
  ignore line: [/usr/bin/cc     -v CMakeFiles/cmTryCompileExec3388367821.dir/CMakeCCompilerABI.c.o  -o cmTryCompileExec3388367821 -rdynamic  ]
  ignore line: [Using built-in specs.]
  ignore line: [COLLECT_GCC=/usr/bin/cc]
  ignore line: [COLLECT_LTO_WRAPPER=/usr/libexec/gcc/x86_64-redhat-linux/4.8.3/lto-wrapper]
  ignore line: [Target: x86_64-redhat-linux]
  ignore line: [Configured with: …/configure --prefix=/usr --mandir=/usr/share/man --infodir=/usr/share/info --with-bugurl=http://bugzilla.redhat.com/bugzilla --enable-bootstrap --enable-shared --enable-threads=posix --enable-checking=release --with-system-zlib --enable-__cxa_atexit --disable-libunwind-exceptions --enable-gnu-unique-object --enable-linker-build-id --with-linker-hash-style=gnu --enable-languages=c,c++,objc,obj-c++,java,fortran,ada,go,lto --enable-plugin --enable-initfini-array --disable-libgcj --with-isl=/builddir/build/BUILD/gcc-4.8.3-20140911/obj-x86_64-redhat-linux/isl-install --with-cloog=/builddir/build/BUILD/gcc-4.8.3-20140911/obj-x86_64-redhat-linux/cloog-install --enable-gnu-indirect-function --with-tune=generic --with-arch_32=x86-64 --build=x86_64-redhat-linux]
  ignore line: [Thread model: posix]
  ignore line: [gcc version 4.8.3 20140911 (Red Hat 4.8.3-9) (GCC) ]
  ignore line: [COMPILER_PATH=/usr/libexec/gcc/x86_64-redhat-linux/4.8.3/:/usr/libexec/gcc/x86_64-redhat-linux/4.8.3/:/usr/libexec/gcc/x86_64-redhat-linux/:/usr/lib/gcc/x86_64-redhat-linux/4.8.3/:/usr/lib/gcc/x86_64-redhat-linux/]
  ignore line: [LIBRARY_PATH=/usr/lib/gcc/x86_64-redhat-linux/4.8.3/:/usr/lib/gcc/x86_64-redhat-linux/4.8.3/…/…/…/…/lib64/:/lib/…/lib64/:/usr/lib/…/lib64/:/usr/lib/gcc/x86_64-redhat-linux/4.8.3/…/…/…/:/lib/:/usr/lib/]
  ignore line: [COLLECT_GCC_OPTIONS=’-v’ ‘-o’ ‘cmTryCompileExec3388367821’ ‘-rdynamic’ ‘-mtune=generic’ ‘-march=x86-64’]
  link line: [ /usr/libexec/gcc/x86_64-redhat-linux/4.8.3/collect2 --build-id --no-add-needed --eh-frame-hdr --hash-style=gnu -m elf_x86_64 -export-dynamic -dynamic-linker /lib64/ld-linux-x86-64.so.2 -o cmTryCompileExec3388367821 /usr/lib/gcc/x86_64-redhat-linux/4.8.3/…/…/…/…/lib64/crt1.o /usr/lib/gcc/x86_64-redhat-linux/4.8.3/…/…/…/…/lib64/crti.o /usr/lib/gcc/x86_64-redhat-linux/4.8.3/crtbegin.o -L/usr/lib/gcc/x86_64-redhat-linux/4.8.3 -L/usr/lib/gcc/x86_64-redhat-linux/4.8.3/…/…/…/…/lib64 -L/lib/…/lib64 -L/usr/lib/…/lib64 -L/usr/lib/gcc/x86_64-redhat-linux/4.8.3/…/…/… CMakeFiles/cmTryCompileExec3388367821.dir/CMakeCCompilerABI.c.o -lgcc --as-needed -lgcc_s --no-as-needed -lc -lgcc --as-needed -lgcc_s --no-as-needed /usr/lib/gcc/x86_64-redhat-linux/4.8.3/crtend.o /usr/lib/gcc/x86_64-redhat-linux/4.8.3/…/…/…/…/lib64/crtn.o]
    arg [/usr/libexec/gcc/x86_64-redhat-linux/4.8.3/collect2] ==> ignore
    arg [–build-id] ==> ignore
    arg [–no-add-needed] ==> ignore
    arg [–eh-frame-hdr] ==> ignore
    arg [–hash-style=gnu] ==> ignore
    arg [-m] ==> ignore
    arg [elf_x86_64] ==> ignore
    arg [-export-dynamic] ==> ignore
    arg [-dynamic-linker] ==> ignore
    arg [/lib64/ld-linux-x86-64.so.2] ==> ignore
    arg [-o] ==> ignore
    arg [cmTryCompileExec3388367821] ==> ignore
    arg [/usr/lib/gcc/x86_64-redhat-linux/4.8.3/…/…/…/…/lib64/crt1.o] ==> ignore
    arg [/usr/lib/gcc/x86_64-redhat-linux/4.8.3/…/…/…/…/lib64/crti.o] ==> ignore
    arg [/usr/lib/gcc/x86_64-redhat-linux/4.8.3/crtbegin.o] ==> ignore
    arg [-L/usr/lib/gcc/x86_64-redhat-linux/4.8.3] ==> dir [/usr/lib/gcc/x86_64-redhat-linux/4.8.3]
    arg [-L/usr/lib/gcc/x86_64-redhat-linux/4.8.3/…/…/…/…/lib64] ==> dir [/usr/lib/gcc/x86_64-redhat-linux/4.8.3/…/…/…/…/lib64]
    arg [-L/lib/…/lib64] ==> dir [/lib/…/lib64]
    arg [-L/usr/lib/…/lib64] ==> dir [/usr/lib/…/lib64]
    arg [-L/usr/lib/gcc/x86_64-redhat-linux/4.8.3/…/…/…] ==> dir [/usr/lib/gcc/x86_64-redhat-linux/4.8.3/…/…/…]
    arg [CMakeFiles/cmTryCompileExec3388367821.dir/CMakeCCompilerABI.c.o] ==> ignore
    arg [-lgcc] ==> lib [gcc]
    arg [–as-needed] ==> ignore
    arg [-lgcc_s] ==> lib [gcc_s]
    arg [–no-as-needed] ==> ignore
    arg [-lc] ==> lib [c]
    arg [-lgcc] ==> lib [gcc]
    arg [–as-needed] ==> ignore
    arg [-lgcc_s] ==> lib [gcc_s]
    arg [–no-as-needed] ==> ignore
    arg [/usr/lib/gcc/x86_64-redhat-linux/4.8.3/crtend.o] ==> ignore
    arg [/usr/lib/gcc/x86_64-redhat-linux/4.8.3/…/…/…/…/lib64/crtn.o] ==> ignore
  remove lib [gcc]
  remove lib [gcc_s]
  remove lib [gcc]
  remove lib [gcc_s]
  collapse library dir [/usr/lib/gcc/x86_64-redhat-linux/4.8.3] ==> [/usr/lib/gcc/x86_64-redhat-linux/4.8.3]
  collapse library dir [/usr/lib/gcc/x86_64-redhat-linux/4.8.3/…/…/…/…/lib64] ==> [/usr/lib64]
  collapse library dir [/lib/…/lib64] ==> [/lib64]
  collapse library dir [/usr/lib/…/lib64] ==> [/usr/lib64]
  collapse library dir [/usr/lib/gcc/x86_64-redhat-linux/4.8.3/…/…/…] ==> [/usr/lib]
  implicit libs: [c]
  implicit dirs: [/usr/lib/gcc/x86_64-redhat-linux/4.8.3;/usr/lib64;/lib64;/usr/lib]
  implicit fwks: []

Determining if the CXX compiler works passed with the following output:
Change Dir: /usr/local/src/highfidelity/hifi/build/CMakeFiles/CMakeTmp

Run Build Command:"/usr/bin/gmake" “cmTryCompileExec2721752223/fast”
/usr/bin/gmake -f CMakeFiles/cmTryCompileExec2721752223.dir/build.make CMakeFiles/cmTryCompileExec2721752223.dir/build
gmake[1]: Entering directory /usr/local/src/highfidelity/hifi/build/CMakeFiles/CMakeTmp' /usr/bin/cmake -E cmake_progress_report /usr/local/src/highfidelity/hifi/build/CMakeFiles/CMakeTmp/CMakeFiles 1 Building CXX object CMakeFiles/cmTryCompileExec2721752223.dir/testCXXCompiler.cxx.o /usr/bin/c++     -o CMakeFiles/cmTryCompileExec2721752223.dir/testCXXCompiler.cxx.o -c /usr/local/src/highfidelity/hifi/build/CMakeFiles/CMakeTmp/testCXXCompiler.cxx Linking CXX executable cmTryCompileExec2721752223 /usr/bin/cmake -E cmake_link_script CMakeFiles/cmTryCompileExec2721752223.dir/link.txt --verbose=1 /usr/bin/c++        CMakeFiles/cmTryCompileExec2721752223.dir/testCXXCompiler.cxx.o  -o cmTryCompileExec2721752223 -rdynamic gmake[1]: Leaving directory/usr/local/src/highfidelity/hifi/build/CMakeFiles/CMakeTmp’

Detecting CXX compiler ABI info compiled with the following output:
Change Dir: /usr/local/src/highfidelity/hifi/build/CMakeFiles/CMakeTmp

Run Build Command:"/usr/bin/gmake" “cmTryCompileExec4050116777/fast”
/usr/bin/gmake -f CMakeFiles/cmTryCompileExec4050116777.dir/build.make CMakeFiles/cmTryCompileExec4050116777.dir/build
gmake[1]: Entering directory /usr/local/src/highfidelity/hifi/build/CMakeFiles/CMakeTmp' /usr/bin/cmake -E cmake_progress_report /usr/local/src/highfidelity/hifi/build/CMakeFiles/CMakeTmp/CMakeFiles 1 Building CXX object CMakeFiles/cmTryCompileExec4050116777.dir/CMakeCXXCompilerABI.cpp.o /usr/bin/c++     -o CMakeFiles/cmTryCompileExec4050116777.dir/CMakeCXXCompilerABI.cpp.o -c /usr/share/cmake-3.0/Modules/CMakeCXXCompilerABI.cpp Linking CXX executable cmTryCompileExec4050116777 /usr/bin/cmake -E cmake_link_script CMakeFiles/cmTryCompileExec4050116777.dir/link.txt --verbose=1 /usr/bin/c++      -v CMakeFiles/cmTryCompileExec4050116777.dir/CMakeCXXCompilerABI.cpp.o  -o cmTryCompileExec4050116777 -rdynamic   Using built-in specs. COLLECT_GCC=/usr/bin/c++ COLLECT_LTO_WRAPPER=/usr/libexec/gcc/x86_64-redhat-linux/4.8.3/lto-wrapper Target: x86_64-redhat-linux Configured with: ../configure --prefix=/usr --mandir=/usr/share/man --infodir=/usr/share/info --with-bugurl=http://bugzilla.redhat.com/bugzilla --enable-bootstrap --enable-shared --enable-threads=posix --enable-checking=release --with-system-zlib --enable-__cxa_atexit --disable-libunwind-exceptions --enable-gnu-unique-object --enable-linker-build-id --with-linker-hash-style=gnu --enable-languages=c,c++,objc,obj-c++,java,fortran,ada,go,lto --enable-plugin --enable-initfini-array --disable-libgcj --with-isl=/builddir/build/BUILD/gcc-4.8.3-20140911/obj-x86_64-redhat-linux/isl-install --with-cloog=/builddir/build/BUILD/gcc-4.8.3-20140911/obj-x86_64-redhat-linux/cloog-install --enable-gnu-indirect-function --with-tune=generic --with-arch_32=x86-64 --build=x86_64-redhat-linux Thread model: posix gcc version 4.8.3 20140911 (Red Hat 4.8.3-9) (GCC) COMPILER_PATH=/usr/libexec/gcc/x86_64-redhat-linux/4.8.3/:/usr/libexec/gcc/x86_64-redhat-linux/4.8.3/:/usr/libexec/gcc/x86_64-redhat-linux/:/usr/lib/gcc/x86_64-redhat-linux/4.8.3/:/usr/lib/gcc/x86_64-redhat-linux/ LIBRARY_PATH=/usr/lib/gcc/x86_64-redhat-linux/4.8.3/:/usr/lib/gcc/x86_64-redhat-linux/4.8.3/../../../../lib64/:/lib/../lib64/:/usr/lib/../lib64/:/usr/lib/gcc/x86_64-redhat-linux/4.8.3/../../../:/lib/:/usr/lib/ COLLECT_GCC_OPTIONS='-v' '-o' 'cmTryCompileExec4050116777' '-rdynamic' '-shared-libgcc' '-mtune=generic' '-march=x86-64'  /usr/libexec/gcc/x86_64-redhat-linux/4.8.3/collect2 --build-id --no-add-needed --eh-frame-hdr --hash-style=gnu -m elf_x86_64 -export-dynamic -dynamic-linker /lib64/ld-linux-x86-64.so.2 -o cmTryCompileExec4050116777 /usr/lib/gcc/x86_64-redhat-linux/4.8.3/../../../../lib64/crt1.o /usr/lib/gcc/x86_64-redhat-linux/4.8.3/../../../../lib64/crti.o /usr/lib/gcc/x86_64-redhat-linux/4.8.3/crtbegin.o -L/usr/lib/gcc/x86_64-redhat-linux/4.8.3 -L/usr/lib/gcc/x86_64-redhat-linux/4.8.3/../../../../lib64 -L/lib/../lib64 -L/usr/lib/../lib64 -L/usr/lib/gcc/x86_64-redhat-linux/4.8.3/../../.. CMakeFiles/cmTryCompileExec4050116777.dir/CMakeCXXCompilerABI.cpp.o -lstdc++ -lm -lgcc_s -lgcc -lc -lgcc_s -lgcc /usr/lib/gcc/x86_64-redhat-linux/4.8.3/crtend.o /usr/lib/gcc/x86_64-redhat-linux/4.8.3/../../../../lib64/crtn.o gmake[1]: Leaving directory/usr/local/src/highfidelity/hifi/build/CMakeFiles/CMakeTmp’

Parsed CXX implicit link information from above output:
  link line regex: [^( |.[/])(ld|([^/]±)?ld|collect2)[^/]*( |$)]
  ignore line: [Change Dir: /usr/local/src/highfidelity/hifi/build/CMakeFiles/CMakeTmp]
  ignore line: []
  ignore line: [Run Build Command:"/usr/bin/gmake" “cmTryCompileExec4050116777/fast”]
  ignore line: [/usr/bin/gmake -f CMakeFiles/cmTryCompileExec4050116777.dir/build.make CMakeFiles/cmTryCompileExec4050116777.dir/build]
  ignore line: [gmake[1]: Entering directory `/usr/local/src/highfidelity/hifi/build/CMakeFiles/CMakeTmp’]
  ignore line: [/usr/bin/cmake -E cmake_progress_report /usr/local/src/highfidelity/hifi/build/CMakeFiles/CMakeTmp/CMakeFiles 1]
  ignore line: [Building CXX object CMakeFiles/cmTryCompileExec4050116777.dir/CMakeCXXCompilerABI.cpp.o]
  ignore line: [/usr/bin/c++     -o CMakeFiles/cmTryCompileExec4050116777.dir/CMakeCXXCompilerABI.cpp.o -c /usr/share/cmake-3.0/Modules/CMakeCXXCompilerABI.cpp]
  ignore line: [Linking CXX executable cmTryCompileExec4050116777]
  ignore line: [/usr/bin/cmake -E cmake_link_script CMakeFiles/cmTryCompileExec4050116777.dir/link.txt --verbose=1]
  ignore line: [/usr/bin/c++      -v CMakeFiles/cmTryCompileExec4050116777.dir/CMakeCXXCompilerABI.cpp.o  -o cmTryCompileExec4050116777 -rdynamic  ]
  ignore line: [Using built-in specs.]
  ignore line: [COLLECT_GCC=/usr/bin/c++]
  ignore line: [COLLECT_LTO_WRAPPER=/usr/libexec/gcc/x86_64-redhat-linux/4.8.3/lto-wrapper]
  ignore line: [Target: x86_64-redhat-linux]
  ignore line: [Configured with: …/configure --prefix=/usr --mandir=/usr/share/man --infodir=/usr/share/info --with-bugurl=http://bugzilla.redhat.com/bugzilla --enable-bootstrap --enable-shared --enable-threads=posix --enable-checking=release --with-system-zlib --enable-__cxa_atexit --disable-libunwind-exceptions --enable-gnu-unique-object --enable-linker-build-id --with-linker-hash-style=gnu --enable-languages=c,c++,objc,obj-c++,java,fortran,ada,go,lto --enable-plugin --enable-initfini-array --disable-libgcj --with-isl=/builddir/build/BUILD/gcc-4.8.3-20140911/obj-x86_64-redhat-linux/isl-install --with-cloog=/builddir/build/BUILD/gcc-4.8.3-20140911/obj-x86_64-redhat-linux/cloog-install --enable-gnu-indirect-function --with-tune=generic --with-arch_32=x86-64 --build=x86_64-redhat-linux]
  ignore line: [Thread model: posix]
  ignore line: [gcc version 4.8.3 20140911 (Red Hat 4.8.3-9) (GCC) ]
  ignore line: [COMPILER_PATH=/usr/libexec/gcc/x86_64-redhat-linux/4.8.3/:/usr/libexec/gcc/x86_64-redhat-linux/4.8.3/:/usr/libexec/gcc/x86_64-redhat-linux/:/usr/lib/gcc/x86_64-redhat-linux/4.8.3/:/usr/lib/gcc/x86_64-redhat-linux/]
  ignore line: [LIBRARY_PATH=/usr/lib/gcc/x86_64-redhat-linux/4.8.3/:/usr/lib/gcc/x86_64-redhat-linux/4.8.3/…/…/…/…/lib64/:/lib/…/lib64/:/usr/lib/…/lib64/:/usr/lib/gcc/x86_64-redhat-linux/4.8.3/…/…/…/:/lib/:/usr/lib/]
  ignore line: [COLLECT_GCC_OPTIONS=’-v’ ‘-o’ ‘cmTryCompileExec4050116777’ ‘-rdynamic’ ‘-shared-libgcc’ ‘-mtune=generic’ ‘-march=x86-64’]
  link line: [ /usr/libexec/gcc/x86_64-redhat-linux/4.8.3/collect2 --build-id --no-add-needed --eh-frame-hdr --hash-style=gnu -m elf_x86_64 -export-dynamic -dynamic-linker /lib64/ld-linux-x86-64.so.2 -o cmTryCompileExec4050116777 /usr/lib/gcc/x86_64-redhat-linux/4.8.3/…/…/…/…/lib64/crt1.o /usr/lib/gcc/x86_64-redhat-linux/4.8.3/…/…/…/…/lib64/crti.o /usr/lib/gcc/x86_64-redhat-linux/4.8.3/crtbegin.o -L/usr/lib/gcc/x86_64-redhat-linux/4.8.3 -L/usr/lib/gcc/x86_64-redhat-linux/4.8.3/…/…/…/…/lib64 -L/lib/…/lib64 -L/usr/lib/…/lib64 -L/usr/lib/gcc/x86_64-redhat-linux/4.8.3/…/…/… CMakeFiles/cmTryCompileExec4050116777.dir/CMakeCXXCompilerABI.cpp.o -lstdc++ -lm -lgcc_s -lgcc -lc -lgcc_s -lgcc /usr/lib/gcc/x86_64-redhat-linux/4.8.3/crtend.o /usr/lib/gcc/x86_64-redhat-linux/4.8.3/…/…/…/…/lib64/crtn.o]
    arg [/usr/libexec/gcc/x86_64-redhat-linux/4.8.3/collect2] ==> ignore
    arg [–build-id] ==> ignore
    arg [–no-add-needed] ==> ignore
    arg [–eh-frame-hdr] ==> ignore
    arg [–hash-style=gnu] ==> ignore
    arg [-m] ==> ignore
    arg [elf_x86_64] ==> ignore
    arg [-export-dynamic] ==> ignore
    arg [-dynamic-linker] ==> ignore
    arg [/lib64/ld-linux-x86-64.so.2] ==> ignore
    arg [-o] ==> ignore
    arg [cmTryCompileExec4050116777] ==> ignore
    arg [/usr/lib/gcc/x86_64-redhat-linux/4.8.3/…/…/…/…/lib64/crt1.o] ==> ignore
    arg [/usr/lib/gcc/x86_64-redhat-linux/4.8.3/…/…/…/…/lib64/crti.o] ==> ignore
    arg [/usr/lib/gcc/x86_64-redhat-linux/4.8.3/crtbegin.o] ==> ignore
    arg [-L/usr/lib/gcc/x86_64-redhat-linux/4.8.3] ==> dir [/usr/lib/gcc/x86_64-redhat-linux/4.8.3]
    arg [-L/usr/lib/gcc/x86_64-redhat-linux/4.8.3/…/…/…/…/lib64] ==> dir [/usr/lib/gcc/x86_64-redhat-linux/4.8.3/…/…/…/…/lib64]
    arg [-L/lib/…/lib64] ==> dir [/lib/…/lib64]
    arg [-L/usr/lib/…/lib64] ==> dir [/usr/lib/…/lib64]
    arg [-L/usr/lib/gcc/x86_64-redhat-linux/4.8.3/…/…/…] ==> dir [/usr/lib/gcc/x86_64-redhat-linux/4.8.3/…/…/…]
    arg [CMakeFiles/cmTryCompileExec4050116777.dir/CMakeCXXCompilerABI.cpp.o] ==> ignore
    arg [-lstdc++] ==> lib [stdc++]
    arg [-lm] ==> lib [m]
    arg [-lgcc_s] ==> lib [gcc_s]
    arg [-lgcc] ==> lib [gcc]
    arg [-lc] ==> lib [c]
    arg [-lgcc_s] ==> lib [gcc_s]
    arg [-lgcc] ==> lib [gcc]
    arg [/usr/lib/gcc/x86_64-redhat-linux/4.8.3/crtend.o] ==> ignore
    arg [/usr/lib/gcc/x86_64-redhat-linux/4.8.3/…/…/…/…/lib64/crtn.o] ==> ignore
  remove lib [gcc_s]
  remove lib [gcc]
  remove lib [gcc_s]
  remove lib [gcc]
  collapse library dir [/usr/lib/gcc/x86_64-redhat-linux/4.8.3] ==> [/usr/lib/gcc/x86_64-redhat-linux/4.8.3]
  collapse library dir [/usr/lib/gcc/x86_64-redhat-linux/4.8.3/…/…/…/…/lib64] ==> [/usr/lib64]
  collapse library dir [/lib/…/lib64] ==> [/lib64]
  collapse library dir [/usr/lib/…/lib64] ==> [/usr/lib64]
  collapse library dir [/usr/lib/gcc/x86_64-redhat-linux/4.8.3/…/…/…] ==> [/usr/lib]
  implicit libs: [stdc++;m;c]
  implicit dirs: [/usr/lib/gcc/x86_64-redhat-linux/4.8.3;/usr/lib64;/lib64;/usr/lib]
  implicit fwks: []

Performing C++ SOURCE FILE Test COMPILER_SUPPORTS_CXX11 succeded with the following output:
Change Dir: /usr/local/src/highfidelity/hifi/build/CMakeFiles/CMakeTmp

Run Build Command:"/usr/bin/gmake" “cmTryCompileExec833115668/fast”
/usr/bin/gmake -f CMakeFiles/cmTryCompileExec833115668.dir/build.make CMakeFiles/cmTryCompileExec833115668.dir/build
gmake[1]: Entering directory /usr/local/src/highfidelity/hifi/build/CMakeFiles/CMakeTmp' /usr/bin/cmake -E cmake_progress_report /usr/local/src/highfidelity/hifi/build/CMakeFiles/CMakeTmp/CMakeFiles 1 Building CXX object CMakeFiles/cmTryCompileExec833115668.dir/src.cxx.o /usr/bin/c++    -Wall -Wextra -fno-strict-aliasing -Wno-unused-parameter -ggdb -Woverloaded-virtual -Wdouble-promotion -DCOMPILER_SUPPORTS_CXX11   -std=c++11 -o CMakeFiles/cmTryCompileExec833115668.dir/src.cxx.o -c /usr/local/src/highfidelity/hifi/build/CMakeFiles/CMakeTmp/src.cxx Linking CXX executable cmTryCompileExec833115668 /usr/bin/cmake -E cmake_link_script CMakeFiles/cmTryCompileExec833115668.dir/link.txt --verbose=1 /usr/bin/c++    -Wall -Wextra -fno-strict-aliasing -Wno-unused-parameter -ggdb -Woverloaded-virtual -Wdouble-promotion -DCOMPILER_SUPPORTS_CXX11    CMakeFiles/cmTryCompileExec833115668.dir/src.cxx.o  -o cmTryCompileExec833115668 -rdynamic gmake[1]: Leaving directory/usr/local/src/highfidelity/hifi/build/CMakeFiles/CMakeTmp’

Source file was:
int main() { return 0; }
Performing C++ SOURCE FILE Test COMPILER_SUPPORTS_CXX0X succeded with the following output:
Change Dir: /usr/local/src/highfidelity/hifi/build/CMakeFiles/CMakeTmp

Run Build Command:"/usr/bin/gmake" “cmTryCompileExec3586360479/fast”
/usr/bin/gmake -f CMakeFiles/cmTryCompileExec3586360479.dir/build.make CMakeFiles/cmTryCompileExec3586360479.dir/build
gmake[1]: Entering directory /usr/local/src/highfidelity/hifi/build/CMakeFiles/CMakeTmp' /usr/bin/cmake -E cmake_progress_report /usr/local/src/highfidelity/hifi/build/CMakeFiles/CMakeTmp/CMakeFiles 1 Building CXX object CMakeFiles/cmTryCompileExec3586360479.dir/src.cxx.o /usr/bin/c++    -Wall -Wextra -fno-strict-aliasing -Wno-unused-parameter -ggdb -Woverloaded-virtual -Wdouble-promotion -DCOMPILER_SUPPORTS_CXX0X   -std=c++0x -o CMakeFiles/cmTryCompileExec3586360479.dir/src.cxx.o -c /usr/local/src/highfidelity/hifi/build/CMakeFiles/CMakeTmp/src.cxx Linking CXX executable cmTryCompileExec3586360479 /usr/bin/cmake -E cmake_link_script CMakeFiles/cmTryCompileExec3586360479.dir/link.txt --verbose=1 /usr/bin/c++    -Wall -Wextra -fno-strict-aliasing -Wno-unused-parameter -ggdb -Woverloaded-virtual -Wdouble-promotion -DCOMPILER_SUPPORTS_CXX0X    CMakeFiles/cmTryCompileExec3586360479.dir/src.cxx.o  -o cmTryCompileExec3586360479 -rdynamic gmake[1]: Leaving directory/usr/local/src/highfidelity/hifi/build/CMakeFiles/CMakeTmp’

Source file was:
int main() { return 0; }


#2

Hello @JuelsDreki,

There is a new GLEW dependency.

Try installing glew-devel:

sudo yum install glew-devel

that should fix it,

Greetings,

Thoys


#3

I installed the library GLEW. The compiling of hifi works now again. Thank you very much thoys. :slight_smile: