CraxIM Instant Messenger / Global Chat Alpha v1.0.0.6


#21

I see you were trying to connect. Did you get any errors in your hifi log?


#22

Checking now on a fresh run. I logged on… the interface loads your script and the interface bits and bobs fine from http://craxim.com/scripts/craxim.js

C:\Users\me\AppData\Local\High Fidelity\Interface\Logs\hifi-log.txt

Only bit in hifi-log.txt after the initial load that mentioned your script is this…

[12/02 14:47:58] [DEBUG] waiting on script: “craxim.js”
[12/02 14:47:58] [DEBUG] done waiting on script: “craxim.js”
[12/02 14:47:58] [DEBUG] Script Engine shutting down (destructor) for script: “craxim.js”

But I set available presence, selected global, saw “Connecting…”, typed in the box a test message and “Not connected”. Repeated that and then logged off.

Do you see me trying to come in at your server support end?


#23

Ah, if you have turned off Secure Web Sockets then I think I am not able to connect. The echo.js test doe snot do anything on normal WS until I tick the secure/TPS box. Either way its not clear to a user what is happening or why if the setup is not making a connection.


#24

Did you try this script? Try running ws and wss. Also you should post results here. On the echo server I can only get results on the WSS test like you, but I can still connect to craxim just fine.


#25

Run that one inside the Interface do you mean @Cracker_Hax ?

https://gist.github.com/CrackerHax/c0b0bd105ef44f06fb31.js

I ran it from the URL in the Interface but cannot see it doing anything.

Chat shows you online, amongst others, but everyone is grey, me included, and Connecting… is all I get.


#26

Yeah it is doing the same thing for me now too. It was working earlier now it’s not, even when I restart the server.

The gray names are from the global user list.


#27

Add complete hide when you press the ‘O’ key would be nice. so the chat interface is not getting in pictures. Now you need to remove the script complete.


#28

Nice suggestion, I will add that to my todo list.


#29

I just tested this and hitting O does hide the ui, just make sure you dont have the text bar currently active because when it is, it captures all keys. You can do this by clicking anything other than the chat bar.


#30

Ok I ran a different version of the websocket server on the same port and still couldn’t connect. I am 69% sure this problem is with hifi and not my server, although I am able to connect to echo server as well.

I am going to compile this and run it on another server and see if it still happens (just to make sure something is not keeping the port closed).


#31

Well, it is working for me again. I really don’t know why it is doing this. It’s possible it is because the script is hammering the server to connect so I set the retry to 30 seconds (instead of 10).

I tried adding your IP to the whitelist (assuming yours is the one starting with 162) and that didn’t work either. It’s still probable it has something to do with hifi.

I do have session resumes disabled so for those of you who fail to reconnect, that is why. But it only happens if you restart the software. I need to give an error message when this happens so you know what you are waiting for.


#32

update to 1.0.0.4

  • Fixed a bug that would prevent the entire global userlist from displaying properly.
  • Session resumes now work. You no longer have to wait for your ghost to timeout to log in again.
  • logging in users now disconnect properly when there is an error
  • Fixed a bug that would screw things up when more than one user was logged in at a time (Thanks to @Ai_Austin and @Richardus.Raymaker for helping to spot this one whether they knowingly helped or not).

#33

Glad I was of assistance without knowing it @Cracker_Hax

On a test just now I cannot see the global user list at all now, though it did show yesterday. The global online user list does shows in the usual HiFi lower left tool.

And I am still not able to connect, I just get “connecting…” every 10 seconds or so, and “Not Connected” if I type something in the chat line.


#34

Yeah it doesn’t show global users until you are connected now. Do you think it should? I am trying to avoid hammering globalservices too much, as I don’t want it blocking craxim users.

Hopefully we can get these hifi websocket issues fixed.

I see some of the buttons hang off yoru window too… I need to make icons for those. The window size depends on the width of your screen, maybe that should be changed too.


#35

update to 1.0.0.5

  • Changed “global” and “domain” buttons to icons indicating global or domain chat selection
  • friends list window was based on interface window size, this has been removed and window now has the same size for everybody (at least until window resizing is implemented).


#36

Shame, words many times more clear then icon. best combination is word + icon. It’s already all so tiny to read. need to check how tiny the icons are. icons, seems fine, it’s only a guess what icon is doing what.

Really missing a minimize button.


#37

Hopefully the resolution of the consumer Oculus Rift is better than DK1 and DK2.

**edit: From googling around I have found the consumer rift will have the same resolution as DK2. Are you using a DK2 Richard?


#38

@Cracker_Hax … that’s odd, as I don’t think I have properly connected yet… but maybe I was partially getting connected, as yesterday and in earlier tests it showed the list of online users when I selected global… same list as Hifi tool in bottom left. But all greyed out. See the snapshot higher up in this thread.

Whereas on test today there was no users at all in the list when global was selected. See snapshot less high up in this thread.

If its done through a different mechanism I would lave the presence lists showing independent of connection for chat interchange. That’s adds context and can eventually replace the (non-scalable) hifi user list mechanism.

For me presence indication, friends lists, text chat, online and offline IM are all very much in the same ball park and need one good tool I would say Jabber/XMPP does it right, links to other tools easily, is extensible and is based in standards.


#39

Sorry bro, gonna have to play trump card here.
CV1 will be a much higher resolution than the DK2, and uses 2 screens not 1.


#40

DK1 - 1280 x 800, so 640 x 800 each eye
DK2 - 1920 x 1080, so 960 x 1080 each eye.
CV1 - (Binstock quote) 2160×1200 2-screens.
CV1 - (rumors) 2560 x 1440

The CV1,whichever of those high resolutions, requires some heavyweight graphics processing.

Most of the resolution issues are less about the resolution and much more about the optics. I wish Oculus woud have taken up Microsoft’s free offer of better lenses. Microsoft computed the complex lens shape needed to correct the optical aberration.Then again, maybe they did for the CV1.