Create mode in tablet not useable. Constant reload / flashing


#1

The create mode is not useable anymore.
As soon you open it. it start to flash withd elayes between it.
You also see the scroolbar is moving.

Look’s like it’s scrolling automatic down ever few seconds and then up again.

Edit, not sure if it’s because the reloading of the properties page. But i cannot turn grabbable off on the fences. No setting seems to change.

ADD: @Adrian I just did the test in Maker not have the problem there. just rezzed a simple cube on earth and the problem is back. It’s mabye soemthig on earth, not high fidelity

I go finish my sandbox server and test it on there.


#2

Works for me,is your model locked?


#3

The fence does not look locked in earth.
It also works normal on my sandbox. Must be soemthing in earth. @Adrian need to look at it i think.


#4

Yes I see the problem, clearly there is a problem, always a problem of some kind.
It is happening since this latest update. I have restarted server, still broken.
I have no idea what the cause is.
Hifi is broken and its not my fault, and I really dont know if I care anymore.

Tired and burned out, I will have a look tomorrow, does anybody else on a cloud domain have a similar issue?
@Judas are you not seeing the issue on Earth?


#5

I know that feeling of burned out very good @Adrian. I hit it almost every day again. So many broken software and so many old bugs that are still not fixed. Or just, to say it simple stupid choices.

Very frustrating if you want todo things for years.
Your at least not alone @adrian !


#6

tried it on earth its a bit jumpy but works
wheres mi house gone o.o


#7

Your house has been missing for a while now, I wasnt sure if you removed it but things just go missing at regular intervals, this has been hapening as long as I can remember.
Random items just suddenly dissapear for no reason, Twinks land (again), Richardus’s house and he replaced it recently, Alfs wheel, some random land pieces, the beta house has gone away twice in the last year, DrFrans house and untold other items just go poof. I have posted about it until I am blue in the face ages ago and nothing happened.


Almost every time I log in I have to replace a missing piece or two, I havent had time for the last few months and the result is holes all over the city, bits of land, roads, buildings, signs, gone and never return. I have replaced the roads time and time again, and they are locked and ungrabbable so its a Hifi bug without doubt, a bug that just seems to get ignored constantly. And thats not counting items of users that might go missing and they dont tell me, they just give up and walk away in disgust.
And thats just one problem of many. Audio volume changes itself, primatives go back to red of their own accord, Things move themselves by a few milimeters and wreck a carefully set up placement, The whole domain goes black for no reason. (dont get me started)
@Judas If you want your house back there I ask you to please replace it because I dont have a copy of it.

This problem of the edit window not knowing if its an model or a box or a light has happened before and I discovered it was due to trying to select an object further away than your search radius, but this latest bug happens no matter what.

My only hope is that other people see the issue too and complain then maybe it will get some attention.
I will reload a backup models file, replace the missing parts :roll_eyes: again, place a bug report and dash forehead firmly against brick wall repeatedly to see if that helps.
issues


#8

Restarting domain, rebooting server, reloading recent backup makes no difference, I will try to describe the bug as best I can.

Selecting any entity causes the entity window to bounce regularly (every second) between a normal selection and a “no selection” making it impossible to edit properly.
please see gif for a visual https://i.gyazo.com/bf43776aa05007a67f77e7397d9491eb.gif
This only seems to happen on Earth (cloud domian) and I cannot replicate it on my localhost running the same models.gz file.

Please help. I can live with all the other issues but this one is a game killer.


#9

U should nag Caitlyn see if they will host it on one of their s3’s


#10

@Judas I’m not even sure the problem is with the hosting yet, I am waiting to see if anybody else is seeing the same thing especially anybody else using the cloud domain system.


#11

The problem is definitely in the edit script.
I have switched to using ctrlAltDavid’s edit script and there is no issue. I can move stuff around and edit easilly with Davids script.
I now recommend everybody on Earth use this script, it is great apart from an issue with locked/visible checkboxes which I have alerted David to.

http://ctrlaltstudio.com/downloads/hifi/scripts/edit.js

It will save a world of hurt until the hifi default edit thing gets fixed.

Ps/ AlphaVersionD has restored the London Eye and it is nice to see it back spinning in all its grandeur.
I will get around to replacing all the missing bits as soon as I can.


#12

I’ve fixed the properties checkboxes in my old edit.js script.

Details: http://ctrlaltstudio.com/hifi/archived/edit
Download: http://ctrlaltstudio.com/downloads/hifi/scripts/edit.js

UPDATING: If you’ve previously run the script, you’ll probably need to press the “reload” button for its entry in the Running Scripts dialog. The version number reported in Developer > Script Log window should be 0.4.4-82.
If you subsequently get an error dialog saying, “Entities Editor file version numbers don’t match”, you’ll need to manually clear your Interface cache: C:\Users\UserName\AppData\Local\High Fidelity\Interface\ directories \cache, \data8, \ktx_cache, \prepared.

P.S. I’ve been assigned the task of fixing the Create app.


#13

David has isolated the problem to objects being created and deleted.
In the case of Earth domain, the vehicle script I use to create traffic spawns a moving vehicle at random locations every second or so causing the edit panel to glitch every time an entity is created somewhere on the domain.
I have disabled the vehicle script to reduce the problems on earth, however the airplane script which is still running spawns a new plane every 2 minutes, so there is a glitch that happens every 2 minutes (Its not a game killer so I have left the airplane script running), if anybody has too much trouble with it I will disable this script also until the fix is deployed.
I am trying to replace the roads but another issue (X and Z drag also moves Y) as posted (again) on the bugs thread, is making this a very difficult job. Instead of just drag copying a new piece of road, now I also have to fix the Y position because it moves itself up 100mm every time.