Creating and rigging an avatar with Blendshapes in Makehuman


#1

Last week we spoke about getting avatars from Makehuman into High Fidelity with Blendshapes. I have spent the last couple of days working out how to do it and have had a lot of success. I am now passing the torch for you all to take it to the next level. Here are the links you need.

What I need from you!!

  • Fix up the Eyes and skin
  • Tighten up the Blendshape parameters
  • Get some great avatars up on the marketplace

Here is the video:

Check it out
Big thnaks to Ariana Alexander for the help:


Resource to describe optimal flow from makehuman to highfidelity?
MakeHuman to Blender to High Fidelity ATP
#2

This topic is now pinned. It will appear at the top of its category until it is either unpinned by a moderator, or the Clear Pin button is pressed.


#3

@chris Thanks for this video, it will allow some content creators to get started

I have some comments from what I’ve looked that add to this:

  • Eyes require bones exporting that are pointing on the Z axis (in
    Blender) (The Y normal faces up, while the Z normal faces front/Y) So youd have to tweak the make-human skeleton slightly by moving the eye bones.
  • You can streamline the exporting without having to touch the FBX
    Converter by using the Blender Exporter’s Path Mode set to
    Copy and Embed Textures. But prior to this the textures can be resized with the process you showed in the video.

#4

Challenge accepted! I’ll see if I have luck with this in the coming week. Thanks @chris and everyone else working hard to streamline this process.


#5

@summer4me… you may be interested in checking this out


#6

Looks like the textures are going to be fixed with this PR: https://github.com/highfidelity/hifi/pull/4657

Check it out

Thanks for your input @Menithal . I also have no idea why the MakeHuman avatars do not have the ability to blink. Any ideas?


#7

@chris I looked through the export blends and its missing the eye lids blinks (so its missing EyeBlink_L / EyeBlink_R to have the blinking action

Also its a good idea when adjusting the eyes with X axis mirror enabled via the side bar of options> x-axis mirror when editing the bones. Mostly to avoid abit of a lazy-eye effect :slight_smile:


#8

@Menithal in the output of the blendshapes there is no eyelid blend that I could find.


#9

This is great @chris wow!


#10

Tried this - it was going well until i managed to fry interface on Windows 8.1. I presume something in the fst file created an unexpected error? Where can i learn more about associating joints in the proper order and fst files?


#11

@Hiro wtach this part of the video


#12

This process has become so incredibly intuitive since last year, I find it utterly incredible that our initial founders find the strength to shrug off the nay-sayers.

Last year I began working in 3d again, and decided to try importing mesh avatars into SL via different pipelines. That process ended in much frustration and wasted man hours.

I understand we aren’t comparing apples-to-apples here… but WOW!

A process that took me 16 hours in SL; I just did in 16 MINUTES using the combined pipeline of @chris and @Judas.

The original team should be very happy and take great pride with their work; if I was on the fence about jumping ship, this demonstration today has sealed the deal. I’m on board, and I’m not going back. :smile:


#13

OK, what am I doing wrong? I downloaded Makehuman. I already had the latest Blender. I downloaded the addons. I put the export MHX into MakehumanExchange into Makehuman, and the Import Add on in Blender, enabled Auto Run Python Scripts in Blender.

I created an avatar in MakeHuman, exported it to my documents file. I can see it in Windows Explorer, but Blender doesn’t see it when I try to Import MHX? Any ideas what I need to do? Thanks.


#14

Greetings good Dr.

I am currently conducting a more in-depth write up on the process over on http://captainoculus.com

In the meantime, can you confirm you have both the .mhx AND .mhx2 addons for Blender? Also, I do not follow the instruction set of chris or Judas 1:1, my process requires a combination of both… also, I will need to integrate the amazing work of @Menithal to get proper blendshapes.

One thing is for sure, when it ‘clicks’ it’s a magical thing. No more nude avatars for me! :smile:

Keep patient, I’ll have the write up finished sometime later today. Thanks, -Capt.O


#15

Bless you. That was it. I was putting the add on in the WRONG folder in the new Blender. I appreciate your help. Thanks, and onward. :slight_smile:


#16

WONDERFUL!

Also, when @chris mentioned he re-opens the fresh .fbx and switches the materials to Phong and re-exports, I can’t figure out why this happens… well, neither can I. o.O

Just make sure you grab his custom .fst file, copy it, rename it, open it and modify it for your model. This step is super important or the system wont find it post-upload.

I’m going to try to stay pretty busy today and seeing as you’ve got your issue figured out; I may not finish the article until tomorrow.

Happy Weekend Alphas!


#17

@DrFranny when you go into blender import do you see:

If not, when you go to User Preferences in Blender do you see the ability to enable mhx2?

If you do not see it in your user preferences addons then you have not put it into blender correctly.

Make sure you are following these steps:

https://bitbucket.org/ThomasMakeHuman/mhx2-makehuman-exchange


#18

my shapekeys explode when i try this still figuring out why (seems to break if i add in the clothes)


#19

mine too, it’s kind of cool. I will play until I get this.


#20

Thanks, Chris. I think I have gotten this part sorted, at least. Now…where’s that .fst?. :slight_smile: