Creating collision shapes within Blender


#1

Hi,

I put together a video showing you how to create collision shapes in Blender. There are many settings you can use and I have not tried them all. Here is the video tutorial:

Here is the train model: https://s3.amazonaws.com/hifi-public/marketplace/hificontent/Architecture/sandbox/demo/Trains.fbx

And the convex hull created: https://s3.amazonaws.com/hifi-public/marketplace/hificontent/Architecture/sandbox/demo/train.obj

More detail on getting V-HACD 2.2 going (Advanced: you need OpenCL)


#2

Ooh looks cool I shall give that a go
V-HACD Code: https://code.google.com/p/v-hacd/sour

oh happy birthday @chris :stuck_out_tongue:


#3

It is the same tool that we are using within our code base, with some modifications. Thanks for the birthday wish.


#4

tadaaaa idiot proof :slight_smile:


#5

@judas, mabye idiote proof. Not me proof :smile:

Spacebar -> Hierarchical Approximate Convex Decomposition

@judas, using it seems foolproof. Installing the plugin not. First i where missing some microsoft run time. After that i could finaly install the add-on. But still generate a error.

Uhmm, not see anything wrong or option to point to filepath.

Cannot test it right now.


#6

Volumetric Hierarchical Approximate Convex Decomposition
explanation an idiot like me will understand

If u stick a ring doughnut in a clingfilm that’s like a convex hull shape.
so if u do that with a ring doughnut u loose the hole in the middle of the doughnut
what this prog does is slice up the doughnut into lots of chunks then pops the individual parts into lots of clingfilm so u get the hole back.when u jigsaw the chunks back together.

english to american translation clingfilm=ceramwrap


#7

I understand how it works. but i don’;t get it working. because the pluging fails to find some file. just removed the add-on and did it again same result as i posted above.

Feels, noob :open_mouth: Watching the downloaded video (better quality) and i forgot to set the path. just like it’s screaming all the time to me. Let em try it again.

Back to noob mode :stuck_out_tongue:
When i set the pad it works, but i get another error. No Meshes to process
Anyway, when you close bledner the path setting is gone to. possible need to save the settings. But first need to find the mesh problem.


#8

download the zip file chris linked 2
install the python script

this part is looking for the things in the bin folder which is also in the zip file,

u knew what Volumetric Hierarchical Approximate Convex Decomposition was? i had no idea i had to google it , then Google didn’t know so i asked Kevin he didn’t know but hes friends with this spiritual guru goat , he taught to me the meaning in a protracted dream sequence


#9

Done that, offcorse it get lost after every restart of blender. i need to look at this later closer. doing 1 thing wrong somewhere.

It’s not holding and saving the path to the exe. so after i have add the path i do restart and the path seems gone. Something weird with that add-on.

Checking i tomorrow when system is restarted again. then i know for sure the runtime is complete active too.


#10

i think once u know where your storing the bin file you can edit that location into the blender python script
easily vhacd_path
damn im starting to sound like @thoys


#11

@judas, no your not thoys. just checked it. but not so easy to replace it. then say it. Nah, i need to look at relaxed time.

Add:

@chris , Path V-hacd is still not saved. when i read the path it still created the error “No Meshes to process” This on windows 10 64bit. Add-on seems to be installed correct. unless the 64bit windows version of V-hacd is just bad.

Hmm, on the console this error canm be intressting.

:\Software\Blender’ is not recognized as an internal or external command, operable program or batch file.

Blames windows 10 for breaking something. or …this error happens when i start blender from the console and try to gernerate the convex.


#12

@chris

It would be good if we had away to view the collision shapes in world


#13

Yes, there was a menu that allowed this. It just needs someone to go in and fix it back great: https://worklist.net/20647


#14

@Richardus.Raymaker you must not be putting the link in correctly. Watch the video again. The video is just using a standard package, I did not make any special modification to it.


#15

The link seems correct, i know why it dissapears. if you load old blender project. you need to set the path manual first again for that project.

But still “No meshes to process” error. And that one i don’t see. did test with a simple cube. and i get already this error.


#16

I have updated the details above with more links. Also when you’re getting errors look at the log output and see what it is saying.


#17

Then i have one question. not figured out how to open the python cnsole in windows with blender. SO cannot really look good at the output.


#18

Hi @Richardus.Raymaker, I googled it “(Window > Toggle System Console) .” . To be clear, I am a Blender beginner.


#19

Like we discussed at the meeting hit space bar and type console, or anything you cant find and it should pop up


#20

Sorry judas, voice is not always the best medium to explain things. i did missed that part, not heared it. or just not did understadn it.

Going to check it. !