Currently absent MyAvatar.overrideAnimation () function


#1

Those who saw my avatar at this most recent meeting most likely noted that I am no longer able to call my custom animations. @Menithal you’d said you’d look at my use of the function. If I enter this into console as :
MyAvatar.overrideAnimation(“http://blackbear.dnsalias.com/public/a_horse_white04.fbx”, 30, true, 340, 800)
I get a return response “undefined” . Can I assume that this function is currently null and awaiting work from the team?

The animations contained in those frames, defined above, use the standard bones so using them, if they worked, wouldn’t harm your avi, only contort it into a horse shape at idle. The file will remain so that anyone may try this out, but currently I am unable to call those animations from my resources url.

If the functions are being worked on it might be that I can point to the animation graph soon. Info on the status of this would be appreciated. I am sure anyone using custom animations and/or custom models will be interested in following the progress of these related functions.


#2

From the interface console I listed all the methods for MyAvatar:
Object.getOwnPropertyNames(MyAvatar);

…and overrideAnimation is there.
overrideAnimation(QString,float,bool,float,float)

I did this on the latest beta version of interface. Though the method returns ‘undefined’ it does work for the clap anim: http://hifi-production.s3.amazonaws.com/tutorials/avatarAnimation/clap.fbx

It did not work for your horse animation but then again when I tried to do a get using that URL I got a 404. My guess, misspelled or it’s not on that server?


#3

The server host what updating and therefore the resource was not available. I am informed it will be available sometime this evening. As soon as I can get to the computer I will try it again. I thought it was working since I was also drawing my avatar from the resource server. I have another animation set I can point to if that one is not present. Thanks, I’ll let you know what I get.


#4

I forgot to mention that the error returned on an unimplemented method is a type error:
eg. MyAvatar.fooBar();
TypeError: Result of expression ‘MyAvatar.fooBar’ [undefined] is not a function.


#5

Thanks Balpien! My error, while my avatar was available the animation reference was not until the host had returned things to operational. It was a surprise to see this function suddenly stop but the idea that the avatar was present and the animations not, was unexpected.