Custom avatar appears, then disappears


#1

I am very close to having my first custom avatar in HiFi, but I am running into the same issue this person did a year ago.

When I import my avatar, the avatar appears correctly for a second, albeit untextured. It appears to assume its animation pose properly for a split second (if I’m in the air, flying, the avatar correctly deforms and assumes a flying pose) However, it disappears instantly after that. The log shows the following:

[12/14 17:47:50] [WARNING] [hifi.interface] Invalid display name position (nan, nan, nan), setting is to (0.0f, 0.5f, 0.0f)
[12/14 17:47:50] [WARNING] [hifi.interface] Invalid display name position (nan, nan, nan), setting is to (0.0f, 0.5f, 0.0f)
[12/14 17:47:50] [WARNING] [hifi.interface] Invalid display name position (nan, nan, nan), setting is to (0.0f, 0.5f, 0.0f)
[12/14 17:47:50] [WARNING] [hifi.interface] Invalid display name position (nan, nan, nan), setting is to (0.0f, 0.5f, 0.0f)
[12/14 17:47:50] [WARNING] [hifi.interface] Invalid display name position (nan, nan, nan), setting is to (0.0f, 0.5f, 0.0f)
[12/14 17:47:50] [WARNING] [hifi.interface] Invalid display name position (nan, nan, nan), setting is to (0.0f, 0.5f, 0.0f)
[12/14 17:47:50] [WARNING] [hifi.interface] Invalid display name position (nan, nan, nan), setting is to (0.0f, 0.5f, 0.0f)
[12/14 17:47:50] [WARNING] [hifi.interface] Invalid display name position (nan, nan, nan), setting is to (0.0f, 0.5f, 0.0f)

Hundreds of these nan messages keep appearing, endlessly. It seems to be stuck in an endless loop

To make my custom avatar, I used the Being of Light as a template (using its skeleton and FST file), then I exported my new avatar from Blender. I’m not sure what could be the problem.

Help would be really appreciated. P.S. I am running whatever version of HiFi that Steam has (v5782), if that matters.


#2

The scale needs to be 0.01. B4 exporting from blender. If u search the forum for that number u should find more detail


#3

Unfortunately I already tried that (on both the armature + mesh, as well as separately), and it didn’t fix it. I also tried the “rotate 90 degrees on X axis” suggestion. No difference :confused:

I’m wondering if this has something to do with the Units settings I have in Blender. I have it set to Metric, and Meters. Does that make a difference?

I’ve followed pretty much every guideline in the Ultimate Blender Compendium thread.


#4

units no, tricky to problem solve playing guess the workflow
Made a blender ava in 2.78a rigged it in mixamo last week the scale thing was the only quirky bit
assumes u packaged it in hifi


#5

Why does it look loke the numbers are in hex ? since when does high fidelity hex ? and why is it complaining about invalid display name position ? I get the idea that am smell a bug.


#6

I can replicate this guys workflow almost identically. This is a perfect description of what was happening when I attempted to use the Bastoni Blender Plugin to make an avatar for High Fidelity. I never did manage to get it to work after 12 iterations.
Things I tried:

  • changing the root bone (removed the one between the stance)
  • fixing the ‘rest’ pose in Blender to be a T-Pose
  • attempting the 90/0/-90 nonsense
  • Scale methond a la @Menithal

I have reason to believe there might be something wonky with the skeleton, and I’ve done avatars in HF before so I’m kinda wondering what’s up.

Oh hey! This month marks my original 2 year ‘entry date’ to Interface, you helped me import my very first ‘head-only’ model to the original web-share; do you think you could take a crack at the Bastoni > Blender > HF workflow? Again, I gave up after about 12 attempts… :confused:

Thaaaaaaanks. :smiley:


#7

…indeed; if you (or anyone) attempts the Bastoni Blender Plugin workflow and gets the process ‘wrong’, in my experience I would end up with a hard-lock crash of Interface with no bug submit page. o.O

This was analogous to my experience building another custom avatar that had bone-configuration-counts miss configured.

Skeletons are VERY specific for use as an avatar here, despite our best attempts at making them open. This is a reflection of the default animations making assumptions about bone-counts, and things like the “display name” attempting to place a nametag upon a bone that has no numerical equivalent… Not a Number or NaN for short.


#8

If ur not using the mixamo rig ur own your own

shouts Quaternions and runs away


#9


#10

Heya,
I think I need to make a bot for this.
But if you have a blender issue, I suggest taking a peek at my thread on everything Blender, including Avatar Creation:

Invalid display name position (nan, nan, nan), setting is to (0.0f, 0.5f, 0.0f)

Sounds either that:
A. You are missing a Head
B. You havent re-packaged the avatar and are not using the fst file

It appearing and dissapearing usually means the skeleton in the fst file is missing and not defined correctly. Defining (repackaging the fbx) it properly should fix the issue.


#11


package model is that thing - it puts the fbx and textures all together with an fst file that makes it work in hifi


#12

I appreciate the help, thank you all for the suggestions. However I already did repackage it through the Interface. Sadly it didn’t help :cry: And the model does have a Head. Is there something special to it I need to do? Right now it’s just rigged to the Head bone like any other model. The top of the head is also rigged to the HeadTop_End bone.

UPDATE: Well I managed to get rid of the Nan error. It appears that Blender was adding a root bone of its own upon export (with the same name as the armature in Blender), so I set the jointRoot to that extra bone and it made the Nan message go away. I had previously made my own “root” bone and I was setting the jointRoot to that one, as that was what the Ultimate Blender Compendium thread suggested (in my case, that didn’t work). However, although the Nan message is gone, my avatar is still completely invisible and now doesn’t appear at all, not even for a split second like it did before. Not sure if I’ve made progress or made it worse :stuck_out_tongue:


#13

ooh its an ascii fbx blender says no needs to be binary
I dragged it into maya which will open those

thats not a mixamo rig and its lost the textures

I think get the textures back on it in whatever u made it in then put it in the mixamo auto rig


#14

I’ve been using binary FBX mostly. You just happened to download the FBX while I was in the middle of trying a ASCII version just now. Sorry XD

I’ve ran the model through Mixamo.com’s re-mapper. Is that what you’re talking about? Never mind I get what you’re saying, I’ll try uploading it without a skeleton and rigging it entirely through Mixamo.


#15

this thing
https://www.mixamo.com/auto-rigger


#16

Alright, I used the auto-rigger on it. The resulting armature ends up with the same bone names as the previous skeleton I was already using (Being of Light armature) except the auto-rigged one simply has “mixamorig:” appended to the beginning of every bone name.

The weightpaint of the autorig is also really hilariously bad and totally unacceptable. It’s nowhere as nice as my own manual weight painting job. I can fix those messed-up weights in Blender but then I’m back at square 1 - I’ll have to export this new auto-rigged model from Blender after fixing the weights, and I’ll end up running into the same problem as before with HiFi not liking my Blender-exported FBX.

Honestly, I really don’t think a third-party website like Mixamo should be required or necessary for the avatar pipeline in the first place. Mixamo or Adobe could one day shut down their services or make them pay-only. I’ve used lots of game engines - Unreal, Unity, Source Engine, Second Life/OpenSim - none of them have a process this convoluted. I know it’s a beta, though. I think I might just have to wait until HiFi improves its Blender import pipeline. It shouldn’t be this difficult to get an avatar into the engine.

On a related note, I think adding .DAE support to HiFi for avatar imports, in addition to .FBX, would probably help a lot. Blender’s FBX export functionality has always been terrible. For a long time you couldn’t even import a Blender-exported FBX, into Blender (which made no sense). Blender’s always worked pretty well with DAE though.


#17

agrees completely…


#18

It isn’t required. It is a speed-assist. See also custom-rigged "Angry Stacy"

You might be waiting a VERY long time…

…but we’ll still be here when you get back. :blush:


#19

well yap the bone names arent required either, but u have to link ur bone to their bone name if u wanna use it as an ava


#20

Hey,

I finally got to around to checking your post again
What version of Blender are you using? FBX export got alot better after 2.75,.

In anycase, I actually suggest not using mixamo.
Doing any modifications in Blender to it will just be headache inducing. Doing the rigging in Blender, even if complex will save you from a whole bunch of headache later on if you decide to do mods to the outputted avatar.

Use the template skeleton I made, as it has the naming convention down, among other things to make your life easier.

This workflow takes only about 5 minutes if you are familiar with blender controls. more if you want to refine it like crazy. I tried to slow down a bit and show how to do it, so below is a 10 min video on how to do it.

Ill have a refined version of this tutorial, now that I have a few weeks of free time :slight_smile:

And @Judas, @AlphaVersionD I suggest not suggesting people to hop on to Mixamo as a workflow tool, It makes things more complicated, especially as soon as anyone wants to do modifications to the rigged avatar it outputs: the mixamo bone prefix is a whole lot of erasing.

We also do not know how much longer that service will stay up.