Dec 19 2015 Ubuntu 14.04.3LTS cmake errors


#1

I try to compile Hifi at an Ubuntu 14.04.3LTS server, but It does not works. I get the following messages:

<
Could NOT find LeapMotion (missing:  LEAPMOTION_INCLUDE_DIRS LEAPMOTION_LIBRARIES)

CMake Warning at /usr/local/Qt-5.5.1/lib/cmake/Qt5/Qt5Config.cmake:26 (find_package):
  Could not find a package configuration file provided by “Qt5WebEngine” with
  any of the following names:

Qt5WebEngineConfig.cmake
    qt5webengine-config.cmake

Add the installation prefix of “Qt5WebEngine” to CMAKE_PREFIX_PATH or set
  “Qt5WebEngine_DIR” to a directory containing one of the above files.  If
  “Qt5WebEngine” provides a separate development package or SDK, be sure it
  has been installed.
Call Stack (most recent call first):
  interface/CMakeLists.txt:48 (find_package)

CMake Warning at /usr/local/Qt-5.5.1/lib/cmake/Qt5/Qt5Config.cmake:26 (find_package):
  Could not find a package configuration file provided by
  “Qt5WebEngineWidgets” with any of the following names:

Qt5WebEngineWidgetsConfig.cmake
    qt5webenginewidgets-config.cmake

Add the installation prefix of “Qt5WebEngineWidgets” to CMAKE_PREFIX_PATH
  or set “Qt5WebEngineWidgets_DIR” to a directory containing one of the above
  files.  If “Qt5WebEngineWidgets” provides a separate development package or
  SDK, be sure it has been installed.
Call Stack (most recent call first):
  interface/CMakeLists.txt:48 (find_package)
/>

  • QT_CMAKE_PREFIX_PATH is set
  • LEAPMOTION_INCLUDE_DIRS and LEAPMOTION_LIBRARIES are not set,
    with echo $LEAPMOTION_INCLUDE_DIRS and echo $LEAPMOTION_LIBRARIES you get an empty output
  • in the directory "/usr/local/Qt-5.5.1/lib/cmake there are not directories for Qt5WebEngine and Qt5WebEngineWidgets

The Compiling follows the steps, like Coal has declared it here:
https://alphas.highfidelity.io/t/basic-outline-only-how-to-compile-hifi-in-ubuntu-14-04-again/9010

Is the command “apt-get install qt cmake gcc-4.9…” not completely? How should it be completed?


#2

sighs I wanted to deal during the holidays in order to create a terrain and plants. But I can it safely forgotten. The developers are sure all already on vacation. What is of course quite normal. I wish you all a peaceful Christmas and a happy new year.

But I had twice now problems compiling with new dependencies. Is it not possible to take into account the dependencies in the cmake scripts?

This sequence par example:

apt-get install software-properties-common

add-apt-repository “deb http://hifi-debian-repo.s3.amazonaws.com/ stable main”

add-apt-repository ppa:george-edison55/cmake-3.x

add-apt-repository ppa:ubuntu-toolchain-r/test

apt-get update

apt-get install qt cmake gcc-4.9 g+±4.9 build-essential git zlib1g-dev libssl-dev libstdc++6 freeglut3 freeglut3-dev mesa-common-dev libxrandr-dev libudev-dev libxslt1.1 libpulse0 libgstreamer0.10-0 libgstreamer-plugins-base0.10-0 libicu52 libxcomposite1 libtbb2 libsoxr0 -y --force-yes

update-alternatives --install /usr/bin/gcc gcc /usr/bin/gcc-4.9 60 --slave /usr/bin/g++ g++ /usr/bin/g+±4.9

echo QT_CMAKE_PREFIX_PATH=/usr/local/Qt-5.5.1/lib/cmake/ >> /etc/environment


#3

Hi @JuelsDreki can you look to get QT from the QT website, install the home directory and set the path

export QT_CMAKE_PREFIX_PATH=/home/[user]/Qt/5.5/gcc_64/lib/cmake/


#4

My last break was due to personal reasons and by ubuntu substitutions. But slowly I understand “summerforme…” which is apparently frustrated about the compiling recurring problems too.

Ok, we are in alpha stage. Many things can change. But you need content. We want create and test contents, but it must be ensured, that you can compile Hifi. Errors always happen, which is human. For this reason, there are the alpha and beta status. But obviously nonfunctioning things to look for in a repository nothing.


#5

Upps. Chris, your answer was send, while I last wrote. It it is to late today. I try it in next day. bye.


#6

Ok, I now have a deep breath. What I do not understand, Hifi should be an open system. Would Linux because not the first choice as a domain server? I do not remember where. But I still have in mind the linux is no official operating system of Hifi. Provides Linux binaries and for many the problems have done.

I am embedded software developers. But Hifi is a very complex project. I do not know Qt and its dependencies from the development. So a library like Qt I would use only under very big constraint. :wink:


#7

Hi @JuelsDreki we have put a new PR up that removes QtWebengine as a requirement on the server. We use Linux for all our servers.

https://alphas.highfidelity.io/t/nov-29-2015-ubuntu-15-cmake-build-errors/9811/50

Chris


#8

But to be clear - in order for it to work you have to manually edit a cmake file so you can compile server components. See;


#9

I’ll see if I can add in a CMake command line flag so you don’t need to edit the cmake files, you can just specify on the command line to build server-only components.


#10

It should be possible to run CMake with a -DSERVER_ONLY=TRUE command line options and skip the dependencies brought in by the new UI code.


#11

Thank you very much @Jherico will test this later today.


#12

Works as expected, thank you again @Jherico


#13

@Jherico
The server building does works with the command “cmake … -DSERVER_ONLY=TRUE!”

Thank you very much and a peaceful christmas and a happy new year!


#14

Got the exact same error building interface on windows 10 visual studio 14

environment variable QT_CMAKE_PREFIX_PATH is set to C:\Qt\5.5\mingw492_32\lib\cmake
tried setting CMAKE_PREFIX_PATH is set to C:\Qt\5.5\mingw492_32\lib\cmake as well.
I looked around in the qt cmake lib files and there is no qt5webengineconfig.cmake file.


#15

@Cracker_Hax
But I compile the Hifi server at Linux. :wink:

And the old Path exists. Must I change this path at Linux too?

echo QT_CMAKE_PREFIX_PATH=/usr/local/Qt-5.5.1/lib/cmake/ >> /etc/environment


#16

You shouldn’t have to if you’re only building server.


#17

@Cracker_Hax
Ok. Thank you.


#18

I have updated my post to include the new SERVER_ONLY flag. Thanks for adding it @Jherico