Desktop interface start in HMD mode if no config file available


#1

Another bug.
If there’s no config file. and you start high fidelity in desktop mode and not have steamVR running. It still start in HMD mode. Possible to blame because high fidelity is starting without permission also hidden steamVR


#2

If there’s an HMD attached to system, or its supporting software is present, on first run (no config file) Interface starts in HMD mode by default. So, not bug – feature.


#3

A bug, you want it default in desktop mode if you start it from the desktop.
Especially if steamVR is not running.

Thats problem with Hifi, it thinks to much for the user and is doing things against settings users made. Starting STeamVR in the background hidden and not doing a correct shutdown of that when you close interface. One of the things that make VR complete useless to use with voice.


#4

I may or may not agree with it starting in Desktop or HMD on first run (no config), but, it’s not a bug. It’s how HiFi wants it – we had to QA Test the specific behavior and that is intent - prefer HMD over desktop mode on first run if HMD is available. After that - you can switch to desktop and, unless you remove settings or reset, it will then start as you want.


#5

Ok. Not good ! More i do not say.


#6

This is one of the results of the bad implementation of the hidden startup of steamVR when the user did say NO ! Because if orgot to start steam i did it later then high fidelty started.

Big fail. The person that where thinking to start steamVR always. hmm

Time to get the gun and kill steamVR again manual. Because the bug in high fidelity that does not close steamVR when yu close interface.exe. the biggest bug is that it’s starting something against the users preference.

It’s a bug, it will keep a bug until fixt !