Disable edit mode automatic when you press the (X) from the edit window


#1

I do not get used to this straneg flow. It happens many times that i press the (x) in the edit window. the window close. but edit mode keeps enabled.

To get the edit winmdow back, you first need to press twice the edit button at the bottom ? What is the use to keep edit mode open after you closed the edit propertioes window ? Because you cannot reopen that window.

So my suggestion is when you close the edit properties window, close edit mode automatic too. It’s less confusing. Or mabye there’s a better way i not see right now.


Edit.js windows press [X] minimize window. Do not close!
#2

I’m fairly certain this isn’t new behavior. You can also get the window back from the menu by selecting ‘Edit->Entities List’


#3

It’s old behavior, and in this case I find the current behavior is OK. I often close the edit window just to get it out of the way when I am manipulating edited entities then open it again when making property changes.

I suppose it would be nice if when the edit window is closed that clicking on the edit icon would reveal the window, but I suspect that’s a zero-sum game in terms of who would like/dislike that new behavior.


#4

It’s not new, but i always where hoping to get used to it. That never worked. clicking the edit button twice is faster then.

It still is confusing if you cose that window edit keeps open, with the risk of spontanic actions on objects you not want because you forgot things are still in edit mode.


Edit window should close when you close it
#5

Same for me, I always klick the x to close the window, and expect it would reopen by just click ‘edit’ again. It would be much smarter and smother workflow, if the edit mode would get closed totally by klicking the x, or - the window would re-open by another 1 click on the edit button.

I also tried to find a hotkey to re-open the edit window, but there isn’t one, or?


#6

What Rich said, totally. The click response is slow and closing the window leaves an entity selected.

If you close the edit window you generally want it closed, not just hidden, why can’t we have it behave as expected and just close?


#7

I’m not entirely certain this is a good or better behavior. As I wrote before:
“It’s old behavior, and in this case I find the current behavior is OK. I often close the edit window just to get it out of the way when I am manipulating edited entities then open it again when making property changes.”

My biggest issue is that the super huge edit pane is almost always in the way. It has no minimize/restore button, which would have made getting it out of the ay so much easier. It is very difficult to resize the window because the overall UI is very 1980s - no side/top/bottom resizing - only only teensy bottom right resizer. So, because of all these deficiencies, none that I expect will get corrected soon if ever, I’d rather be able to at least close the damn window and continue editing.


#8

Valid reason, very good one.
But how can we make it clear and easy when edit is enabled but the window is closed. there’s no minimize and maximize window button. How it’s implemented right now is very annoying. Lucky i use most of the time ctrlaltdavid edit tool. that one is so suprior compared to high fidelity’s one.


#9

Much agreement. :smile_cat: