Disable OcculusRift support in compile?


#1
Settings thread started.
Asynchronously looking up IP address for hostname "stun.highfidelity.io" - lookup ID is 1
NodeList socket is listening on 56114
Changed socket "send" buffer size from 212992 to 212992 bytes
Changed socket "receive" buffer size from 212992 to 212992 bytes
Local socket is xxx.xxx.xxx.xxx:56114
Time zone: AEDT
[DEBUG] [04/03 11:23:17] [VERSION] Build sequence:  dev
[WARNING] [04/03 11:23:17] Couldn't open bookmarks file for reading
[DEBUG] [04/03 11:23:17] First call to Menu::getInstance() - initing menu.
[DEBUG] [04/03 11:23:17] AccountManager URL for authenticated requests has been changed to https://metaverse.highfidelity.com
[DEBUG] [04/03 11:23:17] Found a data-server access token for https://metaverse.highfidelity.com
[DEBUG] [04/03 11:23:17] Starting worker thread to generate 2048-bit RSA key-pair.
[DEBUG] [04/03 11:23:17] The default audio input device is "alsa_input.usb-C-Media_Electronics_Inc._USB_PnP_Sound_Device-00-Device.analog-mono"
[DEBUG] [04/03 11:23:17] The audio input device  "alsa_input.usb-C-Media_Electronics_Inc._USB_PnP_Sound_Device-00-Device.analog-mono" is available.
[DEBUG] [04/03 11:23:17] The format to be used for audio input is QAudioFormat(24000Hz, 16bit, channelCount=1, sampleType=SignedInt, byteOrder=LittleEndian, codec="audio/pcm")
[DEBUG] [04/03 11:23:17] No resampling required for audio input to match desired network format.
[DEBUG] [04/03 11:23:17] The default audio output device is "alsa_output.pci-0000_00_1b.0.analog-stereo"
[DEBUG] [04/03 11:23:17] The audio output device  "alsa_output.pci-0000_00_1b.0.analog-stereo" is available.
[DEBUG] [04/03 11:23:17] The format to be used for audio output is QAudioFormat(24000Hz, 16bit, channelCount=2, sampleType=SignedInt, byteOrder=LittleEndian, codec="audio/pcm")
[DEBUG] [04/03 11:23:17] No resampling required for network output to match actual output format.
[DEBUG] [04/03 11:23:17] Output Buffer capacity in frames:  3
[DEBUG] [04/03 11:23:17] Logging activity "launch"
[DEBUG] [04/03 11:23:17] Created Display Window.
[DEBUG] [04/03 11:23:17] GL Version:  "3.0 Mesa 10.4.2"
[DEBUG] [04/03 11:23:17] GL Shader Language Version:  "1.30"
[DEBUG] [04/03 11:23:17] GL Vendor:  "X.Org"
[DEBUG] [04/03 11:23:17] GL Renderer:  "Gallium 0.4 on AMD REDWOOD"
[DEBUG] [04/03 11:23:17] Initialized Display.
[DEBUG] [04/03 11:23:18] Oculus SDK 0.5.0.1
[DEBUG] [04/03 11:23:18] Logging activity "connected_device"
Error: [Context] Unable to obtain x11 visual from context
[DEBUG] [04/03 11:23:18] Trying to go to URL "hifi://elsewhere/513.031,513.997,520.311/1.50537e-06,0.0616676,-1.2756e-05,0.998097"
[DEBUG] [04/03 11:23:18] Loaded settings
[DEBUG] [04/03 11:23:18] Sending intial stun request to stun.highfidelity.io
[DEBUG] [04/03 11:23:18] init() complete.
[DEBUG] [04/03 11:23:18] Startup time: 9.27 seconds.
[DEBUG] [04/03 11:23:25] Overflowed ring buffer! Overwriting old data
[DEBUG] [04/03 11:24:59] Overflowed ring buffer! Overwriting old data
[DEBUG] [04/03 11:25:12] Overflowed ring buffer! Overwriting old data
[DEBUG] [04/03 11:25:50] Overflowed ring buffer! Overwriting old data

Just started with today’s git pull. Other than not having an output window, it seems to be running fine according to the console output, though top indicates it is running away and consuming a full CPU and the process has to be force-killed.

The relevant error is towards the bottom:

Error: [Context] Unable to obtain x11 visual from context

#2

My Google-fu is weak on this one, but the error may be a recently introduced bad interaction between MESA and OculusRift SDK.

Is there a compile flag or something I can use to remove OR support entirely (I can’t use one anyway)?


#3

Switching back to the proprietary AMD driver got past the LibOVR glitch.

At the expense of having to Ctrl-Alt-Esc kill a number of applications, including Interface and VLC which won’t exit without an explicit kill under that driver. (And the extra 200MB of source and associated compilers that the drivers drag into the system, of course).

The text rendering is fried under this driver, naturally:

:frowning:


#4

Nope. I can’t put up with AMD’s flakey official driver! Had to put the OSS one back on, which means no HiFi unless I can get libOVR out of the compile chain. :frowning:


#5

Well, I’m back up.

Had to dig out an old Nvidia 9600GT from deep storage, but the proprietary Nvidia driver is all good (as it tends to be).