Do not show mute spheres default when using people app


Please do not show the mute spheres default when youi open the people app. Because:

  1. It breaking the immersive world view.

  2. The draw priority is wrong. The bubbles have a higher priority then the tablet. The result is that all the spheres are on top of the tablet and it’s very hard to read the tablet because the block parts of the tablet.

  3. 99% of the time you not need the mute spheres. I have at least never used it so far. Most of the time you open the tablet people app to check other things or adjust volume etc.

  4. The eat system resources. It’s always noticeable when the spheres appear.

  5. The spheres not seems very functional if there 300 people around you, there are just to many spheres.

My suggestion is to keep the spheres default off and add a easy to click option to enable and disable the mute buttons. But always have them disabled by default when you open the
people app.


The other issue is the spheres are very high poly. I had voice spheres which used the same calls but I stopped using it due to the dip in framerate when there’s a large number of users around.