Domain-server.exe get deleted by avast


#1

I want to test some content, so what is more easy then run the sandbox local. Not that i like to run sandbox on client pc. But ok for testing.

Now the problem is that domain-server.exe is not really know by avast and mabye other virusscanners. So it get removed automatic. In other words, cannot run de sandbox on this system.

Not going to whitelist it.
It’s the version from HighFidelity-Beta-0.70.4.exe

image

Looking on verification options etc.


Other problem, what made me look in avast.
If i try to run sandbox from the shortcut.

image

There’s no server-console.exe instaled.
And i do not see it in the avast chest to.


Did install the complete back again with silent mode disabled on avast. It’s not reporting much helpfull information.

After saying “Move to chest” it’s blocking the instalelr i think.

So… now the whole installer is moved to the chest.
Moved file out of the chest and did a manualk scan that seems to have no issue’s.

Grrrr…

New round, it’s doing the same. It must be a false / Positive but i always take the safe side.

I can only install the client fine. Not the sandbox on this system.


#2

I’ve been banging my head against this one, too. I have to temporarily disable Avast! shield to let the installer finish, and then later I still get that dialog box at machine startup telling me domain-server.exe cannot be found. I’ve never actually set up a server for public access, with a customized location in it, so its still sporting whatever the default, local-only copy of the generic introduction to HiFi tutorial location thingy is… and where one’s original home position is set to, but I never go to my home position, I always park myself at Help or something before logging out, so the personal server isn’t something I need per say… but its still hugely stupid that Avast! keeps killing it, thinking its a malware, and this needs to stop, because plenty of people DO need that local server. oO

I’ve managed to whitelist the directory that domain-server.exe resides inside of, so I HOPE this has fixed the issue at my end, but the issue is one that should never have existed in the first place. oo


#3

Just installed 0.71 on my system, tried to install the sandbox again. The installation works (avast runs in silent mode)

After that i did run sandbox. Avast kciked in with cyber security but it did look to start fine.

Now i closed it and try to start it again and , it fails.
Checked the chest. and domain-server.exe is again in jail.

This not let me not test anything in high fidelity.
Except on maker that have strange lighting i think.


#4

Have you taken this approach?

It’s what I did.

edit: And just to be totally unambiguous: I whitelisted the folder that domain-server.exe resides in, and I haven’t had an issue since. My avatar is parked in my local sandbox server right now, staring at the Welcome to High Fidelity navigational tutorial video thingy in world.

In my case, the folder is C:\Program Files\High Fidelity\server-console\ *
(Take the space out that is between that last \ and the * because the message system wants to hide that last \ from it for some reason, tho it shows when I go to edit the message.)


#5

I hate it ti whitelist programs i have done it once for some other software. It’s not needed anymore there but it where way to long whitelisted.

Whitelisting is security risk.
So simple, no not going to try it to whitelist it on my main system. The fixed the problem long ago with interface. So why not with sandbox.

In good mood i can turn the server on. But to muvh work for quick try something.

Still strange that it start first time in cybersecurity fine. with a delay.