Dropping frame rate on ATP server with custom avatar


#1

Hi all,

came back after a while and tried to create a custom avatar. I used the predefined mixamo rig and parented it to a new skin in Blender. Somehow when I export the fbx to my local world streamed from atp server, the frame rate drops to about 2 frames per second , which is unworkable. When I stop the server, the frame rate returns to normal. Does anybody experience this too and possibly have a solution? The model is about 1 MB 15000 vertices which should work well.

Hifi Greets,

Basinsky


#2

It sounds more of an issue with the avatar scale than the atp, since atp’s purpose is just to host the file for within use in the domain:

Specifically there is a bug relating to incorrect scale, and the physics calculations going bonkers on your own end, causing your frames to drop.

Check that the custom avatar scale is correct.

Otherway you can test this is simply get the path to the fst and pointing to it directly from the hard drive, like

C:/Users/Menithal/Documents/Projects/High Fidelity/Avatars/MyAvatar.fst
(Note windows points with \ but you need to use / for it to work.)

which is handy to remember when testing / developing an avatar and quickens the pace in developing one. Just remember that this will not show to anyone else, until you upload it to a server. Also note that atp only applies for your own domain.


#3

Hi Menithal,

thanks for the reply. I took the scale from the avatar in the marketplace removed the skin, and parented my skin to it. I use a scale of 1 in the exporter of blender:
image
the scale in blender is 0.01:


I removed doubles, pointed normals outside, removed all materials. I pointed the fst to my local file. But still it doesn’t work.

This is on my local world:093. frames/sec

this is when I kill my server: 60 frames/sec

I tried getting an avatar from the marketplace opened it in Blender exported it. Uploaded it and used in on my server: It worked flawlessly. So the pipeline is not wrong. I think there something wrong with the mesh or the parenting but I cannot find what.I created the mesh with google Blocks can this be a problem? I even looked at the code for the model packager on github and saw that it looks for mixamo’s blend shapes to determine the avatar is a mixamo one. Can that be an issue?

Basinsky


#4

What is the scale of the mesh in the skeleton?

You only showed me the scale of the skeleton. The scale of the mesh must also be 0.01.

It still sounds like an issue with physics going haywire as its considered as “large” and colliding with all the objects in the scene (thus having high frame rate without anything and low frame rate when there is something. )


#5

Hi Menithal,

after some more testing, your idea of scale problems made me investigate more. The rig was scaled to 0.01. The mesh however was not! I rescaled it so it was 0.01 and uploaded the avatar. This did the trick. It is working now! Thanks for pointing me in the right direction.

Greetz,

Basinsky